<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" /><script type="text/javascript">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</script>
	<link rel="pingback" href="https://baltimore.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="maryland weather, maryland severe storms, fells point, fells point flooding," />
<meta name="keywords" content="maryland weather, maryland severe storms, fells point, fells point flooding," />
<meta property="fb:pages" content="261323008476" />
<meta name="facebook-domain-verification" content="iiv3w5z7llhkla8zlctcj5kqsjba3k" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>Fast-Moving Storms Cause Flash Flooding In Parts Of Baltimore Thursday Night &#8211; CBS Baltimore</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CBS Baltimore &raquo; Feed" href="https://baltimore.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Baltimore &raquo; Comments Feed" href="https://baltimore.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Baltimore &raquo; Fast-Moving Storms Cause Flash Flooding In Parts Of Baltimore Thursday Night Comments Feed" href="https://baltimore.cbslocal.com/2019/08/23/baltimore-flash-flooding-fells-point/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/_static/??-eJytj0sOwjAMRC9EMKWirBBnyceUqI4d5SOuT0jZsIJKrGyP/UZjeERlhQtygXLHgBmsyYrEagLPlqp7STnDTaRg2rd2Bz9BGAy6lY0JSbT7Dkeqs+cMQVylttFvg1a3w/1ABc16xtRtPhTVQi5F4oaXVo8aDGtPijwv/0+F1CYu/d9ruAynaTyep8MwPgF1gZ9T' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://baltimore.cbslocal.com/_static/??-eJyNy0sKgDAMANELWWMt1pV4lhqDCukHEhFvr72AuB3ewFUM5qSUFHSnSAK4iOGMgUH0ZmpRpIEvdiTkc61JBErYyCjFwkF/vHUhfmNSqXqOkx2860ffWfcAIb85Fg==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://baltimore.cbslocal.com/_static/??-eJydUu1uwjAMfKGFDMGQ+DHtWVLHKlmdOEpcqr793FaAWKVt3b/zx53PTuyQDXASTGLlghGrhaYaYnBkM/VtSNVG9j1pZW4w0SXXYrFQNTNmPO4UvdifhEIC6v2UUs4QPBrBmMkJ1o3k7Ir8gfPdeb1wEeCbyiPcMB5jg37hz9BQqGLAiSNuN66hWwQgNNfH8Z7qXqVto8ROpzTFldFWGQl3MaTt2+vFW5T79Se8Eom9udE+UbKDbkUXziZzVbR42exj/X+iK90kvfQDE5d/vO5vunzFMpQgs+WP+L5/O50Or+fzYf8F2hkg4w==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-external-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-8' href='https://baltimore.cbslocal.com/wp-content/mu-plugins/jetpack/css/jetpack.css?m=1565296053g' type='text/css' media='all' />
<script type='text/javascript' src='https://baltimore.cbslocal.com/_static/??-eJy1kEESwiAMRS8k0jrqzvEsCBFTQ6gltNPbix0XdmXrjKtA+P/lEz20ykYWYNFygwBJ20tSFK0hjWwpu9Jqkm4jjVck2gbkbZM2eqmxWeRoKXvkpEN0mcqLcZO5FNXvPgkz9CNDN77LV4EK6Dsj8FOeSaCCYeOhe6FnDVXm3SW2qxZzzWwFI6d/BAIqN5a0KpFxN0jYL9tQ0XuKF0PrRnSClmD1dwd0HmRCvI8FcQ6n+nDcV1VVV4fmCXWcCmc='></script>
<link rel='https://api.w.org/' href='https://baltimore.cbslocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://baltimore.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://baltimore.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://cbsloc.al/2ZpKcsY' />
<link rel="alternate" type="application/json+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2019%2F08%2F23%2Fbaltimore-flash-flooding-fells-point%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2019%2F08%2F23%2Fbaltimore-flash-flooding-fells-point%2F&#038;format=xml" />
			<meta property="fb:pages" content="" />
			
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="Fast-Moving Storms Cause Flash Flooding In Parts Of Baltimore Thursday Night" /><meta property="og:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Baltimore-Flooding.jpg?w=1208" /><meta property="og:image:secure_url" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Baltimore-Flooding.jpg?w=1208" /><meta property="og:image:width" content="1208" /><meta property="og:image:height" content="701" /><meta property="og:description" content="Fast-moving storms hit parts of Maryland hard Thursday night. " /><meta property="og:type" content="article" /><meta property="og:url" content="https://baltimore.cbslocal.com/2019/08/23/baltimore-flash-flooding-fells-point/" /><meta property="article:published_time" content="2019-08-23T17:35:51+00:00" /><meta property="article:suggested-social-copy" content="Fast-moving storms hit parts of Maryland hard Thursday night. " /><meta property="article:publisher" content="http://www.facebook.com/CBSBaltimore" /><meta property="article:author" content="http://www.facebook.com/CBSBaltimore" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Baltimore-Flooding.jpg?w=1208"><meta name="twitter:title" content="Fast-Moving Storms Cause Flash Flooding In Parts Of Baltimore Thursday Night"/><meta name="twitter:description" content="Fast-moving storms hit parts of Maryland hard Thursday night. "/><meta name="twitter:site" content="/wjz"/>
<link rel="canonical" href="https://baltimore.cbslocal.com/2019/08/23/baltimore-flash-flooding-fells-point/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://baltimore.cbslocal.com/2019/08/23/baltimore-flash-flooding-fells-point/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/baltimore.cbslocal.com","url":"https:\/\/baltimore.cbslocal.com","name":"CBS Baltimore","foundingDate":"1941-07-01T14:30:00+00:00","sameAs":"http:\/\/wjz.com","logo":{"@type":"ImageObject","url":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2018\/07\/3_baltimore_cbs13_wjz.png?w=258"}},"url":"https:\/\/baltimore.cbslocal.com\/2019\/08\/23\/baltimore-flash-flooding-fells-point\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/baltimore.cbslocal.com\/2019\/08\/23\/baltimore-flash-flooding-fells-point\/"},"headline":"Fast-Moving Storms Cause Flash Flooding In Parts Of Baltimore Thursday Night","description":"Fast-moving storms hit parts of Maryland hard Thursday night.\u00a0","image":{"@context":"https:\/\/schema.org","@type":"ImageObject","url":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2019\/08\/Baltimore-Flooding.jpg?w=150"},"keywords":["Baltimore City","Local","Maryland","Montgomery County","News","Seen On","Syndicated Local","Watch + Listen","Weather Stories","Baltimore","Baltimore News","Fells Point","Fells Point Flooding","Local TV","Maryland Severe Weather","Maryland Weather","Talkers","Rick Ritter","news","Fast-Moving Storms Cause Flash Flooding In Parts Of Baltimore Thursday Night"],"datePublished":"2019-08-23T17:35:51+00:00","dateModified":"2019-08-23T17:35:51+00:00","author":{"@type":"Person","name":"Rick Ritter"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"Fast-Moving Storms Hit Parts Of Maryland Thursday Night","description":"Fast-moving storms hit parts of Maryland hard Thursday night.\u00a0","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/captures\/BDD\/2C9\/BDD2C952CFDB4E478A9365E81A00DECB.jpg?Expires=1661207773&KeyName=mcpkey1&Signature=lta_YtyqAcCNOw45uPqAcaLuPdQ","uploadDate":"2019-08-23","duration":62,"contentUrl":"https:\/\/baltimore.cbslocal.com\/video\/4151814-fast-moving-storms-hit-parts-of-maryland-thursday-night\/","embedUrl":"https:\/\/baltimore.cbslocal.com\/video\/4151814-fast-moving-storms-hit-parts-of-maryland-thursday-night\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.BALTIMORE","news",["fastmovingstormscauseflashfloodinginpartsofbaltimorethursdaynight","post","article","baltimorecity","local","maryland","montgomerycounty","news","seenon","syndicatedlocal","watchlisten","weatherstories","baltimore","baltimorenews","fellspoint","fellspointflooding","localtv","marylandsevereweather","marylandweather","talkers","rickritter","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>
		<script type="text/javascript">
			var formatTracker,marketTracker,masterTracker,stationsTracker,rollupTracker,pageTracker;
			var cbs_evidon_noticecdn_id = "https:\/\/baltimore.cbslocal.com\/wp-content\/themes\/cbs-local\/files\/crownpeak\/sitenotice\/425";
			var cbs_evidon_noticecdn_sitenotice = "https:\/\/baltimore.cbslocal.com\/wp-content\/themes\/cbs-local\/files\/crownpeak\/sitenotice\/";
		</script>
		<script type="text/javascript">(function(id){
			function append(scriptid,url,async){var d=document,sn='script',f=d.getElementsByTagName(sn)[0];if(!f)f=d.head;var s=d.createElement(sn);s.async=!0;s.id=scriptid;s.src=url;f.parentNode.insertBefore(s,f)}
			function getRootDomain(){return 'cbslocal';}
			window.evidon={};window.evidon.id=id;
			var evidoncdn='//c.evidon.com/',cdn="https:\/\/baltimore.cbslocal.com\/wp-content\/themes\/cbs-local\/files\/crownpeak\/",rootDomain='cbslocal',noticecdn=cbs_evidon_noticecdn_sitenotice;
			append('evidon-notice',cbs_evidon_noticecdn_sitenotice+'evidon-sitenotice-tag.js',!1);
			append('evidon-location',evidoncdn+'geo/country.js',!0);
			append('evidon-themes',cbs_evidon_noticecdn_id+'/snthemes.js',!0);
			append('evidon-settings',cbs_evidon_noticecdn_id+'/cbslocal/settings.js',!0);
			window.evidon.priorConsentCallback=function(){
				cbs_j.log('[CPM] priorConsentCallback');
				cbs_j.function_queue("partners-header-js", 'cbs_partners_header_js');
				cbs_j.function_queue("partners-footer-js", 'cbs_partners_footer_js');
			}
		})(425)</script>
		<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=32" sizes="32x32" />
<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=180" />
<meta name="msapplication-TileImage" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Fast-moving storms hit parts of Maryland hard Thursday night. " />
<script>//<![CDATA[
		!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://untidyrice.com/v2/0/bbrp1jweGIk3YvinQ2xQP9xVRQ9H4y2_c-h04atyes-rzbUS3_RWHfBv0Ar3WF7b6K9SlFNiOpX",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,n,a){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var a=o();if(a){var r=t[e].pubads();typeof r.setTargeting===n&&r.setTargeting("admiral-engaged","true")}}a=t[e]=t[e]||{},a.cmd=a.cmd||[],typeof a.pubads===n?r():typeof a.cmd.unshift===n?a.cmd.unshift(r):a.cmd.push(r)}(window,"googletag","function");;;;;
	
function cbs_partners_header_js(){cbs_j.log('[PARTNER] Header Function');cbs_j.dom.load_script("cbs-apstag", "//c.amazon-adsystem.com/aax2/apstag.js");cbs_j.dom.load_script("sonobi", "https://mtrx.go.sonobi.com/morpheus.cbslocal.3566.js");cbs_j.dom.load_script("dfp", "//www.googletagservices.com/tag/js/gpt.js");cbs_j.dom.load_script("trak-ga", "https://ssl.google-analytics.com/ga.js");cbs_j.dom.load_script("addthis", "//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ddd05dc24272928");cbs_j.dom.load_script("sharethrough", "//native.sharethrough.com/assets/tag.js");cbs_j.dom.load_script("taboola-pixel", "//cdn.taboola.com/libtrc/cbslocal-sc/tfa.js", function() {window._tfa = window._tfa || []; _tfa.push({ notify: "action",name: "page_view" });});}cbs_j.function_queue.activate_point('partners-header-js');
//]]></script>

</head>

<body class="post-template-default single single-post postid-814627 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://baltimore.cbslocal.com" id="header-logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/07/3_baltimore_cbs13_wjz.png?w=258" alt="CBS Baltimore" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://baltimore.cbslocal.com/category/sports/">Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="http://baltimore.cbslocal.com/category/baltimore-gameday-uncensored/" title="Baltimore Gameday Uncensored" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Baltimore Gameday Uncensored</strong></div></a><a href="http://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/1170" title="Drone 13" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Drone 13</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/677/" title="Manic Monday" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Manic Monday</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/news/local/" title="Local News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Local News</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/anne-arundel-county/" title="Anne Arundel County" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Anne Arundel County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-city/" title="Baltimore City" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Baltimore City</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-county/" title="Baltimore County" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Baltimore County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/carroll-county/" title="Carroll County" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Carroll County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/harford-county/" title="Harford County" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Harford County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/howard-county/" title="Howard County" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Howard County</strong></div></a><a href="http://baltimore.cbslocal.com/category/health" title="HealthWatch" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://baltimore.cbslocal.com/category/watch-listen/" title="Watch + Listen" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">Watch + Listen</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://baltimore.cbslocal.com/category/news/">Latest News</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/08/23/robert-griffin-iii-gervonta-davis-baltimore-city-schools/" title="Robert Griffin III, Gervonta Davis Get Students Ready For Upcoming School Year With Free Haircuts, Supplies" class="cbs-thumbnail-link item-1566599082 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/School-Supplies.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Robert Griffin III, Gervonta Davis Get Students Ready For Upcoming School Year With Free Haircuts, Supplies</strong><em class="description">With a week and a half left in summer vacation, two local athletes helped to make sure kids will be ready for the up and coming school year. </em></div></a><a href="https://baltimore.cbslocal.com/2019/08/23/baltimore-teachers-union-fan-drive/" title="&#039;It&#039;s Inhumane&#039; | Baltimore Teachers Union Holds Fan Drive In Effort To Combat Problems Of Hot Classrooms" class="cbs-thumbnail-link item-1566597676 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Baltimore-Teachers-Union-Fan-Drive.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;It&#039;s Inhumane&#039; | Baltimore Teachers Union Holds Fan Drive In Effort To Combat Problems Of Hot Classrooms</strong><em class="description">The Baltimore Teachers Union is scrambling to get space fans into schools before the start of the academic year, all in an effort to alleviate the problem of hot classrooms. </em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://baltimore.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/1170" title="Drone 13" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Drone 13</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/677/" title="Manic Monday" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Manic Monday</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">WJZ On Demand Video</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1480350753" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="http://baltimore.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="http://baltimore.cbslocal.com/category/baltimore-gameday-uncensored/" title="Baltimore Gameday Uncensored" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Baltimore Gameday Uncensored</strong></div></a><a href="http://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/08/23/dan-fouts-ravens-have-tailored-offense-to-fit-lamar-jacksons-strengths/" title="Dan Fouts: Ravens Have Tailored Offense To Fit Lamar Jackson&#039;s Strengths" class="cbs-thumbnail-link item-1566584359 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/GettyImages-1168298510.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Dan Fouts: Ravens Have Tailored Offense To Fit Lamar Jackson&#039;s Strengths</strong><em class="description">The NFL on CBS commentator weighs in on the Ravens offense heading into the 2019-20 season with Jackson as the starting QB. </em></div></a><a href="https://baltimore.cbslocal.com/2019/08/23/orioles-set-mark-for-hrs-allowed-in-late-night-loss-to-rays/" title="Orioles Set Mark For HRs Allowed In Late-Night Loss To Rays" class="cbs-thumbnail-link item-1566543018 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/GettyImages-1169751858.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Orioles Set Mark For HRs Allowed In Late-Night Loss To Rays</strong><em class="description">For a while, there&#039;s been no doubt the Baltimore Orioles would set a dubious record for the most home runs allowed in a season.</em></div></a><a href="https://baltimore.cbslocal.com/2019/08/22/trace-mcsorley-impresses-in-ravens-26-15-win-over-eagles/" title="Trace McSorley Impresses In Ravens&#039; 26-15 Win Over Eagles" class="cbs-thumbnail-link item-1566532263 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/GettyImages-1163253724.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Trace McSorley Impresses In Ravens&#039; 26-15 Win Over Eagles</strong><em class="description">Trace McSorley will be too valuable for special teams with performances like this.</em></div></a><a href="https://baltimore.cbslocal.com/2019/08/22/orioles-home-runs-allowed-record/" title="O&#039;s Claim Unwanted Record With 259th Home Run Surrendered, Most Allowed By A Team In A Single Season" class="cbs-thumbnail-link item-1566519892 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/05/gettyimages-1143175765.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">O&#039;s Claim Unwanted Record With 259th Home Run Surrendered, Most Allowed By A Team In A Single Season</strong><em class="description">The O&#039;s made the record books Thursday against the Tampa Bay Rays, but for all the wrong reasons. </em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://baltimore.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Links</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/wjz-radar/" title="Weather Maps" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Weather Maps</strong></div></a><a href="http://baltimore.cbslocal.com/school-closings/" title="Maryland School Closings" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Maryland School Closings</strong></div></a><a href="http://baltimore.cbslocal.com/category/weather/weather-blog/" title="Weather Blog" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Weather Blog</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/4151650-meg-mcnamara-has-your-friday-afternoon-forecast/" title="Meg McNamara Has Your Friday Afternoon Forecast" class="cbs-thumbnail-link item-1566581314 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/384/4FA/3844FA10C506499CB6D1A6F25944132C.jpg?Expires=1661207863&#038;KeyName=mcpkey1&#038;Signature=TbuxN7ozqE1NW8ayA3uRDmTrm2c"></span></div><div class="title-wrapper"><strong class="title">Meg McNamara Has Your Friday Afternoon Forecast</strong><em class="description">A look at your Friday and weekend forecast.</em></div><time datetime="2019-08-23T17:28:34+00:00" title="August 23, 2019 at 1:28 pm">5 hours ago</time></a><a href="https://baltimore.cbslocal.com/video/4151441-marty-bass-has-your-friday-morning-forecast/" title="Marty Bass Has Your Friday Morning Forecast" class="cbs-thumbnail-link item-1566563904 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/5C3/193/5C31930A4D3748F9AFF9DEAD722E21E5.jpg?Expires=1661207863&#038;KeyName=mcpkey1&#038;Signature=x-8moUmSIATHaylnNSvOAMOYMz0"></span></div><div class="title-wrapper"><strong class="title">Marty Bass Has Your Friday Morning Forecast</strong><em class="description">Shower or thunderstorm possible, cooler and 77 in Baltimore.</em></div><time datetime="2019-08-23T12:38:24+00:00" title="August 23, 2019 at 8:38 am">10 hours ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Stories</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/08/23/baltimore-flash-flooding-fells-point/" title="Fast-Moving Storms Cause Flash Flooding In Parts Of Baltimore Thursday Night" class="cbs-thumbnail-link item-1566596151 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Baltimore-Flooding.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Fast-Moving Storms Cause Flash Flooding In Parts Of Baltimore Thursday Night</strong><em class="description">Fast-moving storms hit parts of Maryland hard Thursday night. </em></div></a><a href="https://baltimore.cbslocal.com/2019/08/22/severe-thunderstorm-warning-in-effect-for-carroll-frederick-counties/" title="Flood Warning In Effect For Baltimore Into Friday, Thousands Without Power After Severe Storms" class="cbs-thumbnail-link item-1566529689 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Baltimore-Flooding-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Flood Warning In Effect For Baltimore Into Friday, Thousands Without Power After Severe Storms</strong><em class="description">Another round of severe weather could make its way through parts of Maryland again Thursday evening.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="http://baltimore.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://baltimore.cbslocal.com/category/best-of/">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/08/17/your-guide-to-the-4-most-popular-spots-in-baltimores-fells-point-neighborhood/" title="Your Guide To The 4 Most Popular Spots In Baltimore&#039;s Fells Point Neighborhood" class="cbs-thumbnail-link item-1566084279 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/0817thamesst.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Your Guide To The 4 Most Popular Spots In Baltimore&#039;s Fells Point Neighborhood</strong></div></a><a href="https://baltimore.cbslocal.com/2019/08/10/best-baltimore-dive-bars/" title="Baltimore&#039;s 3 Favorite Dive Bars That Won&#039;t Break The Bank" class="cbs-thumbnail-link item-1565469248 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Hoodline-Only-3-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Baltimore&#039;s 3 Favorite Dive Bars That Won&#039;t Break The Bank</strong><em class="description">Looking to try the best dive bars in town?</em></div></a><a href="https://baltimore.cbslocal.com/2019/08/09/the-5-best-spots-for-coffee-in-baltimore/" title="The 5 Best Spots For Coffee In Baltimore" class="cbs-thumbnail-link item-1565389851 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/hoodline-only-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">The 5 Best Spots For Coffee In Baltimore</strong><em class="description">Looking to sample the best coffee around town?</em></div></a><a href="https://baltimore.cbslocal.com/2019/08/03/best-grocery-stores-in-baltimore/" title="The 3 Best Grocery Stores In Baltimore" class="cbs-thumbnail-link item-1564873723 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Hoodline-Only-4.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">The 3 Best Grocery Stores In Baltimore</strong><em class="description">Wondering where to find the best grocery stores near you?</em></div></a><a href="https://baltimore.cbslocal.com/2019/08/02/best-sandwiches-in-baltimore/" title="The 5 Best Spots To Score Sandwiches In Baltimore" class="cbs-thumbnail-link item-1564792867 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/hoodline-only-3.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">The 5 Best Spots To Score Sandwiches In Baltimore</strong><em class="description">Got a hankering for sandwiches? You won&#039;t want to miss these locations in Baltimore.</em></div></a><a href="https://baltimore.cbslocal.com/2019/07/27/best-spots-in-upper-fells-point/" title="Explore The 3 Top Spots In Baltimore&#039;s Upper Fells Point Neighborhood" class="cbs-thumbnail-link item-1564269331 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/07/hoodline-only-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Explore The 3 Top Spots In Baltimore&#039;s Upper Fells Point Neighborhood</strong><em class="description">Spending time in Upper Fells Point? Get to know this Baltimore neighborhood by browsing its most popular local businesses, from a breakfast and brunch spot to a nail salon.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Contests &amp; More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/learn-about-us/">Station Info</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="WJZ 13" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">WJZ 13</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://baltimore.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/08/22/nfl-stadium-guides-parking-transportation-tailgating/" title="Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides" class="cbs-thumbnail-link item-1566480885" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/GettyImages-466663843.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Heading To An NFL Game? Be Sure To Check Out Our NFL Stadium Guides</strong><em class="description">If you and your family are headed to an NFL game this season, we have you covered with guides to stadiums across the league.</em></div></a><a href="https://baltimore.cbslocal.com/2019/08/16/bwi-air-travel-international-entry-system-issue/" title="Temporary System Outage Causes Issues For International Passengers At Some U.S. Airports" class="cbs-thumbnail-link item-1565994774 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/bwi-airport-generic.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Temporary System Outage Causes Issues For International Passengers At Some U.S. Airports</strong><em class="description">A system outage caused issues for passengers flying internationally at multiple U.S. airports Friday evening, but not at Baltimore Washington International Thurgood Marshall Airport.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Contests</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/06/26/enter-to-win-a-4-pack-of-cirque-du-soleils-corteo-tickets-at-royal-farms-arena/" title="Enter To Win A 4-Pack Of Cirque Du Soleil&#039;s Corteo Tickets At Royal Farms Arena" class="cbs-thumbnail-link item-1561521622" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/06/0614cirquepromotionphoto.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Enter To Win A 4-Pack Of Cirque Du Soleil&#039;s Corteo Tickets At Royal Farms Arena</strong><em class="description">One person can win four tickets to see the Cirque du Soleil&#039;s Corteo show.</em></div></a><a href="https://baltimore.cbslocal.com/2019/06/03/price-is-right-casting-call/" title="The Price Is Right Casting Call" class="cbs-thumbnail-link item-1559583523" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/06/price-is-right-casting-call-revised-0619-cs.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">The Price Is Right Casting Call</strong><em class="description">The Price is Right is holding a casting call in Maryland on June 6. </em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519402862" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	<ul id="live"><li class="menu-item item-0 w-active"><a href="/live/channel/cbs-baltimore-live-video/" title="WJZ 13" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WJZ 13</strong><em class="description">Watch Now</em></div></a><div class="submenu"><div class="wrapper"><a class="live-now-text" href="/live/channel/cbs-baltimore-live-video/">Live News - WJZ at 6</a><div id="embed-list-1" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">6:30 PM</strong><em class="description">WJZ News @ 6:30PM</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">7:00 PM</strong><em class="description">CBS Evening News with Norah O'Donnell</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">7:30 PM</strong><em class="description">Entertainment Tonight</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">8:00 PM</strong><em class="description">NFL Preseason Football</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">11:00 PM</strong><em class="description">WJZ News @11PM</em></div></div></div>
</div></div><a class="view-all" href="http://baltimore.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	<a href="http://baltimore.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="39.290385" longitude="-76.612189" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://baltimore.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Fast-Moving Storms Cause Flash Flooding In Parts Of Baltimore Thursday Night</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><span class="post-personality">By <a href="https://baltimore.cbslocal.com/personality/rick-ritter">Rick Ritter</a></span><time class="post-date">August 23, 2019 at 5:35 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://baltimore.cbslocal.com/tag/baltimore/">Baltimore</a>, <a href="https://baltimore.cbslocal.com/tag/baltimore-news/">Baltimore News</a>, <a href="https://baltimore.cbslocal.com/tag/fells-point/">Fells Point</a>, <a href="https://baltimore.cbslocal.com/tag/fells-point-flooding/">Fells Point Flooding</a>, <a href="https://baltimore.cbslocal.com/tag/local-tv/">Local TV</a>, <a href="https://baltimore.cbslocal.com/tag/maryland-severe-weather/">Maryland Severe Weather</a>, <a href="https://baltimore.cbslocal.com/tag/maryland-weather/">Maryland Weather</a>, <a href="https://baltimore.cbslocal.com/tag/talkers/">Talkers</a></div></div></section><section id="column_block_2" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id='p0'></div><script data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4151814&quot;,&quot;autoplay&quot;:true,&quot;titleVisible&quot;:false,&quot;accessKey&quot;:&quot;DVzl9QRzox3ZZsP9bNu5Li3X7obQOnqP&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p0&quot;,&quot;plugins&quot;:{&quot;heartbeat&quot;:{&quot;account&quot;:&quot;cbslocal-global-unified&quot;,&quot;publisherId&quot;:&quot;cbslocal&quot;,&quot;jobId&quot;:&quot;sc_va&quot;,&quot;marketingCloudId&quot;:&quot;823BA0335567497F7F000101@AdobeOrg&quot;,&quot;trackingServer&quot;:&quot;cbsdigitalmedia.hb.omtrdc.net&quot;,&quot;customTrackingServer&quot;:&quot;cbsdigitalmedia.d1.sc.omtrdc.net&quot;,&quot;chapterTracking&quot;:false,&quot;version&quot;:&quot;1.5&quot;},&quot;comscore&quot;:{&quot;clientId&quot;:&quot;3000023&quot;,&quot;c3&quot;:&quot;Baltimore.cbslocal.com&quot;},&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.BALTIMORE&amp;ciu_szs&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=[description_url]&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;featured&quot;}}}},&quot;recom&quot;:true,&quot;maxRecomPages&quot;:3,&quot;shareLink&quot;:&quot;https:\/\/cbsloc.al\/2ZpKcsY&quot;,&quot;token&quot;:&quot;default&quot;}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script></div></section>
<div class="main-story-wrapper"><p><!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" "http://www.w3.org/TR/REC-html40/loose.dtd"><br />
<html><body><strong>BALTIMORE (WJZ) &#8212;&nbsp;</strong>Fast-moving storms hit parts of Maryland hard Thursday night.</p>
<p>The storms brought lightning, flash flooding and thousands without power.</p>
<p>Those fast-moving storms meant D&eacute;j&agrave; vu for Fells Point downtown, which once again, featured cars looking like bath toys.</p>
<p>Some streets, like South Ann, saw flash flooding.</p>
<p><strong>Related Coverage&nbsp;</strong></p>
<ul>
<li><strong><a href="https://cbsloc.al/2NrFSYa" rel="nofollow">Bob Turk Weather Blog</a></strong></li>
<li><strong><a href="https://cbsloc.al/2ZfAzlK" rel="nofollow">Heavy Rain Causes Flooding In Parts Of Baltimore City Thursday</a></strong></li>
</ul>
<p>The impact extended beyond the rainfall, though, with intense lightning.</p>
<div id="attachment_814487" style="width: 310px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-814487" class="wp-image-814487 size-medium" src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Dundalk-Lightning-2.jpg?w=300" alt="" width="300" height="166" srcset="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Dundalk-Lightning-2.jpg 792w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Dundalk-Lightning-2.jpg?resize=150,83 150w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Dundalk-Lightning-2.jpg?resize=300,166 300w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Dundalk-Lightning-2.jpg?resize=768,424 768w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Dundalk-Lightning-2.jpg?resize=620,342 620w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Dundalk-Lightning-2.jpg?resize=640,353 640w" sizes="(max-width: 300px) 100vw, 300px" /><p id="caption-attachment-814487" class="wp-caption-text">Photo Courtesy Of Alyssa Terezakis</p></div>
<p>Firefighters raced to a home in Hyattstown after it was struck. Four people were inside when the lightning hit. Fortunately, everyone was safe.</p>
<p>Friday morning, BGE crews in Glen Burnie were left trying to repair power lines.</p>
<p>At the height of the storm, more than 14,000 people were left in the dark.<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"103fa8ca15","applicationID":"144794115","transactionName":"ZwdaZBdUX0VTVEBRC15NeVMRXF5YHV5aXAFI","queueTime":0,"applicationTime":149,"atts":"S0BNEl9OTBoQVhYCH00f","errorBeacon":"bam.nr-data.net","agent":""}</script></body></html></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/2ZpKcsY"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/2ZpKcsY"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/2ZpKcsY"></a></span>
			</div>
		
			</div>
</div></div></div><div id="personality-credits-container" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>Rick </span> Ritter</h4></header><div class="block-content-wrapper and-list layout-catalog aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" id="personality-credits" data-social-links="{&quot;twitter_url&quot;:&quot;https:\/\/twitter.com\/RickRitterWJZ&quot;,&quot;facebook_url&quot;:&quot;https:\/\/www.facebook.com\/RickJRitter\/&quot;,&quot;instagram_url&quot;:&quot;https:\/\/www.instagram.com\/rickrittercbs\/?hl=en&quot;,&quot;email_address&quot;:&quot;rritter@wjz.com&quot;}" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/09/rick-ritter-bio.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><em class="description">Emmy Award-winning anchor Rick Ritter joined WJZ in May 2014. He anchors the 5 pm newscast with Nicole Baker &amp; hosts the "Purple Connection"...</em><a href="https://baltimore.cbslocal.com/personality/rick-ritter/" id="more-from-personality"><span>More from</span> <strong>Rick Ritter</strong></a></div></div></div>
</div></div><a href="#" id="enable-comments-button" class="generic-button-v1" onclick="document.getElementById('story-comments').style.display=(document.getElementById('story-comments').style.display==='block')?'none':'block';return false;">Comments</a>
	<style>
	#comments .comments-title,
	#comments #respond #reply-title {
		color: black;
		font-size: 16px;
		font-weight: normal;
		margin-bottom: 20px;
	}
	#comments a:hover {
		text-decoration: underline;
	}
	#comments .comment-list,
	#comments .comment-list .children {
		list-style: none;
		margin: 0;
	}
		#comments .comment-list .comment {
			border-top: 1px solid #eaeaea;
			padding: 20px 10px;
		}
			#comments .comment-list .comment .comment-body {
				color: black;
				font-size: 13px;
				position: relative;
			}
				#comments .comment-list .comment .comment-body p {
					margin: 5px 0 7px 0;
					overflow: hidden;
					padding: 0;
				}
			#comments .comment-list .comment .comment-author .avatar {
				float: left;
				height: 42px;
				margin-bottom: 10px;
				margin-right: 15px;
				width: 42px;
			}
			#comments .comment-list .comment .comment-author .fn {
				color: black;
				font-size: 13px;
				font-style: normal;
				font-weight: bold;
			}
			#comments .comment-list .comment .comment-author .says {
				display: none;
			}

			#comments .comment-list .comment .comment-meta {
				position: absolute;
				right: 0;
				top: 0;
			}
			#comments .comment-list .comment .reply {
				margin-left: 57px;
			}
			#comments .comment-list .comment .comment-meta a,
			#comments .comment-list .comment .reply a {
				color: #808080;
				font-size: 11px;
			}
				#comments .comment-list:hover .comment .comment-meta a,
				#comments .comment-list:hover .comment .reply a {
					color: #333;
				}
			#comments .comment-list .comment .reply .safe-comments-report-link:last-of-type {
				display: none;
			}
	#comments .comment-list .children {
		margin-left: 20px;
		margin-top: 20px;
	}
		#comments .comment-list .children .comment {
			border-top: none;
			padding-right: 0;
			padding-top: 0;
		}

	#comments #reply-title a {
		color: black;
		font-size: 13px;
		padding: 0 5px;
	}
		#comments #reply-title small a {
			font-weight: normal;
		}
	



</style>

<div class="commenting-container">
	<a name="comments" class="comments-location-beacon"></a>
	<section id="story-comments" class="column-item">

		<div id="comments" class="comments-area">

			
							<p class="must-log-in">You must <a href="https://baltimore.cbslocal.com/wp-login.php?redirect_to=https%3A%2F%2Fbaltimore.cbslocal.com%2F2019%2F08%2F23%2Fbaltimore-flash-flooding-fells-point%2F%23respond">log in</a> to post a comment.</p>			
		</div>

	</section>
</div>
<div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-3"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/CBSBaltimore" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="http://twitter.com/wjz" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="http://youtube.com/user/CBSBaltimore" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="https://www.reddit.com/user/cbsbaltimore" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/wjz-tv/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=baltimore"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
												<a href="https://baltimore.cbslocal.com/2019/08/22/jessica-leigh-doran-dui-fatal-crash-dundalk/" title="Dundalk Woman Charged With DUI In Fatal Baltimore County Motorcycle Crash" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/jessica-leigh-doran-mugshot.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Dundalk Woman Charged With DUI In Fatal Baltimore County Motorcycle Crash" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/08/22/jessica-leigh-doran-dui-fatal-crash-dundalk/" class="bump-view" data-bump-view="tp">
								Dundalk Woman Charged With DUI In Fatal Baltimore County Motorcycle Crash							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/08/22/luis-alberto-perez-giron-sexual-assault-charges/" title="Md. Man Allegedly Sexually Assaults 12-Year-Old While His Wife Was In Labor" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2015/10/150791840.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Md. Man Allegedly Sexually Assaults 12-Year-Old While His Wife Was In Labor" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/08/22/luis-alberto-perez-giron-sexual-assault-charges/" class="bump-view" data-bump-view="tp">
								Md. Man Allegedly Sexually Assaults 12-Year-Old While His Wife Was In Labor							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/08/21/dawnta-harris-sentencing-teen-convicted-amy-caprio-death-baltimore-county-police/" title="&#039;I Didn&#039;t Want To Hurt Her&#039;: Dawnta Harris Sentenced To Life In Prison In Ofc. Amy Caprio&#039;s Death" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/dawnta-harris.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="&#039;I Didn&#039;t Want To Hurt Her&#039;: Dawnta Harris Sentenced To Life In Prison In Ofc. Amy Caprio&#039;s Death" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/08/21/dawnta-harris-sentencing-teen-convicted-amy-caprio-death-baltimore-county-police/" class="bump-view" data-bump-view="tp">
								&#039;I Didn&#039;t Want To Hurt Her&#039;: Dawnta Harris Sentenced To Life In Prison In Ofc. Amy Caprio&#039;s Death							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/08/22/seth-hurwitz-charged-with-solicitation-of-prostitution/" title="Merriweather Post Pavilion Chairman, 9:30 Club Owner Seth Hurwitz Charged With Soliciting Prostitution From Massage Therapist" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Seth-Hurwitz.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Merriweather Post Pavilion Chairman, 9:30 Club Owner Seth Hurwitz Charged With Soliciting Prostitution From Massage Therapist" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/08/22/seth-hurwitz-charged-with-solicitation-of-prostitution/" class="bump-view" data-bump-view="tp">
								Merriweather Post Pavilion Chairman, 9:30 Club Owner Seth Hurwitz Charged With Soliciting Prostitution From Massage Therapist							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/08/22/baltimore-city-weather-stories/" title="Heavy Rain Causes Flooding In Parts Of Baltimore City Thursday" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Baltimore-Flooding.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Heavy Rain Causes Flooding In Parts Of Baltimore City Thursday" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/08/22/baltimore-city-weather-stories/" class="bump-view" data-bump-view="tp">
								Heavy Rain Causes Flooding In Parts Of Baltimore City Thursday							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/08/22/17-year-old-killed-2-others-injured-in-overnight-baltimore-shootings/" title="&#039;You Don&#039;t Know Who&#039;s Next&#039; | 17-Year-Old Killed, 2 Others Injured In Overnight Baltimore Shootings" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/05/baltimore-city-police-1.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="&#039;You Don&#039;t Know Who&#039;s Next&#039; | 17-Year-Old Killed, 2 Others Injured In Overnight Baltimore Shootings" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/08/22/17-year-old-killed-2-others-injured-in-overnight-baltimore-shootings/" class="bump-view" data-bump-view="tp">
								&#039;You Don&#039;t Know Who&#039;s Next&#039; | 17-Year-Old Killed, 2 Others Injured In Overnight Baltimore Shootings							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/08/21/harford-county-walmart-theft-suspects/" title="Tips Help Police Identify 2 Suspects Caught Stealing From Harford Co. Walmart" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/Walmart-suspects.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Tips Help Police Identify 2 Suspects Caught Stealing From Harford Co. Walmart" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/08/21/harford-county-walmart-theft-suspects/" class="bump-view" data-bump-view="tp">
								Tips Help Police Identify 2 Suspects Caught Stealing From Harford Co. Walmart							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/08/21/sgt-isaac-carrington-to-be-released-from-university-of-marylands-shock-trauma-this-afternoon/" title="&#039;Today Is A Joyous Day&#039;: Sgt. Isaac Carrington Released From Shock Trauma" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/carrington-released-bpd-1.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="&#039;Today Is A Joyous Day&#039;: Sgt. Isaac Carrington Released From Shock Trauma" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/08/21/sgt-isaac-carrington-to-be-released-from-university-of-marylands-shock-trauma-this-afternoon/" class="bump-view" data-bump-view="tp">
								&#039;Today Is A Joyous Day&#039;: Sgt. Isaac Carrington Released From Shock Trauma							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/08/22/maryland-state-fair-guide-2019/" title="It&#039;s Fair Season! What You Need To Know Before Heading To The Maryland State Fair" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/08/state-fair-2.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="It&#039;s Fair Season! What You Need To Know Before Heading To The Maryland State Fair" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/08/22/maryland-state-fair-guide-2019/" class="bump-view" data-bump-view="tp">
								It&#039;s Fair Season! What You Need To Know Before Heading To The Maryland State Fair							</a>
						</div>
												</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2017/10/baltimore.png" alt="CBS Baltimore" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/CBSBaltimore" class="facebook" target="_blank">Facebook</a><a href="http://twitter.com/wjz" class="twitter" target="_blank">Twitter</a><a href="http://youtube.com/user/CBSBaltimore" class="youtube" target="_blank">YouTube</a><a href="https://www.reddit.com/user/cbsbaltimore" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/wjz-tv/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/news/" title="Baltimore News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore News</strong></div></a><a href="https://baltimore.cbslocal.com/category/weather/" title="Maryland Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Maryland Weather</strong></div></a><a href="http://baltimore.cbslocal.com/category/news/national/" title="National" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">National</strong></div></a><a href="http://baltimore.cbslocal.com/category/news/local/" title="Local" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Local</strong></div></a><a href="http://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/sports/" title="Baltimore Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore Sports</strong></div></a><a href="http://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="http://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/822/" title="Fan Cam" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Fan Cam</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Seen On WJZ</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/program/1259/" title="Morning Edition" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/677/" title="Manic Monday" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Manic Monday</strong></div></a><a href="http://baltimore.cbslocal.com/category/its-academic/" title="It&#039;s Academic" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">It&#039;s Academic</strong></div></a><a href="http://baltimore.cbslocal.com/category/on-time/" title="On Time" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">On Time</strong></div></a><a href="http://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Connect With CBS Baltimore</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/2010/11/24/get-your-news-on-the-go/" title="News On The Go" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News On The Go</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="Station Info" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Station Info</strong></div></a><a href="https://baltimore.cbslocal.com/contact-us/" title="Contact Us" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-4" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://baltimore.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://baltimore.cbslocal.com/school-closings/" title="Baltimore School Closings" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Baltimore School Closings</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-5" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="http://policies.cbslocal.com/privacy/current.html#onlinead" title="Ad Choices" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ad Choices</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Baltimore" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2019 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=baltimore.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="http://policies.cbslocal.com/privacy-june-2015/current.html#video-services" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-207290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207290"><a href="http://policies.cbslocal.com/privacy/current.html">Privacy Policy</a></li>
<li id="menu-item-207291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207291"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-533038" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-533038"><a href="http://policies.cbslocal.com/privacy/current.html#cali-visitors">Your California Privacy Rights</a></li>
<li id="menu-item-533039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-533039"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-745179" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-745179"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/08/qpdc-2018-wjz-tv.pdf">MD Digital Political Ad Disclosures</a></li>
<li id="menu-item-788013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788013"><a href="https://publicfiles.fcc.gov/tv-profile/wjz-tv">Public File for WJZ-TV / WJZ-13</a></li>
<li id="menu-item-788792" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788792"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-789850" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-789850"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/05/wjz_fcc-eeo-report-june2019.pdf">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://baltimore.cbslocal.com/_static/??-eJyljFsKgCAQRTeUTRbZV7QWHYcSfJGG22+IVlB/93UutCwwxUqxQj0oUAE0RfiE2oOL6C/LEQVDlpvySuFdqT3bDr7zzIWs8ddPI83rUzRnd3qetrDKWU3jogY53TLaUW4=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563276013g' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201934'></script>
<script type='text/javascript' src='https://baltimore.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1561135339g'></script>
<script type='text/javascript' src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201934.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.6',blog:'162246106',post:'814627',tz:'-4',srv:'baltimore.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246106', '814627' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>