<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://baltimore.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="home invasion, missing person, odenton, darius jason lewis owens" />
<meta name="keywords" content="home invasion, missing person, odenton, darius jason lewis owens" />
<meta property="fb:pages" content="261323008476" />
<meta name="facebook-domain-verification" content="iiv3w5z7llhkla8zlctcj5kqsjba3k" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>Darius Owens Missing, Possibly Abducted In Odenton Home Invasion, Police Say &#8211; CBS Baltimore</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Baltimore &raquo; Feed" href="https://baltimore.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/_static/??-eJytUEkOwjAM/BDBKggoB8RbspgS1bGjLOr3CS2XnqASJ9tjz2jGMEVlhQtygfLEgBmsyYrEagLPlqp7QznDQ6Rg2rd2Bz+RMBh0CzcmJNHuOzlSHTxnCOIqtY1JqEfPg2KcFqkVsl1Qfxy1up08H6igWQ+YZpkVolrqsUjc8KNFowbD2pMiz+P/XSG1icuc9x5u3bk79qf+eri8AIzhviE=' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://baltimore.cbslocal.com/_static/??-eJyNy0sKgDAMANELWUMVtS7Es9QYVEg/kIh4e+0FxO3wBq5sMEWlqKA7BRLARQwn9AyiN1ONIhV8sSMin2tJIpD9RkYpZPb64y0L8RujStFzmGxvW9e5sRkeIeM5Jg==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://baltimore.cbslocal.com/_static/??-eJydUttOwzAM/SHcrFNB4gHxLW5iurDclLir+vdzV7ppVMDKQyTb8Tk+vqghgY6BKbDiA3kqSrcFXNToVHJ9Z0NRPpreyc8lATwG7CgrXSQyJmoqsZ7Ub0Q2aNebKSSYwRoCJp8cMpWN4ISZH8B8V14OMbOOC8vN3VCefEtmxl9McLYwaGR0sdvYhnRhtSM4rYe3SJfH2GX08EFkZtkt3KJ72Ffehiv+jt+INNVK4aOobDPmURUeHd0hHp6ebKwjvm5vslckvocF9kmcUCq/Vs2KgmOCFItYs57NWtY36DEfJ+o5X0cX8z8u5C/eeKI8ZMtryT90PlF8+RPk3b/VL3Wzq3fP++YM+/JLgg==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://baltimore.cbslocal.com/_static/??-eJy1UEEOwjAM+xAlG0IDDoi3lK4bLWlalhS031MmDuw2kDhZcWzHCjySMpHEkoBcbLAM5swKo9EIjgzmtlCeIUUcO4e4Do7Wnlew1OgXORLm3hFDiG3GstHtZC6g7pvPhFn0LdthfMMikQquH7TYnzpNAhU06d4Or+gZocq9q8T01XO6TEZcJP5HIYtlIuGSewrHuqm3VXXYNzv/BLDBujw='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.6.2' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://baltimore.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILRpoMA6Ib+nSqEuVphNp2e9TTVy4sJtlP9uwrR1mLaQFykKJDHC2TjI6AVaU6psVDZxfyPhNfWLto53gX7HxQfLs5JD8uXgVRqHDzio1sBqk7Ku0ZGMfqOwTX9kmnukxXIfLNE738y1+AArkVNw='></script>
<link rel="https://api.w.org/" href="https://baltimore.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://baltimore.cbslocal.com/wp-json/wp/v2/posts/928833" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://baltimore.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://baltimore.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6.2" />
<link rel='shortlink' href='https://cbsloc.al/2PduGBh' />
<link rel="alternate" type="application/json+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2021%2F02%2F25%2Fodenton-home-invasion-possible-abduction-darius-owens-missing-latest%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2021%2F02%2F25%2Fodenton-home-invasion-possible-abduction-darius-owens-missing-latest%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="Darius Owens Missing, Possibly Abducted In Odenton Home Invasion, Police Say" /><meta property="og:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg?w=630" /><meta property="og:image:secure_url" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg?w=630" /><meta property="og:image:width" content="630" /><meta property="og:image:height" content="354" /><meta property="og:description" content="Police are searching for a missing 20-year-old Baltimore man who may have been abducted during a home invasion in Odenton Wednesday night, the Anne Arundel County Police Department said." /><meta property="og:type" content="article" /><meta property="og:url" content="https://baltimore.cbslocal.com/2021/02/25/odenton-home-invasion-possible-abduction-darius-owens-missing-latest/" /><meta property="article:published_time" content="2021-02-25T13:20:29+00:00" /><meta property="article:suggested-social-copy" content="Police are searching for a missing 20-year-old Baltimore man who may have been abducted during a home invasion in Odenton Wednesday night, the Anne Arundel County Police Department said." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Anne Arundel County,Local,News,Syndicated Local" /><meta property="article:publisher" content="http://www.facebook.com/CBSBaltimore" /><meta property="article:author" content="http://www.facebook.com/CBSBaltimore" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg?w=630"><meta name="twitter:title" content="Darius Owens Missing, Possibly Abducted In Odenton Home Invasion, Police Say"/><meta name="twitter:description" content="Police are searching for a missing 20-year-old Baltimore man who may have been abducted during a home invasion in Odenton Wednesday night, the Anne Arundel County Police Department said."/><meta name="twitter:site" content="/wjz"/>
<link rel="canonical" href="https://baltimore.cbslocal.com/2021/02/25/odenton-home-invasion-possible-abduction-darius-owens-missing-latest/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://baltimore.cbslocal.com/2021/02/25/odenton-home-invasion-possible-abduction-darius-owens-missing-latest/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/baltimore.cbslocal.com","url":"https:\/\/baltimore.cbslocal.com","name":"CBS Baltimore","foundingDate":"1941-07-01T14:30:00+00:00","sameAs":"http:\/\/wjz.com","logo":{"@type":"ImageObject","url":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2018\/07\/3_baltimore_cbs13_wjz.png?w=258"}},"url":"https:\/\/baltimore.cbslocal.com\/2021\/02\/25\/odenton-home-invasion-possible-abduction-darius-owens-missing-latest\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/baltimore.cbslocal.com\/2021\/02\/25\/odenton-home-invasion-possible-abduction-darius-owens-missing-latest\/"},"headline":"Darius Owens Missing, Possibly Abducted In Odenton Home Invasion, Police Say","description":"Police are searching for a missing 20-year-old Baltimore man who may have been abducted during a home invasion in Odenton Wednesday night, the Anne Arundel County Police Department said.","image":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2021\/02\/Darius-Jason-Lewis-Owens-missing.jpg?w=630","keywords":["Anne Arundel County","Local","News","Syndicated Local","Baltimore","Baltimore News","Home Invasion","Local TV","Missing person","Odenton","Talkers","CBS Baltimore Staff","news","Darius Owens Missing, Possibly Abducted In Odenton Home Invasion, Police Say"],"datePublished":"2021-02-25T13:20:29+00:00","dateModified":"2021-02-25T13:20:29+00:00","author":{"@type":"Person","name":"CBS Baltimore Staff"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"WJZ Afternoon News & Weather Update 2-25-2021","description":"WJZ Afternoon News & Weather Update 2-25-2021","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/anv-iupl\/2A2\/05C\/2A205CB89C884D1C80F3FDBBE54D5620.jpg?Expires=1708905600&KeyName=mcpkey1&Signature=thPRLaJLXZZz0u-BmK69hPBst4o","uploadDate":"2021-02-25","duration":"T55S","contentUrl":"https:\/\/baltimore.cbslocal.com\/video\/5338920-wjz-afternoon-news-weather-update-2-25-2021\/","embedUrl":"https:\/\/baltimore.cbslocal.com\/video\/5338920-wjz-afternoon-news-weather-update-2-25-2021\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.BALTIMORE","news",["dariusowensmissingpossiblyabductedinodentonhomeinvasionpolicesay","post","article","annearundelcounty","local","news","syndicatedlocal","baltimore","baltimorenews","homeinvasion","localtv","missingperson","odenton","talkers","cbsbaltimorestaff","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("2");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-63" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-63" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"anne-arundel-county;local;news;syndicated-local;","dimension2":"article"});gtag("config","UA-2438645-63");</script>

<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=32" sizes="32x32" />
<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=180" />
<meta name="msapplication-TileImage" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}


#enable-comments-button {
    display: none;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Police are searching for a missing 20-year-old Baltimore man who may have been abducted during a home invasion in Odenton Wednesday night, the Anne Arundel County Police Department said." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-928833 single-format-standard desktop-display-type  and-temp-wide w-breaking-news"><div id="wrapper" class="body-wrapper">

<div id="breaking-news"><div class="wrapper"><a href="https://baltimore.cbslocal.com/2021/02/25/covid-19-in-maryland-just-under-1k-new-cases-added-hospitalizations-positivity-rate-down-slightly/" title="COVID-19 In MD" class="cbs-thumbnail-link" ><div class="title-wrapper"><strong class="title">COVID-19 In MD</strong><em class="description">Just Under 1K New Cases Added</em></div></a></div></div><div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://baltimore.cbslocal.com" id="header-logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/07/3_baltimore_cbs13_wjz.png?w=258" alt="CBS Baltimore" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/sports/">Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="https://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="https://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1394/" title="Purple Connection" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Purple Connection</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/news/">Maryland News</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/tag/baltimore-news/" title="Baltimore News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore News</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/" title="Local News" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Local News</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/anne-arundel-county/" title="Anne Arundel County" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Anne Arundel County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-city/" title="Baltimore City" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Baltimore City</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-county/" title="Baltimore County" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Baltimore County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/carroll-county/" title="Carroll County" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Carroll County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/harford-county/" title="Harford County" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Harford County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/howard-county/" title="Howard County" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Howard County</strong></div></a><a href="https://baltimore.cbslocal.com/category/health" title="HealthWatch" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://baltimore.cbslocal.com/category/watch-listen/" title="Watch + Listen" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Watch + Listen</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/news/">Latest News</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/02/25/odenton-home-invasion-possible-abduction-darius-owens-missing-latest/" title="Darius Owens Missing, Possibly Abducted In Odenton Home Invasion, Police Say" class="cbs-thumbnail-link item-1614277229 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Darius Owens Missing, Possibly Abducted In Odenton Home Invasion, Police Say</strong><em class="description">Police are searching for a missing 20-year-old Baltimore man who may have been abducted during a home invasion in Odenton Wednesday night, the Anne Arundel County Police Department said.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/25/man-dies-from-apparent-gunshot-wound-in-baltimore-thursday/" title="Man Dies From Apparent Gunshot Wound In Baltimore Thursday" class="cbs-thumbnail-link item-1614276476 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/07/baltimore-police-department-generic.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Man Dies From Apparent Gunshot Wound In Baltimore Thursday</strong><em class="description">A man died from an apparent gunshot wound in southeast Baltimore Thursday morning.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="https://baltimore.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1394/" title="Purple Connection" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Purple Connection</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">WJZ On Demand Video</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1480350753" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="https://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="https://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/02/24/hart-scores-20-to-lift-loyola-md-over-american-60-49/" title="Hart Scores 20 To Lift Loyola (Md.) Over American 60-49" class="cbs-thumbnail-link item-1614223791 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1082200376.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Hart Scores 20 To Lift Loyola (Md.) Over American 60-49</strong><em class="description">Isaiah Hart had 20 points as Loyola (Md.) beat American 60-49 on Wednesday night.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/24/orioles-ryan-mountcastle-looks-to-build-on-impressive-start-to-young-career/" title="Orioles&#039; Ryan Mountcastle Looks To Build On Impressive Start To Young Career" class="cbs-thumbnail-link item-1614211586 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Orioles&#039; Ryan Mountcastle Looks To Build On Impressive Start To Young Career</strong><em class="description">The Orioles are showing progress in developing their young players. Some made their Major League debuts last season, and now, they&#039;re getting ready for an encore.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/24/tiger-woods-crash-surgery-maryland-doctor-responds/" title="Maryland Doctor Says He&#039;s Not Ruling Out A Tiger Woods Return After Surgery For Injures In Rollover Car Crash" class="cbs-thumbnail-link item-1614206441 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1231346430.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Maryland Doctor Says He&#039;s Not Ruling Out A Tiger Woods Return After Surgery For Injures In Rollover Car Crash</strong><em class="description">After a rollover car accident in Los Angeles, Tiger Woods had emergency surgery for open fractures on his ankle and lower right leg.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/24/local-company-gets-contract-to-create-redevelopment-plans-for-pimlico-laurel-park/" title="Local Company Gets Contract To Create Redevelopment Plans For Pimlico, Laurel Park" class="cbs-thumbnail-link item-1614202979 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/06/pimlico-preakness.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Local Company Gets Contract To Create Redevelopment Plans For Pimlico, Laurel Park</strong><em class="description">The Maryland Stadium Authority has awarded a contract to a local company to come up with plans to redevelop both Pimlico and Laurel Park.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Links</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/school-closings/" title="Maryland School Closings" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Maryland School Closings</strong></div></a><a href="https://baltimore.cbslocal.com/category/weather/weather-blog/" title="Weather Blog" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather Blog</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/5338915-marty-bass-has-a-look-at-your-thursday-afternoon-forecast/" title="Marty Bass Has A Look At Your Thursday Afternoon Forecast" class="cbs-thumbnail-link item-1614276060 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/AAB/46A/AAB46A579D3843598E4FC38A129F35DE.jpg?Expires=1708905600&#038;KeyName=mcpkey1&#038;Signature=Cb8U9Kcl_ftQhFoheQbvhjc1H0A"></span></div><div class="title-wrapper"><strong class="title">Marty Bass Has A Look At Your Thursday Afternoon Forecast</strong><em class="description">It&#039;s all &quot;bluebird skies&quot; this afternoon!</em></div><time datetime="2021-02-25T18:01:00+00:00" title="February 25, 2021 at 1:01 pm">1 hour ago</time></a><a href="https://baltimore.cbslocal.com/video/5336433-bob-turk-has-an-updated-look-at-your-forecast/" title="Bob Turk Has An Updated Look At Your Forecast" class="cbs-thumbnail-link item-1614226920 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/0B0/A71/0B0A71C0547748E8BB7B4689CA0D2BFC.jpg?Expires=1708905600&#038;KeyName=mcpkey1&#038;Signature=9wgURahT7x2rdQ2_W_2ImcX0-bk"></span></div><div class="title-wrapper"><strong class="title">Bob Turk Has An Updated Look At Your Forecast</strong><em class="description">Bob Turk Has An Updated Look At Your Forecast</em></div><time datetime="2021-02-25T04:22:00+00:00" title="February 24, 2021 at 11:22 pm">15 hours ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Stories</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/02/25/weather-blog-warm-day-2/" title="Weather Blog: Warm Day" class="cbs-thumbnail-link item-1614261829 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2010/11/marty-bass.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Blog: Warm Day</strong><em class="description">It is Friday Eve and we started this day seasonally warm.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/24/weather-blog-63-is-the-high-wednesday/" title="Weather Blog: 63 Is The High Wednesday" class="cbs-thumbnail-link item-1614179164 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/wed-wx.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Blog: 63 Is The High Wednesday</strong><em class="description">63° is now the forecast daytime high for this afternoon up from 58° we discussed yesterday.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/best-of/">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/02/24/mia-dyer-scholastic-art-and-writing-award-winner-2021/" title="Baltimore School For The Arts Student Mia Dyer Named 2021 Recipient Of Scholastic Art And Writing Award" class="cbs-thumbnail-link item-1614225614 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Mia-Dyer.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Baltimore School For The Arts Student Mia Dyer Named 2021 Recipient Of Scholastic Art And Writing Award</strong><em class="description">A Baltimore School for the Arts student recently won a prestigious regional award. Mia Dyer is a junior at the school. She&#039;s been named a 2021 recipient of the Scholastic Art and Writing Award.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/24/owner-of-maryland-market-that-sold-winning-731m-powerball-ticket-gets-100k-bonus-check/" title="Owner Of Maryland Market That Sold Winning $731M Powerball Ticket Gets $100K Bonus Check" class="cbs-thumbnail-link item-1614204032 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Retailer-Check-Presentation-photo1-cropped.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Owner Of Maryland Market That Sold Winning $731M Powerball Ticket Gets $100K Bonus Check</strong><em class="description">The owner of the western Maryland market that sold a winning $731 million Powerball ticket last month has claimed the $100,000 bonus the store earned for selling the winning ticket.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/24/national-aquarium-releases-9-rescued-sea-turtles-back-in-the-ocean/" title="National Aquarium Releases 9 Rescued Sea Turtles In Waters Off Florida&#039;s Coast" class="cbs-thumbnail-link item-1614186575 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/20210223animalrescue_turtlerelease-75.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">National Aquarium Releases 9 Rescued Sea Turtles In Waters Off Florida&#039;s Coast</strong><em class="description">The National Aquarium&#039;s animal rescue team released a group of nine sea turtles -- 8 Kemp&#039;s ridley and one green sea turtle -- off the coast of Florida in their natural habitat. </em></div></a><a href="https://baltimore.cbslocal.com/2021/02/24/crews-rescue-horse-stuck-in-mud-for-7-hours-in-howard-county/" title="Crews Rescue Horse Stuck In Mud For 7 Hours In Howard County" class="cbs-thumbnail-link item-1614185465 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/6F216FA0765145F387BC0AE42DB5B71B.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Crews Rescue Horse Stuck In Mud For 7 Hours In Howard County</strong><em class="description">Rescue crews in Howard County worked to free a horse that got stuck in the mud for seven hours.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/23/guy-fieris-flavortown-opens-ghost-kitchens-in-maryland/" title="Guy Fieri&#039;s Flavortown Opens Ghost Kitchens In Maryland" class="cbs-thumbnail-link item-1614127961 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Flavortown-Kitchen.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Guy Fieri&#039;s Flavortown Opens Ghost Kitchens In Maryland</strong><em class="description">If you&#039;re looking to head to Flavortown, it&#039;s right here in Maryland! Guy Fieri&#039;s Flavortown Kitchen is the latest to use a &quot;ghost kitchen&quot; concept to create a delivery-only service operating out of existing restaurants.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/23/the-untied-states-vs-billie-holiday-feature-film-hulu/" title="Feature Film About Baltimore Jazz Singer Billie Holiday To Debut On Hulu" class="cbs-thumbnail-link item-1614120344 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-7-3.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Feature Film About Baltimore Jazz Singer Billie Holiday To Debut On Hulu</strong><em class="description">Born April 7, 1915, to two teenage parents, Eleanora Fagan, better known by her stage name, Billie Holiday, spent her childhood in Baltimore. </em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Contests &amp; More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/learn-about-us/">Station Info</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="WJZ 13" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">WJZ 13</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/02/25/maryland-chesapeake-bay-bridge-environmental-impact-statement-draft-released/" title="Third Span Along Existing Bay Bridge Has &#039;Substantial Advantages,&#039; Draft Environmental Impact Statement Concludes" class="cbs-thumbnail-link item-1614274733 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2020/10/IMG_7471.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Third Span Along Existing Bay Bridge Has &#039;Substantial Advantages,&#039; Draft Environmental Impact Statement Concludes</strong><em class="description">A draft environmental impact statement of a proposed third crossing of the Chesapeake Bay concluded a third span along the existing Bay Bridge has &quot;substantial advantages&quot; over other alternatives.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/05/tsa-checkpoints-at-bwi-airport-go-touchless-reducing-contact-amid-covid-19-pandemic/" title="TSA Checkpoints At BWI Airport Go Touchless, Reducing Contact Amid COVID-19 Pandemic" class="cbs-thumbnail-link item-1612548154 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/TSA-scanner-BWI.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">TSA Checkpoints At BWI Airport Go Touchless, Reducing Contact Amid COVID-19 Pandemic</strong><em class="description">Travelers at Baltimore-Washington International Thurgood Marshall Airport no longer have to hand over their IDs or boarding passes to Transportation Security Administration officers thanks to new automated scanners, the agency said Friday.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Contests</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2020/12/04/black-history-oratory-competition-2021/" title="Black History Oratory Competition 2021 Airs Saturday" class="cbs-thumbnail-link item-1607136808" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2020/12/16x9_Black_History_Oratory_Competition_Saturday_730.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Black History Oratory Competition 2021 Airs Saturday</strong><em class="description">WJZ&#039;s Annual Black History Oratory Competition.</em></div></a><a href="https://baltimore.cbslocal.com/grateful-in-2020-wjz/" title="What Are You Grateful For?" class="cbs-thumbnail-link item-1607128154 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2020/12/16x9_Grateful.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">What Are You Grateful For?</strong><em class="description">2020 wasn’t exactly how we planned. This year we’ve all missed something. But sometimes that helps us appreciate other things.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519402862" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	<ul id="live"><li class="menu-item item-0"><a href="/live/channel/cbs-baltimore-live-video/" title="WJZ 13" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WJZ 13</strong><em class="description">On Air</em></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">2:00 PM</strong><em class="description">The Talk</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">3:00 PM</strong><em class="description">Dr. Phil</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">4:00 PM</strong><em class="description">WJZ News @ 4PM</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">4:30 PM</strong><em class="description">WJZ News @ 4:30PM</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">5:00 PM</strong><em class="description">WJZ News @ 5PM</em></div></div></div>
</div></div><a class="view-all" href="http://baltimore.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	<a href="http://baltimore.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="39.290385" longitude="-76.612189" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://baltimore.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Darius Owens Missing, Possibly Abducted In Odenton Home Invasion, Police Say</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><span class="post-personality">By <a href="https://baltimore.cbslocal.com/personality/cbs-baltimore-staff">CBS Baltimore Staff</a></span><time class="post-date">February 25, 2021 at 1:20 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://baltimore.cbslocal.com/tag/baltimore/">Baltimore</a>, <a href="https://baltimore.cbslocal.com/tag/baltimore-news/">Baltimore News</a>, <a href="https://baltimore.cbslocal.com/tag/home-invasion/">Home Invasion</a>, <a href="https://baltimore.cbslocal.com/tag/local-tv/">Local TV</a>, <a href="https://baltimore.cbslocal.com/tag/missing-person/">Missing person</a>, <a href="https://baltimore.cbslocal.com/tag/odenton/">Odenton</a>, <a href="https://baltimore.cbslocal.com/tag/talkers/">Talkers</a></div></div></section><section id="column_block_2" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato-program  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"5338920","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5"},"comscore":{"clientId":"3000023","c3":"Baltimore.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"https:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.BALTIMORE&impl=s&gdfp_req=1&env=vp&output=xml_vast4&unviewed_position_start=1&url=[referrer_url]&description_url=https:\/\/baltimore.cbslocal.com&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}},"moat":{"clientSide":{"partnerCode":"cbslocalanvatovideo181732609431"}}},"shareLink":"https:\/\/cbsloc.al\/2PduGBh","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5,"recom":true,"maxRecomPages":3});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>ODENTON, Md. (WJZ) &#8212;</strong> Police are searching for a missing 20-year-old Baltimore man who may have been abducted during a home invasion in Odenton Wednesday night, the Anne Arundel County Police Department said.</p>
<p>The home invasion happened around 10 p.m. at a home in the 300 block of Baldwin Avenue. Police said four men with handguns entered the apartment through a rear door, ransacked the apartment and then fled.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://baltimore.cbslocal.com/2021/02/25/man-dies-from-apparent-gunshot-wound-in-baltimore-thursday/" target="_blank">Man Dies From Apparent Gunshot Wound In Baltimore Thursday</a>
<div id="attachment_928835" style="width: 640px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-928835" loading="lazy" class="wp-image-928835 size-full" src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg" alt="" width="630" height="354" srcset="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg 630w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg?resize=150,84 150w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg?resize=300,169 300w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg?resize=620,349 620w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg?resize=310,174 310w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Darius-Jason-Lewis-Owens-missing.jpg?resize=320,180 320w" sizes="(max-width: 630px) 100vw, 630px" /><p id="caption-attachment-928835" class="wp-caption-text">Darius Jason Lewis Owens. Credit: Anne Arundel County Police</p></div>
<p>Darius Jason Lewis Owens, one of the three people inside the home, is missing and may have been abducted, police said. He&#8217;s five-foot-nine, weighs 160 pounds and was last seen wearing a red jacket, black hat and black pants.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://baltimore.cbslocal.com/2021/02/25/stimulus-check-latest-1400-economic-relief-payment-timeline/" target="_blank">Third Stimulus Check: When Could You Get Another Economic Relief Payment?</a>
<p>The suspects reportedly took a blue 2004 Acura TSX with temporary Texas license plate 97681G3 from one of the other victims.</p>
<p>Anyone with information should call police at 410-222-6155, the Tip Line at 410-222-4700 or 911.</p><strong style="color: black; float: left; padding-right: 5px;">MORE NEWS: </strong><a style="display: block; margin-bottom: 25px;" href="https://baltimore.cbslocal.com/2021/02/25/15-year-old-boy-with-special-needs-missing-in-baltimore-police-say/" target="_blank">15-Year-Old Boy With Special Needs Missing In Baltimore, Police Say</a>
<p><i><span style="font-weight: 400">Get alerts from WJZ first! </span></i><a href="https://www.facebook.com/CBSBaltimore" rel="nofollow"><i><span style="font-weight: 400">Follow WJZ on Facebook</span></i></a><i><span style="font-weight: 400"> and </span></i><a href="https://baltimore.cbslocal.com/2020/05/13/download-wjz-13-cbs-baltimore-news-app/"><i><span style="font-weight: 400">download the app.</span></i></a></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/2PduGBh"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/2PduGBh"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/2PduGBh"></a></span>
			</div>
		
			</div>
</div></div></div><div id="app-promo-wrapper"><a href="https://apps.cbslocal.com/baltimore/" data-ios="https://apps.apple.com/us/app/cbs-baltimore/id1511220375" data-android="https://play.google.com/store/apps/details?id=com.wjz.android.news" target="_blank"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/app-promos/baltimore.jpg"/></a></div><div id="personality-credits-container" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>CBS </span> Baltimore Staff</h4></header><div class="block-content-wrapper and-list layout-catalog aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" id="personality-credits" data-social-links="{&quot;twitter_url&quot;:&quot;twitter.com\/wjz&quot;,&quot;facebook_url&quot;:&quot;https:\/\/www.facebook.com\/CBSBaltimore&quot;,&quot;instagram_url&quot;:&quot;https:\/\/www.instagram.com\/wjztv\/&quot;,&quot;email_address&quot;:&quot;cbsbaltimore@wjz.com&quot;}" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/01/wjz13logo.jpg?w=625&#038;h=352&#038;crop=1"></span></div><div class="title-wrapper"><em class="description"><a href="https://baltimore.cbslocal.com/personality/cbs-baltimore-staff/" id="more-from-personality"><span>More from</span> <strong>CBS Baltimore Staff</strong></a></em></div></div></div>
</div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-3"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/CBSBaltimore" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="http://twitter.com/wjz" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="http://youtube.com/user/CBSBaltimore" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="https://www.reddit.com/user/cbsbaltimore" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/wjz-tv/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=baltimore"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://baltimore.cbslocal.com/2021/02/22/former-ups-driver-turned-philanthropist-calvin-tyler-gives-morgan-state-20m-for-scholarships/" title="Former UPS Driver, Morgan State Alumnus Calvin Tyler Commits $20M For Scholarships" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/50968088671_6b0cfda5ec_o.jpg?resize=55%2C55&#038;ssl=1" alt="Former UPS Driver, Morgan State Alumnus Calvin Tyler Commits $20M For Scholarships" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/22/former-ups-driver-turned-philanthropist-calvin-tyler-gives-morgan-state-20m-for-scholarships/" title="Former UPS Driver, Morgan State Alumnus Calvin Tyler Commits $20M For Scholarships" class="bump-view" data-bump-view="tp">Former UPS Driver, Morgan State Alumnus Calvin Tyler Commits $20M For Scholarships</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/02/23/maryland-will-be-epicenter-of-this-years-cicada-palooza/" title="Maryland Will Be Epicenter Of This Year&#039;s &#039;Cicada-Palooza&#039;" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-74544572.jpg?resize=55%2C55&#038;ssl=1" alt="Maryland Will Be Epicenter Of This Year&#039;s &#039;Cicada-Palooza&#039;" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/23/maryland-will-be-epicenter-of-this-years-cicada-palooza/" title="Maryland Will Be Epicenter Of This Year&#039;s &#039;Cicada-Palooza&#039;" class="bump-view" data-bump-view="tp">Maryland Will Be Epicenter Of This Year&#039;s &#039;Cicada-Palooza&#039;</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/02/23/guy-fieris-flavortown-opens-ghost-kitchens-in-maryland/" title="Guy Fieri&#039;s Flavortown Opens Ghost Kitchens In Maryland" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Flavortown-Kitchen.jpg?resize=55%2C55&#038;ssl=1" alt="Guy Fieri&#039;s Flavortown Opens Ghost Kitchens In Maryland" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/23/guy-fieris-flavortown-opens-ghost-kitchens-in-maryland/" title="Guy Fieri&#039;s Flavortown Opens Ghost Kitchens In Maryland" class="bump-view" data-bump-view="tp">Guy Fieri&#039;s Flavortown Opens Ghost Kitchens In Maryland</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/02/23/ravens-john-harbaugh-takes-pictures-with-fans-pays-everyones-tab-while-out-to-dinner-at-jimmys-famous-seafood/" title="Ravens&#039; John Harbaugh Takes Pictures With Fans, Pays Everyone&#039;s Tab While Out To Dinner At Jimmy&#039;s Famous Seafood" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/12/GettyImages-1193740708.jpg?resize=55%2C55&#038;ssl=1" alt="Ravens&#039; John Harbaugh Takes Pictures With Fans, Pays Everyone&#039;s Tab While Out To Dinner At Jimmy&#039;s Famous Seafood" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/23/ravens-john-harbaugh-takes-pictures-with-fans-pays-everyones-tab-while-out-to-dinner-at-jimmys-famous-seafood/" title="Ravens&#039; John Harbaugh Takes Pictures With Fans, Pays Everyone&#039;s Tab While Out To Dinner At Jimmy&#039;s Famous Seafood" class="bump-view" data-bump-view="tp">Ravens&#039; John Harbaugh Takes Pictures With Fans, Pays Everyone&#039;s Tab While Out To Dinner At Jimmy&#039;s Famous Seafood</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/02/23/ups-driver-robbed-in-south-baltimore-tuesday-morning-police-say/" title="UPS Driver Robbed In South Baltimore Tuesday Morning, Police Say" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/12/ups.jpg?resize=55%2C55&#038;ssl=1" alt="UPS Driver Robbed In South Baltimore Tuesday Morning, Police Say" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/23/ups-driver-robbed-in-south-baltimore-tuesday-morning-police-say/" title="UPS Driver Robbed In South Baltimore Tuesday Morning, Police Say" class="bump-view" data-bump-view="tp">UPS Driver Robbed In South Baltimore Tuesday Morning, Police Say</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/02/23/crystal-jackson-hot-mom-children-expelled-catholic-school-only-fans-videos/" title="&#039;Hot Mom&#039; Says Catholic School Expelled Her 3 Kids Over Her Online Adult Videos" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/crystal-jackson.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;Hot Mom&#039; Says Catholic School Expelled Her 3 Kids Over Her Online Adult Videos" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/23/crystal-jackson-hot-mom-children-expelled-catholic-school-only-fans-videos/" title="&#039;Hot Mom&#039; Says Catholic School Expelled Her 3 Kids Over Her Online Adult Videos" class="bump-view" data-bump-view="tp">&#039;Hot Mom&#039; Says Catholic School Expelled Her 3 Kids Over Her Online Adult Videos</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/02/23/dimitris-international-grille-in-catonsville-to-close-its-doors/" title="Dimitri&#039;s International Grille In Catonsville To Close Its Doors" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Dimitris.jpg?resize=55%2C55&#038;ssl=1" alt="Dimitri&#039;s International Grille In Catonsville To Close Its Doors" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/23/dimitris-international-grille-in-catonsville-to-close-its-doors/" title="Dimitri&#039;s International Grille In Catonsville To Close Its Doors" class="bump-view" data-bump-view="tp">Dimitri&#039;s International Grille In Catonsville To Close Its Doors</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/02/24/johnson-johnson-covid-19-vaccine-meets-requirements-for-emergency-use-authorization-fda-says/" title="&#039;Game-Changing&#039; Johnson &amp; Johnson Single-Dose Covid-19 Vaccine Meets Requirements For Emergency Use Authorization, FDA Says" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1230829293.jpg?resize=55%2C55&#038;ssl=1" alt="&#039;Game-Changing&#039; Johnson &amp; Johnson Single-Dose Covid-19 Vaccine Meets Requirements For Emergency Use Authorization, FDA Says" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/24/johnson-johnson-covid-19-vaccine-meets-requirements-for-emergency-use-authorization-fda-says/" title="&#039;Game-Changing&#039; Johnson &amp; Johnson Single-Dose Covid-19 Vaccine Meets Requirements For Emergency Use Authorization, FDA Says" class="bump-view" data-bump-view="tp">&#039;Game-Changing&#039; Johnson &amp; Johnson Single-Dose Covid-19 Vaccine Meets Requirements For Emergency Use Authorization, FDA Says</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/02/25/stimulus-check-latest-1400-economic-relief-payment-timeline/" title="Third Stimulus Check: When Could You Get Another Economic Relief Payment?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/joe-biden-2-1.jpg?resize=55%2C55&#038;ssl=1" alt="Third Stimulus Check: When Could You Get Another Economic Relief Payment?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/25/stimulus-check-latest-1400-economic-relief-payment-timeline/" title="Third Stimulus Check: When Could You Get Another Economic Relief Payment?" class="bump-view" data-bump-view="tp">Third Stimulus Check: When Could You Get Another Economic Relief Payment?</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/02/24/man-killed-in-shooting-in-dundalk-tuesday-night-baltimore-county-police-say/" title="Man Killed In Shooting In Dundalk Tuesday Night, Baltimore County Police Say" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/snapshot-37.jpg?resize=55%2C55&#038;ssl=1" alt="Man Killed In Shooting In Dundalk Tuesday Night, Baltimore County Police Say" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/02/24/man-killed-in-shooting-in-dundalk-tuesday-night-baltimore-county-police-say/" title="Man Killed In Shooting In Dundalk Tuesday Night, Baltimore County Police Say" class="bump-view" data-bump-view="tp">Man Killed In Shooting In Dundalk Tuesday Night, Baltimore County Police Say</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2017/10/baltimore.png" alt="CBS Baltimore" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/CBSBaltimore" class="facebook" target="_blank">Facebook</a><a href="http://twitter.com/wjz" class="twitter" target="_blank">Twitter</a><a href="http://youtube.com/user/CBSBaltimore" class="youtube" target="_blank">YouTube</a><a href="https://www.reddit.com/user/cbsbaltimore" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/wjz-tv/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/tag/baltimore-news/" title="Baltimore News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore News</strong></div></a><a href="https://baltimore.cbslocal.com/category/weather/" title="Maryland Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Maryland Weather</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/national/" title="National" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">National</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/" title="Local" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Local</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://baltimore.cbslocal.com//category/health/" title="HealthWatch" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Baltimore Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore Sports</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/822/" title="Fan Cam" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Fan Cam</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Seen On WJZ</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/program/1259/" title="Morning Edition" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/677/" title="Manic Monday" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Manic Monday</strong></div></a><a href="https://baltimore.cbslocal.com/category/its-academic/" title="It&#039;s Academic" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">It&#039;s Academic</strong></div></a><a href="https://baltimore.cbslocal.com/category/on-time/" title="On Time" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">On Time</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Connect With CBS Baltimore</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2010/11/24/get-your-news-on-the-go/" title="News On The Go" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News On The Go</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="Station Info" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Station Info</strong></div></a><a href="https://baltimore.cbslocal.com/contact-us/" title="Contact Us" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-4" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://baltimore.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://baltimore.cbslocal.com/school-closings/" title="Baltimore School Closings" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Baltimore School Closings</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-5" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://privacy.cbs/personalizedads" title="Ad Choices" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ad Choices</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Baltimore" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=baltimore.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-207290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207290"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-207291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207291"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-839526" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-839526"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-839527" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-839527"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-533039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-533039"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-745179" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-745179"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/08/qpdc-2018-wjz-tv.pdf">MD Digital Political Ad Disclosures</a></li>
<li id="menu-item-788013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788013"><a href="https://publicfiles.fcc.gov/tv-profile/wjz-tv">Public File for WJZ-TV / WJZ-13</a></li>
<li id="menu-item-788792" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788792"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-906064" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-906064"><a href="https://baltimore.cbslocal.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-789850" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-789850"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2020/05/WJZJune2020-2-1.pdf">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://baltimore.cbslocal.com/wp-admin/admin-ajax.php";
</script>
<link rel='stylesheet' id='screen-css-0' href='https://baltimore.cbslocal.com/_static/??-eJyljFsKgCAQRTeUDRaVfURr0XEowUek4fYbohXU332dC/UQmGKhWKDsFCgDmix8Qu3BRfSX5YiCIctNfqXwLpeWbQPfeebCofHXTyXN61NUZzd6ntawyFH2alBzN90y/lF+' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1613858927g' type='text/css' media='all' />
<script type='text/javascript' src='https://baltimore.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1614009867g'></script>
<script src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1' id='cbs-weather-widget-js'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.6.2' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202108.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.4.1',blog:'162246106',post:'928833',tz:'-5',srv:'baltimore.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246106', '928833' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>