<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://baltimore.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="mlb, baltimore orioles, brandon hyde, orioles rebuild, opening day, opening day 2021, boston red sox, baltimore orioles opening day 2021," />
<meta name="keywords" content="mlb, baltimore orioles, brandon hyde, orioles rebuild, opening day, opening day 2021, boston red sox, baltimore orioles opening day 2021," />
<meta property="fb:pages" content="261323008476" />
<meta name="facebook-domain-verification" content="iiv3w5z7llhkla8zlctcj5kqsjba3k" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>Orioles To Open Season Against Red Sox. Here&#8217;s Who You Should Keep An Eye On This Year &#8211; CBS Baltimore</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Baltimore &raquo; Feed" href="https://baltimore.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/_static/??-eJytUMsOwjAM+yFKNG0gOCC+JW3DqJamVR/a71M2LjvBJE5JnNiyA3NUJkghKVCe5CmD0VlxMMjgxHC1byhneIRQKB1be4CfSOQ12ZUbE3FA+50cuY5OMvhgK7eNToSTk1EJzavUBtkviB9Hre4nLwfKo+BIaZHZIKqlnkqIO360alSvBR0rdjL93xVxm6Qsee/+1p0uXX8erv3wAozYvhs=' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://baltimore.cbslocal.com/_static/??-eJyNy0sKgDAMANELWaPFKi7Es9QYVEg/kIh4e+0FxO3wBq5sMEWlqKA7BRLARQwn9AyiN1ONIhV8sSMin2tJIpD9RkYpZPb64y0L8RujStFzmFo3dM1oXW8fIdQ5HQ==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://baltimore.cbslocal.com/_static/??-eJydUttOwzAM/SHcqIUi8YD4FjcxXVhuStxV/XvclW4aFbDyEMl2fI6PL2pMoGNgCqz4QJ6K0l0BFzU6ldzQ21CUj2Zw8nNOAI8Be8pKF4lMiZ4qsR7Ub0Q2aDeYOSSY0RoCJp8cMpWd4ISZ78B8V14OMbOOK8vV3VGefEdmwZ9NcLYwaGR0sd/ZhnRhtSM4bYe3SpfH2Gf08E5kFtkdXKMNNJW34YK/4TciTXVS+Cgqu4x5UoUnRzeIu6cnG+uJL9ub7Q2JH2CFfRAnlMovVbuh4JggxSLWome3lu0NeszHmXrJ19HF/I8L+Ys3niiP2fJW8g+dzxRf/gx586/1c90+NnXb1p/9TUuK' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://baltimore.cbslocal.com/_static/??-eJy1UEEOwjAM+xBdtKFyQ7yldNloSdOypqD9njJxYLeBxMmKYztW4JGUjSzIAnLBgBnsOSuK1hA4tlT6SvkMKdI8OKImOG583sFWo9/kSFRGxxlC7AvVjekXcwV17z4TVtG3gtP8hk0iFdw4GcGfOi0CFQybEadX9IpQ9d5VYvrqOUNhKy5y/kchpDqx5Jp7Csf20Op912rd+Sewqbox'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://baltimore.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILQyNIQ6Ib+nSqEuVphNp2e9TTVy4sJtlP9uwrR1mLaQFykKJDHC2TjI6AVaU6psVDZxfyPhNfWLto53gX7HxQfLs5JD8uXgVRqHDzio1sBqk7Ku0ZGMfqOwTX9kmnukxXO/D+TLdpjF+AAq8VNM='></script>
<link rel="https://api.w.org/" href="https://baltimore.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://baltimore.cbslocal.com/wp-json/wp/v2/posts/934901" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://baltimore.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://baltimore.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://cbsloc.al/3weepNl' />
<link rel="alternate" type="application/json+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2021%2F03%2F31%2Fbaltimore-orioles-opening-day-2021-who-to-watch-for-this-season%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2021%2F03%2F31%2Fbaltimore-orioles-opening-day-2021-who-to-watch-for-this-season%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="Orioles To Open Season Against Red Sox. Here&#039;s Who You Should Keep An Eye On This Year" /><meta property="og:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/09/gettyimages-1033321366.jpg?w=1500" /><meta property="og:image:secure_url" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/09/gettyimages-1033321366.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="994" /><meta property="og:description" content="Baseball season is finally here. The Baltimore Orioles will start their 2021 season Thursday at Fenway Park against the Boston Red Sox." /><meta property="og:type" content="article" /><meta property="og:url" content="https://baltimore.cbslocal.com/2021/03/31/baltimore-orioles-opening-day-2021-who-to-watch-for-this-season/" /><meta property="article:published_time" content="2021-03-31T15:43:29+00:00" /><meta property="article:suggested-social-copy" content="Baseball season is finally here. The Baltimore Orioles will start their 2021 season Thursday at Fenway Park against the Boston Red Sox." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="MLB,Orioles,Sports" /><meta property="article:publisher" content="http://www.facebook.com/CBSBaltimore" /><meta property="article:author" content="http://www.facebook.com/CBSBaltimore" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/09/gettyimages-1033321366.jpg?w=1500"><meta name="twitter:title" content="Orioles To Open Season Against Red Sox. Here&#039;s Who You Should Keep An Eye On This Year"/><meta name="twitter:description" content="Baseball season is finally here. The Baltimore Orioles will start their 2021 season Thursday at Fenway Park against the Boston Red Sox."/><meta name="twitter:site" content="/wjz"/>
<link rel="canonical" href="https://baltimore.cbslocal.com/2021/03/31/baltimore-orioles-opening-day-2021-who-to-watch-for-this-season/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://baltimore.cbslocal.com/2021/03/31/baltimore-orioles-opening-day-2021-who-to-watch-for-this-season/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/baltimore.cbslocal.com","url":"https:\/\/baltimore.cbslocal.com","name":"CBS Baltimore","foundingDate":"1941-07-01T14:30:00+00:00","sameAs":"http:\/\/wjz.com","logo":{"@type":"ImageObject","url":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2018\/07\/3_baltimore_cbs13_wjz.png?w=258"}},"url":"https:\/\/baltimore.cbslocal.com\/2021\/03\/31\/baltimore-orioles-opening-day-2021-who-to-watch-for-this-season\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/baltimore.cbslocal.com\/2021\/03\/31\/baltimore-orioles-opening-day-2021-who-to-watch-for-this-season\/"},"headline":"Orioles To Open Season Against Red Sox. Here&#8217;s Who You Should Keep An Eye On This Year","description":"Baseball season is finally here. The Baltimore Orioles will start their 2021 season Thursday at Fenway Park against the Boston Red Sox.","image":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2018\/09\/gettyimages-1033321366.jpg?w=1500","keywords":["MLB","Orioles","Sports","Baltimore","Baltimore News","Baltimore Orioles","Baltimore Orioles Opening Day 2021","boston red sox","Brandon Hyde","Local TV","mlb","opening Day","Opening Day 2021","Orioles rebuild","Talkers","CBS Baltimore Staff","sports","Orioles To Open Season Against Red Sox. Here's Who You Should Keep An Eye On This Year"],"datePublished":"2021-03-31T15:43:29+00:00","dateModified":"2021-03-31T15:43:29+00:00","author":{"@type":"Person","name":"CBS Baltimore Staff"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.BALTIMORE","sports",["oriolestoopenseasonagainstredsoxhereswhoyoushouldkeepaneyeonthisyear","post","article","mlb","orioles","sports","baltimore","baltimorenews","baltimoreorioles","baltimoreoriolesopeningday2021","bostonredsox","brandonhyde","localtv","openingday","openingday2021","oriolesrebuild","talkers","cbsbaltimorestaff","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("3");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-63" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-63" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"mlb;orioles;sports;","dimension2":"article"});gtag("config","UA-2438645-63");</script>

<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=32" sizes="32x32" />
<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=180" />
<meta name="msapplication-TileImage" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}


#enable-comments-button {
    display: none;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Baseball season is finally here. The Baltimore Orioles will start their 2021 season Thursday at Fenway Park against the Boston Red Sox." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-934901 single-format-standard desktop-display-type  and-temp-wide w-breaking-news"><div id="wrapper" class="body-wrapper">

<div id="breaking-news"><div class="wrapper"><a href="https://baltimore.cbslocal.com/2021/03/31/covid-in-maryland-more-than-1-3k-new-cases-reported-wednesday-hospitalizations-flat/" title="COVID-19 In MD" class="cbs-thumbnail-link" ><div class="title-wrapper"><strong class="title">COVID-19 In MD</strong><em class="description">More Than 1.3K New Cases, Hospitalizations Flat, Positivity Rate Remains Above 5%</em></div></a></div></div><div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://baltimore.cbslocal.com" id="header-logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/07/3_baltimore_cbs13_wjz.png?w=258" alt="CBS Baltimore" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/sports/">Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="https://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="https://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1394/" title="Purple Connection" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Purple Connection</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/news/">Maryland News</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/tag/baltimore-news/" title="Baltimore News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore News</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/" title="Local News" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Local News</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/anne-arundel-county/" title="Anne Arundel County" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Anne Arundel County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-city/" title="Baltimore City" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Baltimore City</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-county/" title="Baltimore County" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Baltimore County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/carroll-county/" title="Carroll County" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Carroll County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/harford-county/" title="Harford County" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Harford County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/howard-county/" title="Howard County" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Howard County</strong></div></a><a href="https://baltimore.cbslocal.com/category/health" title="HealthWatch" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://baltimore.cbslocal.com/category/watch-listen/" title="Watch + Listen" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Watch + Listen</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/news/">Latest News</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/03/31/3-baltimore-corrections-officers-indicted-on-assault-misconduct-charges-including-1-choking-an-inmate-until-she-passed-out/" title="3 Baltimore Central Booking Corrections Officers Indicted, One For Allegedly Choking Inmate Until She Passed Out" class="cbs-thumbnail-link item-1617219050 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/03/jail.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">3 Baltimore Central Booking Corrections Officers Indicted, One For Allegedly Choking Inmate Until She Passed Out</strong><em class="description">Three Baltimore Central Booking corrections officers are accused of assault and misconduct charges this week, with one accused of choking an inmate until went unconscious. </em></div></a><a href="https://baltimore.cbslocal.com/2021/03/31/anne-arundel-county-police-launch-community-engagement-website-ahead-of-body-worn-camera-program/" title="Anne Arundel County Police Launch Community Engagement Website Ahead Of Body-Worn Camera Program" class="cbs-thumbnail-link item-1617217995 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/Anne-Arundel-County.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Anne Arundel County Police Launch Community Engagement Website Ahead Of Body-Worn Camera Program</strong><em class="description">The Anne Arundel County Police Department is entering the community engagement phase of its body worn camera program expected to launch in July.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="https://baltimore.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1394/" title="Purple Connection" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Purple Connection</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">WJZ On Demand Video</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1480350753" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="https://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="https://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/03/31/baltimore-orioles-opening-day-2021-who-to-watch-for-this-season/" title="Orioles To Open Season Against Red Sox. Here&#039;s Who You Should Keep An Eye On This Year" class="cbs-thumbnail-link item-1617219809 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/09/gettyimages-1033321366.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Orioles To Open Season Against Red Sox. Here&#039;s Who You Should Keep An Eye On This Year</strong><em class="description">Baseball season is finally here. The Baltimore Orioles will start their 2021 season Thursday at Fenway Park against the Boston Red Sox.</em></div></a><a href="https://baltimore.cbslocal.com/2021/03/31/marylands-brenda-frese-named-the-associated-press-womens-basketball-coach-of-the-year-for-second-time/" title="Maryland&#039;s Brenda Frese Named The Associated Press Women&#039;s Basketball Coach Of The Year For Second Time" class="cbs-thumbnail-link item-1617205783 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1231995675.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Maryland&#039;s Brenda Frese Named The Associated Press Women&#039;s Basketball Coach Of The Year For Second Time</strong><em class="description">Maryland&#039;s Brenda Frese named The Associated Press women&#039;s basketball coach of the year for second time in her career.</em></div></a><a href="https://baltimore.cbslocal.com/2021/03/30/panarin-has-goal-2-assists-as-rangers-handle-caps-5-2/" title="Panarin Has Goal, 2 Assists As Rangers Handle Caps 5-2" class="cbs-thumbnail-link item-1617157198 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1232030848.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Panarin Has Goal, 2 Assists As Rangers Handle Caps 5-2</strong><em class="description">Artemi Panarin had a goal and two assists and the New York Rangers scored five unanswered goals to beat the Washington Capitals 5-2 Tuesday night.</em></div></a><a href="https://baltimore.cbslocal.com/2021/03/30/rozier-scores-27-points-leads-hornets-past-wizards-114-104/" title="Rozier Scores 27 Points, Leads Hornets Past Wizards 114-104" class="cbs-thumbnail-link item-1617156932 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1310012349.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Rozier Scores 27 Points, Leads Hornets Past Wizards 114-104</strong><em class="description">Terry Rozier scored 27 points, Gordon Hayward had 26 points and a season-high 11 rebounds and the Charlotte Hornets beat the Washington Wizards 114-104 on Tuesday night.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Links</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/school-closings/" title="Maryland School Closings" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Maryland School Closings</strong></div></a><a href="https://baltimore.cbslocal.com/category/weather/weather-blog/" title="Weather Blog" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather Blog</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/5445667-wednesday-morning-weather-with-meteorologist-meg-mcnamara/" title="Wednesday Morning Weather With Meteorologist Meg McNamara" class="cbs-thumbnail-link item-1617189360 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/04F/C5B/04FC5BA6110041089A09EC115BC43D8E.jpg?Expires=1711843200&#038;KeyName=mcpkey1&#038;Signature=0Em1EN7xKSgtLiEI9zqWk_Vdb7s"></span></div><div class="title-wrapper"><strong class="title">Wednesday Morning Weather With Meteorologist Meg McNamara</strong><em class="description">Rain moves in today, and there is a chance for strong thunderstorms in some areas. Cloudy and breezy, with high temperatures in the upper 60&#039;s.</em></div><time datetime="2021-03-31T11:16:00+00:00" title="March 31, 2021 at 7:16 am">9 hours ago</time></a><a href="https://baltimore.cbslocal.com/video/5444767-bob-turk-has-an-updated-look-at-your-forecast/" title="Bob Turk Has An Updated Look At Your Forecast" class="cbs-thumbnail-link item-1617161040 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/46F/72F/46F72F2CBCF249439D8733E85CB9EBAB.jpg?Expires=1711843200&#038;KeyName=mcpkey1&#038;Signature=VU8rgjkMSY77pDXrWj0zThbasEw"></span></div><div class="title-wrapper"><strong class="title">Bob Turk Has An Updated Look At Your Forecast</strong><em class="description">Bob Turk Has An Updated Look At Your Forecast</em></div><time datetime="2021-03-31T03:24:00+00:00" title="March 30, 2021 at 11:24 pm">17 hours ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Stories</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/03/30/weather-blog-should-you-put-the-shovel-away/" title="Weather Blog: Should You Put The Shovel Away?" class="cbs-thumbnail-link item-1617110834 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2010/11/marty-bass.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Blog: Should You Put The Shovel Away?</strong><em class="description">This morning driving in I actually said to myself, “I think you can put the snow shovel away.”</em></div></a><a href="https://baltimore.cbslocal.com/2021/03/29/weather-blog-peak-bloom/" title="Weather Blog: Peak Bloom" class="cbs-thumbnail-link item-1617019381 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1134135087.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Blog: Peak Bloom</strong><em class="description">We received word today that the cherry blossoms around the Tidal Basin in DC are in full bloom.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/best-of/">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/03/26/mural-of-frederick-douglass-to-be-painted-by-michael-rosato-in-talbot-county/" title="Mural Of Frederick Douglass To Be Painted By Michael Rosato In Talbot County" class="cbs-thumbnail-link item-1616813118 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/Frederick-Douglass-mural.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Mural Of Frederick Douglass To Be Painted By Michael Rosato In Talbot County</strong><em class="description">Michael Rosato is a self-taught painter, a muralist of over 30 years, but he describes himself as a storyteller.</em></div></a><a href="https://baltimore.cbslocal.com/2021/03/26/baltimore-museum-of-art-to-reopen-to-public-with-covid-19-safety-measures-in-place/" title="Baltimore Museum Of Art To Reopen To Public With COVID-19 Safety Measures In Place" class="cbs-thumbnail-link item-1616794910 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/Baltimore-Museum-Of-Art.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Baltimore Museum Of Art To Reopen To Public With COVID-19 Safety Measures In Place</strong><em class="description">This weekend, the Baltimore Museum of Art is reopening to the public after being closed for months due to the COVID-19 pandemic. </em></div></a><a href="https://baltimore.cbslocal.com/2021/03/24/one-womans-dream-vacation-was-canceled-due-to-covid-instead-she-explored-baltimore-businesses/" title="One Woman&#039;s Dream Vacation Was Canceled Due To COVID. Instead, She Explored Baltimore Businesses" class="cbs-thumbnail-link item-1616619104 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/Elizabeth-Dickinson.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">One Woman&#039;s Dream Vacation Was Canceled Due To COVID. Instead, She Explored Baltimore Businesses</strong><em class="description">So many of us have had to cancel trips due to the COVID-19 pandemic. But when Elizabeth Dickinson&#039;s trip abroad was canceled, she decided to rediscover her hometown of Baltimore instead. </em></div></a><a href="https://baltimore.cbslocal.com/2021/03/19/chesapeake-blue-crab-spotted-on-shores-of-ireland/" title="Chesapeake Blue Crab Spotted Along Ireland Shore. How Local Experts Believe It Got There" class="cbs-thumbnail-link item-1616162153 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/blue-crab.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Chesapeake Blue Crab Spotted Along Ireland Shore. How Local Experts Believe It Got There</strong><em class="description">A Chesapeake blue crab was recently spotted on the shores of Ireland.</em></div></a><a href="https://baltimore.cbslocal.com/2021/03/18/dj-kopec-the-ulman-foundation-dance-party-fundraiser-latest/" title="DJ Kopec Hopes To Break $2M Mark Saturday With Another Virtual Dance Party Fundraiser" class="cbs-thumbnail-link item-1616106690 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/DJ-Kopec.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">DJ Kopec Hopes To Break $2M Mark Saturday With Another Virtual Dance Party Fundraiser</strong><em class="description">It was almost a year ago when we first introduced you to DJ Kopec, the Ellicott City-based man who has been throwing virtual dance parties for families and raising thousands of dollars for people in need. </em></div></a><a href="https://baltimore.cbslocal.com/2021/03/18/maryland-cancer-survivor-pays-it-forward-sends-more-than-1k-care-kits-to-patients-battling-disease/" title="Maryland Cancer Survivor Pays It Forward, Sends More Than 1K Care Kits To Patients Battling Disease" class="cbs-thumbnail-link item-1616104791 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/F7A6B1FE3A6D490E9ADE054E51116F41.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Maryland Cancer Survivor Pays It Forward, Sends More Than 1K Care Kits To Patients Battling Disease</strong><em class="description">A Maryland cancer survivor is making it her mission to spread joy and hope at hospitals locally and across the country through a simple but powerful care kit.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Contests &amp; More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/learn-about-us/">Station Info</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="WJZ 13" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">WJZ 13</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/03/31/bwi-to-reopening-long-term-a-parking-lot-on-april-1/" title="BWI To Reopening Long Term A Parking Lot On April 1" class="cbs-thumbnail-link item-1617214713 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2020/03/BWI.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">BWI To Reopening Long Term A Parking Lot On April 1</strong><em class="description">Baltimore-Washington International Thurgood Marshall Airport will reopening its long term parking lot starting Thursday.</em></div></a><a href="https://baltimore.cbslocal.com/2021/03/25/march-25-26-projected-to-be-busiest-travel-days-at-bwi-since-covid-pandemic-began-last-year/" title="March 25-26 Projected To Be Busiest Travel Days At BWI Since COVID Pandemic Began Last Year" class="cbs-thumbnail-link item-1616724009 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1186983690.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">March 25-26 Projected To Be Busiest Travel Days At BWI Since COVID Pandemic Began Last Year</strong><em class="description">Baltimore-Washington International Thurgood Marshall Airport officials say they are expected to have the busiest travel days of the COVID era this week.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Contests</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2021/03/04/paramount-plus-launch-shows-movies-live-sports-news-list/" title="LIST: Paramount+ Launches Offering Over 30,000 Episodes And Movies Plus Live News And Sports" class="cbs-thumbnail-link item-1614859247 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/PP.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">LIST: Paramount+ Launches Offering Over 30,000 Episodes And Movies Plus Live News And Sports</strong><em class="description">CBS All Access re-launches as Paramount+ on March 4th.</em></div></a><a href="https://baltimore.cbslocal.com/2021/02/25/black-history-oratory-competition-2021/" title="Winners Announced: WJZ&#039;s Black History Oratory Competition 2021" class="cbs-thumbnail-link item-1614315568 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/Oratory-competition.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Winners Announced: WJZ&#039;s Black History Oratory Competition 2021</strong><em class="description">WJZ&#039;s Annual Black History Oratory Competition.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519402862" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	<ul id="live"><li class="menu-item item-0 w-active"><a href="/live/channel/cbs-baltimore-live-video/" title="WJZ 13" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WJZ 13</strong><em class="description">Watch Now</em></div></a><div class="submenu"><div class="wrapper"><a class="live-now-text" href="/live/channel/cbs-baltimore-live-video/">Live News - WJZ at 4</a><div id="embed-list-1" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">4:00 PM</strong><em class="description">WJZ News @ 4PM</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">4:30 PM</strong><em class="description">WJZ News @ 4:30PM</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">5:00 PM</strong><em class="description">WJZ News @ 5PM</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">5:30 PM</strong><em class="description">WJZ News @ 5:30PM</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">6:00 PM</strong><em class="description">WJZ News @ 6PM</em></div></div></div>
</div></div><a class="view-all" href="http://baltimore.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	<a href="http://baltimore.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="39.290385" longitude="-76.612189" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://baltimore.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Orioles To Open Season Against Red Sox. Here&#8217;s Who You Should Keep An Eye On This Year</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><span class="post-personality">By <a href="https://baltimore.cbslocal.com/personality/cbs-baltimore-staff">CBS Baltimore Staff</a></span><time class="post-date">March 31, 2021 at 3:43 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://baltimore.cbslocal.com/tag/baltimore/">Baltimore</a>, <a href="https://baltimore.cbslocal.com/tag/baltimore-news/">Baltimore News</a>, <a href="https://baltimore.cbslocal.com/tag/baltimore-orioles/">Baltimore Orioles</a>, <a href="https://baltimore.cbslocal.com/tag/baltimore-orioles-opening-day-2021/">Baltimore Orioles Opening Day 2021</a>, <a href="https://baltimore.cbslocal.com/tag/boston-red-sox/">boston red sox</a>, <a href="https://baltimore.cbslocal.com/tag/brandon-hyde/">Brandon Hyde</a>, <a href="https://baltimore.cbslocal.com/tag/local-tv/">Local TV</a>, <a href="https://baltimore.cbslocal.com/tag/mlb/">mlb</a>, <a href="https://baltimore.cbslocal.com/tag/opening-day/">opening Day</a>, <a href="https://baltimore.cbslocal.com/tag/opening-day-2021/">Opening Day 2021</a>, <a href="https://baltimore.cbslocal.com/tag/orioles-rebuild/">Orioles rebuild</a>, <a href="https://baltimore.cbslocal.com/tag/talkers/">Talkers</a></div></div></section><section id="column_block_2" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-send2news  close-btn" id="featured-media"><div class="s2nPlayer k-hZsoTmvZ" data-type="float"></div><script src="https://embed.sendtonews.com/player3/embedcode.js?fk=hZsoTmvZ&cid=5121&sound=on&floatwidth=430&offsetx=15&offsety=80&floatposition=bottom-right" data-type="s2nScript"></script></section>
<div class="main-story-wrapper"><p><strong>BALTIMORE (AP/WJZ) &#8212; </strong>Baseball season is finally here. The Baltimore Orioles will start their 2021 season Thursday at Fenway Park against the Boston Red Sox.</p>
<p>The Orioles aren&#8217;t expected to be playoff contenders, but there are still plenty of reasons to be excited to watch their games this year.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://baltimore.cbslocal.com/2021/03/31/3-baltimore-corrections-officers-indicted-on-assault-misconduct-charges-including-1-choking-an-inmate-until-she-passed-out/" target="_blank">3 Baltimore Central Booking Corrections Officers Indicted, One For Allegedly Choking Inmate Until She Passed Out</a>
<p>It&#8217;s year three of the team&#8217;s rebuild, and while the Orioles have plenty of young talent, there are also veterans on the roster.</p>
<p>Orioles manager Brandon Hyde said he likes the mix that&#8217;s come together in six weeks of Spring Training.</p>
<blockquote class="twitter-tweet" data-width="420" data-dnt="true">
<p lang="en" dir="ltr">Next stop:</p>
<p>Opening Day <a href="https://t.co/jHK3aSD0CI">pic.twitter.com/jHK3aSD0CI</a></p>
<p>&mdash; Baltimore Orioles 😷 (@Orioles) <a href="https://twitter.com/Orioles/status/1376672259667005445?ref_src=twsrc%5Etfw">March 29, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>&#8220;I think we have a nice blend right now,&#8221; Hyde said. &#8220;We have some young guys, and we got some guys that have been around for a while which is always nice to have that mixture. I really like our veteran guys.&#8221;</p>
<p><strong>HERE&#8217;S WHO TO WATCH FOR IN 2021: </strong></p>
<p><em><strong>Trey Mancini, Right Fielder</strong></em></p>
<p>Trey Mancini had surgery for colon cancer last year on the same day Major League Baseball shut down spring training due to the COVID-19 pandemic.</p>
<div id="attachment_928215" style="width: 430px" class="wp-caption alignleft"><img aria-describedby="caption-attachment-928215" loading="lazy" class="size-full wp-image-928215" src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg" alt="" width="420" height="236" srcset="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg 1280w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg?resize=150,84 150w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg?resize=300,169 300w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg?resize=768,432 768w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg?resize=620,349 620w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg?resize=1024,576 1024w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg?resize=640,360 640w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg?resize=310,174 310w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg?resize=1138,640 1138w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/snapshot-11-4.jpg?resize=320,180 320w" sizes="(max-width: 420px) 100vw, 420px" /><p id="caption-attachment-928215" class="wp-caption-text">Photo Credit: Baltimore Orioles</p></div>
<p>Baseball returned later in 2020 and Mancini is back now, healthy and ready to go.</p>
<p>Mancini had a breakout season in 2019, batting .291 with 35 homers and 97 RBIs.</p>
<p>He singled in his first at-bat in Spring Training and got a standing ovation from fans at the ballpark.</p>
<p>Mancini said he plans to take his mission beyond baseball and promote cancer awareness.</p>
<p>His foundation is also dedicated to feeding needy schoolchildren in Baltimore through the &#8220;Blessings in a Backpack&#8221; program.</p>
<p>&#8212;</p>
<p><em><strong>Matt Harvey, Pitcher </strong></em></p>
<p>Matt Harvey is back in the major leagues with the Orioles.</p>
<div id="attachment_933982" style="width: 430px" class="wp-caption alignright"><img aria-describedby="caption-attachment-933982" loading="lazy" class="size-full wp-image-933982" src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg" alt="" width="420" height="279" srcset="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg 3798w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=150,100 150w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=300,200 300w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=768,511 768w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=620,413 620w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=1536,1022 1536w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=2048,1363 2048w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=1024,681 1024w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=640,426 640w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=310,207 310w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=962,640 962w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=1539,1024 1539w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=222,148 222w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1307271795.jpg?resize=1500,998 1500w" sizes="(max-width: 420px) 100vw, 420px" /><p id="caption-attachment-933982" class="wp-caption-text">SARASOTA, FLORIDA &#8211; MARCH 15: Matt Harvey #32 of the Baltimore Orioles throws a pitch during the first inning against the Pittsburgh Pirates during a spring training game at Ed Smith Stadium on March 15, 2021 in Sarasota, Florida. (Photo by Douglas P. DeFelice/Getty Images)</p></div>
<p>Baltimore selected the contract of the 31-year-old right-hander one week before its season opener at Boston.</p>
<p>Harvey gets a $1 million, one-year contract and the chance to earn performance bonuses.</p>
<p>He was 0-3 with an 11.57 ERA in four starts and three relief appearances last year for the Kansas City Royals.</p>
<p>He has a 5.40 ERA in three spring training appearances this year, allowing six runs and 10 hits in 10 innings with six strikeouts and one walk.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://baltimore.cbslocal.com/2021/03/31/anne-arundel-county-police-launch-community-engagement-website-ahead-of-body-worn-camera-program/" target="_blank">Anne Arundel County Police Launch Community Engagement Website Ahead Of Body-Worn Camera Program</a>
<p>An All-Star with the New York Mets in 2013, Harvey was derailed by Tommy John surgery in 2013 and an operation in 2016 to correct thoracic outlet syndrome, a condition in which blood vessels or nerves are compressed.</p>
<p>&#8212;</p>
<p><em><strong>Freddy Galvis, Shortstop </strong></em></p>
<p>Freddy Galvis is expected to take over as Baltimore&#8217;s shortstop for José Iglesias. Galvis played 33 games at shortstop last season and 16 at second base for the Cincinnati Reds.</p>
<div id="attachment_922763" style="width: 430px" class="wp-caption alignleft"><img aria-describedby="caption-attachment-922763" loading="lazy" class="size-full wp-image-922763" src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg" alt="" width="420" height="280" srcset="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg 4155w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=150,100 150w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=300,200 300w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=768,512 768w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=620,413 620w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=1536,1024 1536w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=2048,1365 2048w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=1024,683 1024w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=640,427 640w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=310,207 310w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=960,640 960w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=222,148 222w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/01/GettyImages-1228830056.jpg?resize=1500,1000 1500w" sizes="(max-width: 420px) 100vw, 420px" /><p id="caption-attachment-922763" class="wp-caption-text">ATLANTA, GA OCTOBER 01: Cincinnati Reds shortstop Freddy Galvis (3) hits a single during the National League Wild Card Series game between the Cincinnati Reds and the Atlanta Braves. (Photo by Rich von Biberstein/Icon Sportswire via Getty Images)</p></div>
<p>Galvis has a .247 career batting average with 95 home runs and 386 RBIs. A journeyman who&#8217;s headed to his fifth big league team, Galvis started with the Phillies, made a one-year stop with San Diego in 2018 and played in Toronto before joining Cincinnati during the 2019 season.</p>
<p>His best season offensively was in 2019, when he hit 23 homers with 70 RBIs.</p>
<p>Baltimore signed him primarily for his ability to deftly play in the middle of the infield. He has a .984 fielding percentage as a shortstop over 801 games.</p>
<p>&#8212;</p>
<p><em><strong>Ryan Mountcastle, Left Fielder </strong></em></p>
<p>The Orioles are showing progress in developing their young players.</p>
<p>Some made their Major League debuts last season, and now, they&#8217;re getting ready for an encore.</p>
<div id="attachment_928714" style="width: 430px" class="wp-caption alignleft"><img aria-describedby="caption-attachment-928714" loading="lazy" class="size-full wp-image-928714" src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg" alt="" width="420" height="280" srcset="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg 3600w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=150,100 150w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=300,200 300w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=768,512 768w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=620,413 620w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=1536,1024 1536w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=2048,1365 2048w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=1024,683 1024w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=640,427 640w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=310,207 310w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=960,640 960w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=222,148 222w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/02/GettyImages-1276526657.jpg?resize=1500,1000 1500w" sizes="(max-width: 420px) 100vw, 420px" /><p id="caption-attachment-928714" class="wp-caption-text">BALTIMORE, MD &#8211; SEPTEMBER 19: Ryan Mountcastle #6 of the Baltimore Orioles takes a swing during a baseball game against the Tampa Bay Rays at Oriole Park at Camden Yards on September 19, 2020 in Baltimore, Maryland. (Photo by Mitchell Layton/Getty Images)</p></div>
<p>Ryan Mountcastle has graduated from prospect to time to show he&#8217;s a big-time pro.</p>
<p>He showed plenty of promise with a strong Major League debut in the pandemic-abreviated season last year.</p>
<p>Mountcastle&#8217;s been on the radar and on the rise since the Orioles picked him as a first-round draft choice six years ago when he was an 18-year-old high schooler.</p>
<p>Drafted as a shortstop, he&#8217;s transitioned to outfielder and can play some first base.</p>
<p>But most of all, Mountcastle can hit. His batting average, home runs and runs driven in were all impressive in his first 35 games as a big leaguer.</p>
<p>Mountcastle is projected to be the Orioles&#8217; starting left fielder, and because he played in just 35 games last season, he&#8217;s classified as a &#8220;rookie&#8221; this year.</p>
<p>&#8212;</p>
<p><em><strong>John Means, Pitcher </strong></em></p>
<div id="attachment_791523" style="width: 430px" class="wp-caption alignright"><img aria-describedby="caption-attachment-791523" loading="lazy" class="size-full wp-image-791523" src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg" alt="" width="420" height="278" srcset="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg 3000w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=150,99 150w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=300,199 300w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=768,509 768w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=620,411 620w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=1536,1017 1536w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=2048,1356 2048w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=640,424 640w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=966,640 966w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=1024,678 1024w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=1546,1024 1546w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=222,148 222w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/04/gettyimages-1139159054.jpg?resize=1500,994 1500w" sizes="(max-width: 420px) 100vw, 420px" /><p id="caption-attachment-791523" class="wp-caption-text">BALTIMORE, MD &#8211; APRIL 24: John Means #67 of the Baltimore Orioles pitches in the first inning against the Chicago White Sox at Oriole Park at Camden Yards on April 24, 2019 in Baltimore, Maryland. (Photo by Greg Fiume/Getty Images)</p></div>
<p>LHP John Means is 27. Even a little time in the Majors makes him a mentor to his young teammates.</p>
<p>&#8220;It&#8217;s crazy the fact that I have two years of service time and I&#8217;m stepping into a leadership role,&#8221; Means said. &#8220;But that&#8217;s the way this team works and that&#8217;s the way it needs to be. I&#8217;m excited to kind of take that role on.&#8221;</p>
<p>Manager Brandon Hyde said the veterans on the team are they&#8217;re like coaches to help to move the young players forward.</p>
<p>The Orioles have one of the youngest rosters in Major League Baseball, and that&#8217;s by design.</p><strong style="color: black; float: left; padding-right: 5px;">MORE NEWS: </strong><a style="display: block; margin-bottom: 25px;" href="https://baltimore.cbslocal.com/2021/03/31/baltimore-police-need-help-to-id-two-people-who-they-believe-may-be-in-danger/" target="_blank">Baltimore Police Need Help To ID Two People Who They Believe May Be In Danger</a>
<p>The Orioles want youth to build their future.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3weepNl"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3weepNl"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3weepNl"></a></span>
			</div>
		
			</div>
</div></div></div><div id="app-promo-wrapper"><a href="https://apps.cbslocal.com/baltimore/" data-ios="https://apps.apple.com/us/app/cbs-baltimore/id1511220375" data-android="https://play.google.com/store/apps/details?id=com.wjz.android.news" target="_blank"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/app-promos/baltimore.jpg"/></a></div><div id="personality-credits-container" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>CBS </span> Baltimore Staff</h4></header><div class="block-content-wrapper and-list layout-catalog aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" id="personality-credits" data-social-links="{&quot;twitter_url&quot;:&quot;twitter.com\/wjz&quot;,&quot;facebook_url&quot;:&quot;https:\/\/www.facebook.com\/CBSBaltimore&quot;,&quot;instagram_url&quot;:&quot;https:\/\/www.instagram.com\/wjztv\/&quot;,&quot;email_address&quot;:&quot;cbsbaltimore@wjz.com&quot;}" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/01/wjz13logo.jpg?w=625&#038;h=352&#038;crop=1"></span></div><div class="title-wrapper"><em class="description"><a href="https://baltimore.cbslocal.com/personality/cbs-baltimore-staff/" id="more-from-personality"><span>More from</span> <strong>CBS Baltimore Staff</strong></a></em></div></div></div>
</div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-3"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/CBSBaltimore" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="http://twitter.com/wjz" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="http://youtube.com/user/CBSBaltimore" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="https://www.reddit.com/user/cbsbaltimore" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/wjz-tv/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=baltimore"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://baltimore.cbslocal.com/2021/03/29/tara-savannah-paynes-death-ruled-accidental-latest/" title="Baltimore Police Believe Tara Savannah Payne&#039;s Death Was Accidental, No Threat To The Public" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/Savannah-Payne.jpg?resize=55%2C55&#038;ssl=1" alt="Baltimore Police Believe Tara Savannah Payne&#039;s Death Was Accidental, No Threat To The Public" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/29/tara-savannah-paynes-death-ruled-accidental-latest/" title="Baltimore Police Believe Tara Savannah Payne&#039;s Death Was Accidental, No Threat To The Public" class="bump-view" data-bump-view="tp">Baltimore Police Believe Tara Savannah Payne&#039;s Death Was Accidental, No Threat To The Public</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/03/30/baltimore-man-selling-goth-horror-themed-house-full-of-black-decor/" title="Baltimore Man Selling Goth, Horror-Themed House Full Of Black Decor" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/Goth-House-for-sale-1.jpg?resize=55%2C55&#038;ssl=1" alt="Baltimore Man Selling Goth, Horror-Themed House Full Of Black Decor" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/30/baltimore-man-selling-goth-horror-themed-house-full-of-black-decor/" title="Baltimore Man Selling Goth, Horror-Themed House Full Of Black Decor" class="bump-view" data-bump-view="tp">Baltimore Man Selling Goth, Horror-Themed House Full Of Black Decor</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/03/30/rodsheta-myers-killed-2-year-old-girl-among-3-injured-after-wrong-way-crash-on-i-795n-in-baltimore-county/" title="Woman Killed, 2-Year-Old Girl Among 3 Injured, After Wrong-Way Crash On I-795N In Baltimore County" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2020/01/Police-lights.jpg?resize=55%2C55&#038;ssl=1" alt="Woman Killed, 2-Year-Old Girl Among 3 Injured, After Wrong-Way Crash On I-795N In Baltimore County" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/30/rodsheta-myers-killed-2-year-old-girl-among-3-injured-after-wrong-way-crash-on-i-795n-in-baltimore-county/" title="Woman Killed, 2-Year-Old Girl Among 3 Injured, After Wrong-Way Crash On I-795N In Baltimore County" class="bump-view" data-bump-view="tp">Woman Killed, 2-Year-Old Girl Among 3 Injured, After Wrong-Way Crash On I-795N In Baltimore County</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/03/30/got-the-covid-vaccine-heres-how-to-keep-that-vaccination-card-safe/" title="Got The COVID Vaccine? Here&#039;s How To Keep That Vaccination Card Safe" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/GettyImages-1231929386.jpg?resize=55%2C55&#038;ssl=1" alt="Got The COVID Vaccine? Here&#039;s How To Keep That Vaccination Card Safe" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/30/got-the-covid-vaccine-heres-how-to-keep-that-vaccination-card-safe/" title="Got The COVID Vaccine? Here&#039;s How To Keep That Vaccination Card Safe" class="bump-view" data-bump-view="tp">Got The COVID Vaccine? Here&#039;s How To Keep That Vaccination Card Safe</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/03/29/2-sisters-from-maryland-among-3-dead-in-florida-van-crash/" title="2 Sisters From Maryland Among 3 Dead In Florida Van Crash" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/07/crash.jpg?resize=55%2C55&#038;ssl=1" alt="2 Sisters From Maryland Among 3 Dead In Florida Van Crash" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/29/2-sisters-from-maryland-among-3-dead-in-florida-van-crash/" title="2 Sisters From Maryland Among 3 Dead In Florida Van Crash" class="bump-view" data-bump-view="tp">2 Sisters From Maryland Among 3 Dead In Florida Van Crash</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/03/29/vigil-for-tara-savannah-payne-to-be-held-monday-night-in-baltimore/" title="Family, Friends Gather To Remember Tara Savannah Payne With Vigil In Baltimore Monday Night" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/snapshot-2021-03-30T002346.523.jpg?resize=55%2C55&#038;ssl=1" alt="Family, Friends Gather To Remember Tara Savannah Payne With Vigil In Baltimore Monday Night" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/29/vigil-for-tara-savannah-payne-to-be-held-monday-night-in-baltimore/" title="Family, Friends Gather To Remember Tara Savannah Payne With Vigil In Baltimore Monday Night" class="bump-view" data-bump-view="tp">Family, Friends Gather To Remember Tara Savannah Payne With Vigil In Baltimore Monday Night</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/03/29/baltimore-county-police-identify-joshua-green-shooting-victims-silvesta-day-jr-alpha-smith-douglas-green-olivia-green/" title="Mourners Remember Victims of Baltimore County Shooting Spree; Alleged Gunman’s Relative Says He ‘Struggled With His Mental Health’" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/ESSEX-TRIPLE-SHOOTING-2.jpg?resize=55%2C55&#038;ssl=1" alt="Mourners Remember Victims of Baltimore County Shooting Spree; Alleged Gunman’s Relative Says He ‘Struggled With His Mental Health’" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/29/baltimore-county-police-identify-joshua-green-shooting-victims-silvesta-day-jr-alpha-smith-douglas-green-olivia-green/" title="Mourners Remember Victims of Baltimore County Shooting Spree; Alleged Gunman’s Relative Says He ‘Struggled With His Mental Health’" class="bump-view" data-bump-view="tp">Mourners Remember Victims of Baltimore County Shooting Spree; Alleged Gunman’s Relative Says He ‘Struggled With His Mental Health’</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/03/29/sacramento-barking-dog-owner-anonymous-amazon-shock-collar/" title="Pandemic Pettiness: Sacramento Neighbor Receives ‘Shock Collar’ in Anonymous Amazon Delivery" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/barking-dog-owner.jpg?resize=55%2C55&#038;ssl=1" alt="Pandemic Pettiness: Sacramento Neighbor Receives ‘Shock Collar’ in Anonymous Amazon Delivery" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/29/sacramento-barking-dog-owner-anonymous-amazon-shock-collar/" title="Pandemic Pettiness: Sacramento Neighbor Receives ‘Shock Collar’ in Anonymous Amazon Delivery" class="bump-view" data-bump-view="tp">Pandemic Pettiness: Sacramento Neighbor Receives ‘Shock Collar’ in Anonymous Amazon Delivery</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/03/30/covid-in-maryland-903-new-cases-positivity-rate-above-5/" title="Positivity Rate Above 5% As Officials Say Young People Are Driving Maryland&#039;s COVID Case Spike" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2020/07/hypatia-h_8c03c7a427f7f9d90c76db22078067bd-h_cf41375b632c8c721b2f177fcac52b94.jpg?resize=55%2C55&#038;ssl=1" alt="Positivity Rate Above 5% As Officials Say Young People Are Driving Maryland&#039;s COVID Case Spike" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/30/covid-in-maryland-903-new-cases-positivity-rate-above-5/" title="Positivity Rate Above 5% As Officials Say Young People Are Driving Maryland&#039;s COVID Case Spike" class="bump-view" data-bump-view="tp">Positivity Rate Above 5% As Officials Say Young People Are Driving Maryland&#039;s COVID Case Spike</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/03/30/royal-farms-devastated-by-shooting-at-essex-store-state-police-say-alleged-gunmans-background-check-revealed-no-issues/" title="Royal Farms ‘Devastated’ By Shooting At Essex Store; State Police Say Alleged Gunman’s Background Check Revealed No Issues" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/03/Royal-Farms-shooting.jpg?resize=55%2C55&#038;ssl=1" alt="Royal Farms ‘Devastated’ By Shooting At Essex Store; State Police Say Alleged Gunman’s Background Check Revealed No Issues" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/03/30/royal-farms-devastated-by-shooting-at-essex-store-state-police-say-alleged-gunmans-background-check-revealed-no-issues/" title="Royal Farms ‘Devastated’ By Shooting At Essex Store; State Police Say Alleged Gunman’s Background Check Revealed No Issues" class="bump-view" data-bump-view="tp">Royal Farms ‘Devastated’ By Shooting At Essex Store; State Police Say Alleged Gunman’s Background Check Revealed No Issues</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2017/10/baltimore.png" alt="CBS Baltimore" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/CBSBaltimore" class="facebook" target="_blank">Facebook</a><a href="http://twitter.com/wjz" class="twitter" target="_blank">Twitter</a><a href="http://youtube.com/user/CBSBaltimore" class="youtube" target="_blank">YouTube</a><a href="https://www.reddit.com/user/cbsbaltimore" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/wjz-tv/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/tag/baltimore-news/" title="Baltimore News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore News</strong></div></a><a href="https://baltimore.cbslocal.com/category/weather/" title="Maryland Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Maryland Weather</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/national/" title="National" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">National</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/" title="Local" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Local</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://baltimore.cbslocal.com//category/health/" title="HealthWatch" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Baltimore Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore Sports</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/822/" title="Fan Cam" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Fan Cam</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Seen On WJZ</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/program/1259/" title="Morning Edition" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/677/" title="Manic Monday" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Manic Monday</strong></div></a><a href="https://baltimore.cbslocal.com/category/its-academic/" title="It&#039;s Academic" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">It&#039;s Academic</strong></div></a><a href="https://baltimore.cbslocal.com/category/on-time/" title="On Time" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">On Time</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Connect With CBS Baltimore</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2010/11/24/get-your-news-on-the-go/" title="News On The Go" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News On The Go</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="Station Info" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Station Info</strong></div></a><a href="https://baltimore.cbslocal.com/contact-us/" title="Contact Us" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-4" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://baltimore.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://baltimore.cbslocal.com/school-closings/" title="Baltimore School Closings" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Baltimore School Closings</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-5" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://privacy.cbs/personalizedads" title="Ad Choices" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ad Choices</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Baltimore" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=baltimore.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-207290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207290"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-207291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207291"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-839526" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-839526"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-839527" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-839527"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-533039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-533039"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-745179" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-745179"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/08/qpdc-2018-wjz-tv.pdf">MD Digital Political Ad Disclosures</a></li>
<li id="menu-item-788013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788013"><a href="https://publicfiles.fcc.gov/tv-profile/wjz-tv">Public File for WJZ-TV / WJZ-13</a></li>
<li id="menu-item-788792" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788792"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-906064" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-906064"><a href="https://baltimore.cbslocal.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-789850" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-789850"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2020/05/WJZJune2020-2-1.pdf">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://baltimore.cbslocal.com/wp-admin/admin-ajax.php";
</script>
<link rel='stylesheet' id='screen-css-0' href='https://baltimore.cbslocal.com/_static/??-eJyljFsKgCAQRTeUDUJBfkRr0XEowVFJw+03RCuov/s6F3pRmFOj1KAdxFQBXVUxo40QEsbLS0TsyEtTX6liqG0UO8B3XjguFn/9dLKyPlUPfqfnaeNVz0ZrM+l5uQEy8FF4' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563306323g' type='text/css' media='all' />
<script type='text/javascript' src='https://baltimore.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1615321553g'></script>
<script src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1' id='cbs-weather-widget-js'></script>
<script src='https://stats.wp.com/e-202113.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.5.2',blog:'162246106',post:'934901',tz:'-4',srv:'baltimore.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246106', '934901' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>