<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://baltimore.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="fort worth, titus akins, holly beverly, murder-suicide, dfw news, wallace akins, fort worth murder suicide, fort worth news" />
<meta name="keywords" content="fort worth, titus akins, holly beverly, murder-suicide, dfw news, wallace akins, fort worth murder suicide, fort worth news" />
<meta property="fb:pages" content="261323008476" />
<meta name="facebook-domain-verification" content="iiv3w5z7llhkla8zlctcj5kqsjba3k" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>&#8216;Time Never Waits&#8217;: Father Of Titus Akins, Teen Killed In Murder-Suicide, Says He Sought To Reconnect With Son &#8211; CBS Baltimore</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Baltimore &raquo; Feed" href="https://baltimore.cbslocal.com/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/_static/??-eJytUEkOwjAM/BDBUFDhgnhLFlOiOnaURf0+oeXSE1TiZHvsGc0YpqiscEEuUJ4YMIM1WZFYTeDZUnVvKGd4iBRM+9bu4CcSBoNu4caEJNp9J0eqg+cMQVyltjEJ9eh5UIzTIrVCtgvqj6NWt5PnAxU06wHTLLNCVEs9FokbfrRo1GBYe1Lkefy/K6Q2cZnz3sPt2Hddf74eTpcXjLi+Fg==' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://baltimore.cbslocal.com/_static/??-eJyNy1sOQEAMQNENGWXI8CPWMqpB0nkkrYjdMxsQvzfnwpUNpqgUFXSnQAK4iOGEnkH0ZqpRpIIvdkTkcy1JBLLfyCiFzF5/vGUhfmNUKXoOU+usdf3YdMMDIbo5Gw==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://baltimore.cbslocal.com/_static/??-eJydUttOwzAM/SHcQDeN8YD4FjcxXVhuStxV/XvclW4aFbDyEMl2fI6PL6pPoGNgCqz4QJ6K0k0BFzU6lVzX2lCUj6Zz8nNOAI8BW8pKF4kMibaVWA/qNyIbtOvMGBJMbw0Bk08OmcpKcMLMd2C+Ky+HmFnHmeXqrihPviEz4c8mOFsYNDK62K5sQ7qw2hGclsObpctjbDN6eCcyk+wGrtEa6srbcMHf8BuRphopfBSVTcY8qMKDoxvE3dOTjbXEl+2N9oLEdzDDPogTSuWXar+g4JggxSLWpGe1luUNeszHkXrK19HF/I8L+Ys3nij32fJS8g+djxRf/gh5869Pu7rebfePm+dPARxLmQ==' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://baltimore.cbslocal.com/_static/??-eJy1UEEOwjAM+xBdYaDBBfGW0mWjJU3LkoL2e8rEgd0GEicrju1Y0Y+kbCQBEi0XCMDanllhtAa1I4u5LZRnnSKOnUOsgqPK80ovNfpFjoS5d8Q6xDZj2Zh2MhdQ9/ozYRZ9yzCMb1gkUsH1gxH4qdMkUMGQ6WF4Rc8IVe5dJaavntNlsuIi8T8KAZaJhEvuKRw3TV03u8N6u/dPsM66OQ=='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7.2' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://baltimore.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILbChwQXxLV0adanSdCIt+32qiQsXdrPsZxu2tcOshbRAWSiRAc7WSUYnwIpSfbOigfMLGb+pT6x9tBP8KzY+SJ6dHJI/F6/CKHTYWaUGVoOUfZWWbOwDlX3iK9vEMz0u0zBM1/t5vMUPCrBU0Q=='></script>
<link rel="https://api.w.org/" href="https://baltimore.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://baltimore.cbslocal.com/wp-json/wp/v2/posts/947243" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://baltimore.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://baltimore.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://cbsloc.al/34NV09x' />
<link rel="alternate" type="application/json+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2021%2F06%2F04%2Fwallace-akins-titus-akins-beverly-holly-fort-worth-murder-suicide%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2021%2F06%2F04%2Fwallace-akins-titus-akins-beverly-holly-fort-worth-murder-suicide%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
		
<meta property="og:title" content="&#039;Time Never Waits&#039;: Father Of Titus Akins, Teen Killed In Murder-Suicide, Says He Sought To Reconnect With Son" /><meta property="og:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/download-2.png?w=817" /><meta property="og:image:secure_url" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/download-2.png?w=817" /><meta property="og:image:width" content="817" /><meta property="og:image:height" content="460" /><meta property="og:description" content="Wallace Akins sought to reconnect with his son, Titus, but will not get that chance after the teenager was killed in a murder-suicide in Fort Worth earlier this week." /><meta property="og:type" content="article" /><meta property="og:url" content="https://baltimore.cbslocal.com/2021/06/04/wallace-akins-titus-akins-beverly-holly-fort-worth-murder-suicide/" /><meta property="article:published_time" content="2021-06-04T17:18:42+00:00" /><meta property="article:suggested-social-copy" content="Wallace Akins sought to reconnect with his son, Titus, but will not get that chance after the teenager was killed in a murder-suicide in Fort Worth earlier this week." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Around the Nation" /><meta property="article:publisher" content="http://www.facebook.com/CBSBaltimore" /><meta property="article:author" content="http://www.facebook.com/CBSBaltimore" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/download-2.png?w=817"><meta name="twitter:title" content="&#039;Time Never Waits&#039;: Father Of Titus Akins, Teen Killed In Murder-Suicide, Says He Sought To Reconnect With Son"/><meta name="twitter:description" content="Wallace Akins sought to reconnect with his son, Titus, but will not get that chance after the teenager was killed in a murder-suicide in Fort Worth earlier this week."/><meta name="twitter:site" content="/wjz"/>
<link rel="canonical" href="https://dfw.cbslocal.com/2021/06/03/wallace-akins-titus-akins-beverly-holly-murder-suicide/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://baltimore.cbslocal.com/2021/06/04/wallace-akins-titus-akins-beverly-holly-fort-worth-murder-suicide/?amp">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/baltimore.cbslocal.com","url":"https:\/\/baltimore.cbslocal.com","name":"CBS Baltimore","foundingDate":"1941-07-01T14:30:00+00:00","sameAs":"http:\/\/wjz.com","logo":{"@type":"ImageObject","url":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2018\/07\/3_baltimore_cbs13_wjz.png?w=258"}},"url":"https:\/\/baltimore.cbslocal.com\/2021\/06\/04\/wallace-akins-titus-akins-beverly-holly-fort-worth-murder-suicide\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/baltimore.cbslocal.com\/2021\/06\/04\/wallace-akins-titus-akins-beverly-holly-fort-worth-murder-suicide\/"},"headline":"&#8216;Time Never Waits&#8217;: Father Of Titus Akins, Teen Killed In Murder-Suicide, Says He Sought To Reconnect With Son","description":"Wallace Akins sought to reconnect with his son, Titus, but will not get that chance after the teenager was killed in a murder-suicide in Fort Worth earlier this week.","image":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2021\/06\/download-2.png?w=817","keywords":["Around the Nation","Around The Nation","'Time Never Waits': Father Of Titus Akins, Teen Killed In Murder-Suicide, Says He Sought To Reconnect With Son"],"datePublished":"2021-06-04T17:18:42+00:00","dateModified":"2021-06-04T17:18:42+00:00","author":{"@type":"Organization","name":"CBS Baltimore"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.BALTIMORE","default",["timeneverwaitsfatheroftitusakinsteenkilledinmurdersuicidesayshesoughttoreconnectwithson","post","article","aroundthenation","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("3");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-2438645-63" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-2438645-63" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"around-the-nation;","dimension2":"article"});gtag("config","UA-2438645-63");</script>

<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=32" sizes="32x32" />
<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=180" />
<meta name="msapplication-TileImage" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}


#enable-comments-button {
    display: none;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Wallace Akins sought to reconnect with his son, Titus, but will not get that chance after the teenager was killed in a murder-suicide in Fort Worth earlier this week." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-947243 single-format-standard desktop-display-type  and-temp-wide w-breaking-news"><div id="wrapper" class="body-wrapper">

<div id="breaking-news"><div class="wrapper"><a href="https://baltimore.cbslocal.com/2021/06/02/covid-19-in-maryland-cases-fall-below-100-for-1st-time-since-early-days-of-pandemic/" title="COVID LATEST" class="cbs-thumbnail-link" ><div class="title-wrapper"><strong class="title">COVID LATEST</strong><em class="description">Daily Positivity Rate Drops Below 1%</em></div></a></div></div><div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://baltimore.cbslocal.com" id="header-logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/07/3_baltimore_cbs13_wjz.png?w=258" alt="CBS Baltimore" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list column-count-2 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="https://baltimore.cbslocal.com/category/sports/">Sports</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland Terps" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland Terps</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="https://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="https://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a></div>
</div></div><div id="embed-list-2" class="embed-item embed-list column-count-1 block-type-wpmenu" ><div class="wrapper">
<div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1394/" title="Purple Connection" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Purple Connection</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-3" class="embed-item embed-list column-count-2 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="https://baltimore.cbslocal.com/category/news/">Maryland News</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/tag/baltimore-news/" title="Baltimore News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore News</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/" title="Local News" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Local News</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/anne-arundel-county/" title="Anne Arundel County" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Anne Arundel County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-city/" title="Baltimore City" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Baltimore City</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-county/" title="Baltimore County" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Baltimore County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/carroll-county/" title="Carroll County" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Carroll County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/harford-county/" title="Harford County" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Harford County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/howard-county/" title="Howard County" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Howard County</strong></div></a><a href="https://baltimore.cbslocal.com/category/health" title="HealthWatch" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://baltimore.cbslocal.com/category/watch-listen/" title="Watch + Listen" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Watch + Listen</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-10" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a></div>
</div></div><div id="embed-list-4" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="https://baltimore.cbslocal.com/category/news/">Latest News</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/2021/06/04/dogecoin-cryptocurrency-explainer/" title="Is Dogecoin A Good Investment? Expert Suggests Avoiding Controversial Cryptocurrency Market" class="cbs-thumbnail-link item-1622845474" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/05/dogecoin-dollar-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Is Dogecoin A Good Investment? Expert Suggests Avoiding Controversial Cryptocurrency Market</strong><em class="description">Dogecoin, which started as a joke, is now worth real money, though the value of the cryptocurrency can vary widely.</em></div></a><a href="https://baltimore.cbslocal.com/2021/06/04/maryland-football-unveils-new-home-for-team-jones-hill-house/" title="Maryland Football Unveils New Home For Team, The Jones-Hill House" class="cbs-thumbnail-link item-1622845335 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/snapshot-2021-06-04T175032.342.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Maryland Football Unveils New Home For Team, The Jones-Hill House</strong><em class="description">Five years and $149 million later, The Jones-Hill House, home of Maryland football is finally here.</em></div></a></div>
</div></div><div id="embed-list-5" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Videos</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-4 aspect-ratio-1-1"><a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=400&#038;h=400&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="https://baltimore.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-6" class="embed-item embed-list column-count-2 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">All Videos</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1394/" title="Purple Connection" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Purple Connection</strong></div></a><a href="https://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a></div>
</div></div><div id="embed-list-7" class="embed-item embed-list enable-type-icons column-count-4 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">WJZ On Demand Video</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-4 aspect-ratio-1-1"><a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=400&#038;h=400&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1480350753" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather</strong></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-8" class="embed-item embed-list column-count-2 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">All Sports</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland Terps" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland Terps</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="https://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="https://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a></div>
</div></div><div id="embed-list-9" class="embed-item embed-list enable-type-icons column-count-4 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Featured Sports</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/2021/06/04/belmont-stakes-2021-preview-rombauer-essential-quality-rock-your-world/" title="Belmont Stakes 2021 Preview: Can Rombauer Repeat Against A Tough Field?" class="cbs-thumbnail-link item-1622842698" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/rombauer-1.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Belmont Stakes 2021 Preview: Can Rombauer Repeat Against A Tough Field?</strong><em class="description">Belmont Stakes is set for early Saturday evening, with Essential Quality as the favorite but Rombauer looking for another win.</em></div></a><a href="https://baltimore.cbslocal.com/2021/06/04/stream-the-wells-fargo-championship/" title="Stream The Memorial Tournament" class="cbs-thumbnail-link item-1622836819" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/MemorialTournament_Local_1200x675.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Stream The Memorial Tournament</strong><em class="description">Watch the Memorial Tournament live from Muirfield Village.</em></div></a><a href="https://baltimore.cbslocal.com/2021/06/04/rashod-bateman-baltimore-ravens-otas-first-impression/" title="Ravens Gushing Over Rashod Bateman&#039;s First Impression At OTAs: &#039;He&#039;s A Very Special Wide Receiver&#039;" class="cbs-thumbnail-link item-1622832622 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/GettyImages-1229702622.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Ravens Gushing Over Rashod Bateman&#039;s First Impression At OTAs: &#039;He&#039;s A Very Special Wide Receiver&#039;</strong><em class="description">The Ravens rookie has impressed fellow players and his coaches thus far in OTAs. </em></div></a><a href="https://baltimore.cbslocal.com/2021/06/04/baltimore-orioles-mlb-best-mascots/" title="Orioles&#039; Mascot Is MLB&#039;s 5th Best, According To Fan Survey" class="cbs-thumbnail-link item-1622825716 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/GettyImages-1169990439.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Orioles&#039; Mascot Is MLB&#039;s 5th Best, According To Fan Survey</strong><em class="description">While Orioles fans don&#039;t have much to cheer for on the field, the team&#039;s mascot is considered one of the league&#039;s best. </em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-10" class="embed-item embed-list column-count-1 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Weather Links</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/school-closings/" title="Maryland School Closings" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Maryland School Closings</strong></div></a><a href="https://baltimore.cbslocal.com/category/weather/weather-blog/" title="Weather Blog" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather Blog</strong></div></a></div>
</div></div><div id="embed-list-11" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Latest Videos</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/video/5656295-bob-turk-has-a-look-at-your-evening-forecast/" title="Bob Turk Has A Look At Your Evening Forecast" class="cbs-thumbnail-link item-1622838540 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/39E/DC7/39EDC75A83E54ED79603DE482BAFF673.jpg?Expires=1717459200&#038;KeyName=mcpkey1&#038;Signature=mQQNjQ7nrG40WLV0FbgyYoYjCpw"></span></div><div class="title-wrapper"><strong class="title">Bob Turk Has A Look At Your Evening Forecast</strong><em class="description">Bob Turk Has A Look At Your Evening Forecast.</em></div><time datetime="2021-06-04T20:29:00+00:00" title="June 4, 2021 at 4:29 pm">2 hours ago</time></a><a href="https://baltimore.cbslocal.com/video/5655406-meteorologist-meg-mcnamara-has-your-friday-afternoon-forecast/" title="Meteorologist Meg McNamara Has Your Friday Afternoon Forecast" class="cbs-thumbnail-link item-1622825040 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/anv-iupl/DBC/B7C/DBCB7CE2EE28432884656713F6BC94BC.jpg?Expires=1717459200&#038;KeyName=mcpkey1&#038;Signature=AwyEXh3ofkXrc42Rww9DZOmZ6g8"></span></div><div class="title-wrapper"><strong class="title">Meteorologist Meg McNamara Has Your Friday Afternoon Forecast</strong><em class="description">Meteorologist Meg McNamara Has Your Friday Afternoon Forecast</em></div><time datetime="2021-06-04T16:44:00+00:00" title="June 4, 2021 at 12:44 pm">6 hours ago</time></a></div>
</div></div><div id="embed-list-12" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Weather Stories</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/2021/06/04/2-confirmed-tornados-touched-down-in-maryland-on-thursday/" title="2 Confirmed Tornados Touched Down In Maryland On Thursday" class="cbs-thumbnail-link item-1622842838 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/snapshot-2021-06-04T174012.248.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">2 Confirmed Tornados Touched Down In Maryland On Thursday</strong><em class="description">The National Weather Service confirmed that a tornado touched down in Jacksonville, MD on Thursday. </em></div></a><a href="https://baltimore.cbslocal.com/2021/06/04/maryland-weather-heavy-damage-in-the-region-after-severe-thursday-weather-isolated-storms-expected-tonight/" title="Maryland Weather: Heavy Damage In The Region After Severe Thursday Weather, Isolated Storms Expected Tonight" class="cbs-thumbnail-link item-1622826050 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/snapshot-4.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Maryland Weather: Heavy Damage In The Region After Severe Thursday Weather, Isolated Storms Expected Tonight</strong><em class="description">Baltimore and Harford County were on severe weather threats Thursday as storms blew through. In the Phoenix and Jacksonville area, the National Weather Service will be on the scene to determine if it was a tornado.</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/only-cbs" title="CBS+" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-13" class="embed-item embed-list enable-type-icons column-count-6 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="https://baltimore.cbslocal.com/category/only-cbs">Latest Entertainment News From ViacomCBS</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/2021/06/04/kennedy-center-honors-cbs/" title="Kennedy Center Honors: Star-Studded Group Of Performers Set To Salute This Year&#039;s Honorees On June 6 On CBS" class="cbs-thumbnail-link item-1622833208" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Kennedy Center Honors: Star-Studded Group Of Performers Set To Salute This Year&#039;s Honorees On June 6 On CBS</strong><em class="description">The annual Kennedy Center Honors are set to air this Sunday on CBS with a packed list of tribute performers.</em></div></a><a href="https://baltimore.cbslocal.com/2021/06/04/floyd-mayweather-logan-paul-pay-per-view-how-to-watch-stream/" title="Floyd Mayweather Vs. Logan Paul: How To Watch, Stream &#039;Bragging Rights&#039; Pay-Per-View" class="cbs-thumbnail-link item-1622828426" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/GettyImages-1232731353.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Floyd Mayweather Vs. Logan Paul: How To Watch, Stream &#039;Bragging Rights&#039; Pay-Per-View</strong><em class="description">Showtime Sports has all the action live for the Floyd Mayweather vs. Logan Paul exhibition match.</em></div></a><a href="https://baltimore.cbslocal.com/2021/06/04/marco-andretti-tony-kanaan-superstar-racing-series/" title="Marco Andretti &amp; Tony Kanaan On Superstar Racing Series: &#039;It&#039;s Totally Cool, Something That I&#039;ve Never Done&#039;" class="cbs-thumbnail-link item-1622810220 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/SRX_Logo_Orange.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Marco Andretti &amp; Tony Kanaan On Superstar Racing Series: &#039;It&#039;s Totally Cool, Something That I&#039;ve Never Done&#039;</strong><em class="description">The two IndyCar veterans are among a wide array of drivers gearing up for the inaugural season of the new series.</em></div></a><a href="https://baltimore.cbslocal.com/2021/06/04/courtney-nichole-assisted-living-bet-tyler-perry/" title="&#039;It&#039;s A Multi-Generational Show&#039;: Courtney Nichole On Season 2 Of BET&#039;s &#039;Assisted Living&#039;" class="cbs-thumbnail-link item-1622809305" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/photo-credit-charles-bergmannbettyler-vision-llc-ep-109-9ujc-e1622807835937.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;It&#039;s A Multi-Generational Show&#039;: Courtney Nichole On Season 2 Of BET&#039;s &#039;Assisted Living&#039;</strong><em class="description">The star of &quot;Assisted Living&quot; on BET previews season two and shares what it is like to work with Tyler Perry.</em></div></a><a href="https://baltimore.cbslocal.com/2021/06/03/david-kamp-sesame-street-interview/" title="&#039;These Shows Established A New Vision Of America&#039;: David Kamp On Book &#039;Sunny Days,&#039; &#039;Sesame Street&#039; &amp; &#039;Mister Rogers&#039; Neighborhood&#039;" class="cbs-thumbnail-link item-1622765981" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/gettyimages-96423905-e1537297720932.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;These Shows Established A New Vision Of America&#039;: David Kamp On Book &#039;Sunny Days,&#039; &#039;Sesame Street&#039; &amp; &#039;Mister Rogers&#039; Neighborhood&#039;</strong><em class="description">Author David Kamp explains in his new book how shows like &quot;Sesame Street&quot; and &quot;Mister Rogers&#039; Neighborhood&quot; changed the fabric of American culture.</em></div></a><a href="https://baltimore.cbslocal.com/2021/06/03/vinny-guadagnino-angelina-pivarnick-jersey-shore-family-vacation/" title="&#039;It Was Like Snooki Never Left&#039;: Vinny Guadagnino &amp; Angelina Pivarnick On MTV&#039;s &#039;Jersey Shore Family Vacation&#039;" class="cbs-thumbnail-link item-1622745056" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/GettyImages-1318553098-e1622720773304.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;It Was Like Snooki Never Left&#039;: Vinny Guadagnino &amp; Angelina Pivarnick On MTV&#039;s &#039;Jersey Shore Family Vacation&#039;</strong><em class="description">Vinny &amp; Angelina preview a brand new season of MTV&#039;s hit show &quot;Jersey Shore Family Vacation&quot; and share what it was like to have Snooki back in the mix.</em></div></a></div>
</div></div></div></div></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Contests &amp; More</strong></div></div><div class="submenu"><div class="wrapper"><div id="embed-list-14" class="embed-item embed-list column-count-1 block-type-wpmenu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="https://baltimore.cbslocal.com/learn-about-us/">Station Info</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="WJZ 13" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">WJZ 13</strong></div></a></div>
</div></div><div id="embed-list-15" class="embed-item embed-list enable-type-icons column-count-2 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="https://baltimore.cbslocal.com/category/travel/">Travel</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/2021/05/31/record-number-of-travelers-expected-to-hit-maryland-roads-this-memorial-day/" title="Record Number Of Travelers Expected To Hit Maryland Roads This Memorial Day" class="cbs-thumbnail-link item-1622471333 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/05/snapshot-2021-05-31T094226.051.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Record Number Of Travelers Expected To Hit Maryland Roads This Memorial Day</strong><em class="description">The holiday weekend saw a record number of Americans traveling since the pandemic first started. </em></div></a><a href="https://baltimore.cbslocal.com/2021/05/28/live-updates-memorial-day-weekend-traffic-bay-bridge-maryland/" title="Maryland Traffic: Busy Bay Bridge, Jam-Packed Waterways, And Flooded Airports On Memorial Day Weekend" class="cbs-thumbnail-link item-1622247353 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/05/snapshot-18.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Maryland Traffic: Busy Bay Bridge, Jam-Packed Waterways, And Flooded Airports On Memorial Day Weekend</strong><em class="description">This weekend is the unofficial start of summer, and after more than a year of Covid hibernation, it seems like many are celebrating by getting out of town. One in four people say they plan on traveling.</em></div></a></div>
</div></div><div id="embed-list-16" class="embed-item embed-list enable-type-icons column-count-1 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Contests</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/2021/05/25/vote-for-wjzs-rick-ritter-as-best-tv-personality-for-baltimore-suns-2021-readers-choice/" title="Vote For WJZ&#039;s Rick Ritter As Best TV Personality For Baltimore Sun&#039;s 2021 Readers’ Choice" class="cbs-thumbnail-link item-1621963769" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/09/Web_Bio_Rick_Ritter.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Vote For WJZ&#039;s Rick Ritter As Best TV Personality For Baltimore Sun&#039;s 2021 Readers’ Choice</strong><em class="description">WJZ&#039;s Rick Ritter is among those nominated in The Baltimore Sun&#039;s 2021 Readers&#039; Choice for Best TV Personality.</em></div></a></div>
</div></div><div id="embed-list-17" class="embed-item embed-list enable-type-icons column-count-1 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><a href="https://baltimore.cbslocal.com/category/best-of/">Best Of</a></h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/2021/04/15/maryland-ranks-no-26-on-list-of-best-states-new-survey-finds/" title="Maryland Ranks No. 26 On List Of Best States, New Survey Finds" class="cbs-thumbnail-link item-1618539653 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2020/05/Maryland-Flag.jpg?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Maryland Ranks No. 26 On List Of Best States, New Survey Finds</strong><em class="description">It&#039;s safe to say, most of us think Maryland is pretty great. We have Ocean City, the Preakness, great sports teams and a lot of history! But how do we compare to the rest of the nation? </em></div></a></div>
</div></div><div id="embed-list-18" class="embed-item embed-list enable-type-icons column-count-1 block-type-grid" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">CBS+</h4></header><div class="block-content-wrapper and-list layout-grid and-columns-3 aspect-ratio-16-9"><a href="http://baltimore.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-1519402862" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/02/CBS.png?w=640&#038;h=360&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a></div>
</div></div></div></div></li></ul></nav>
	<ul id="live"><li class="menu-item item-0"><a href="/live/channel/cbs-baltimore-live-video/" title="WJZ 13" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WJZ 13</strong><em class="description">On Air</em></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-19" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">6:30 PM</strong><em class="description">CBS Evening News with Norah O'Donnell</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">7:00 PM</strong><em class="description">WJZ News @ 7PM</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">7:30 PM</strong><em class="description">Entertainment Tonight</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">8:00 PM</strong><em class="description">Magnum P.I.</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">9:00 PM</strong><em class="description">Magnum P.I.</em></div></div></div>
</div></div><a class="view-all" href="http://baltimore.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	<a href="http://baltimore.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="39.290385" longitude="-76.612189" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://baltimore.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size='[[970,250],[970,66],[728,90]]' data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">&#8216;Time Never Waits&#8217;: Father Of Titus Akins, Teen Killed In Murder-Suicide, Says He Sought To Reconnect With Son</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">June 4, 2021 at 5:18 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://baltimore.cbslocal.com/tag/around-the-nation/">Around The Nation</a></div></div></section><section id="column_block_20" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div class="anvato-iframe-wrapper"><div id="p0"></div></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"5652497","autoplay":true,"titleVisible":false,"accessKey":"5VD6Eyd6djewbCmNwBFnsJj17YAvGRwl","accessControl":{"preview":false},"pInstance":"p0","plugins":{"heartbeat":{"account":"cbslocal-global-unified","publisherId":"cbslocal","jobId":"sc_va","marketingCloudId":"823BA0335567497F7F000101@AdobeOrg","trackingServer":"cbsdigitalmedia.hb.omtrdc.net","customTrackingServer":"cbsdigitalmedia.d1.sc.omtrdc.net","chapterTracking":false,"version":"1.5"},"comscore":{"clientId":"3000023","c3":"Baltimore.cbslocal.com"},"dfp":{"clientSide":{"adTagUrl":"https:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.BALTIMORE&impl=s&gdfp_req=1&env=vp&output=xml_vast4&unviewed_position_start=1&url=[referrer_url]&description_url=https:\/\/baltimore.cbslocal.com&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}},"moat":{"clientSide":{"partnerCode":"cbslocalanvatovideo181732609431"}}},"shareLink":"https:\/\/cbsloc.al\/34NV09x","video-type":"featured","token":"default","expectPreroll":true,"expectPrerollTimeout":5,"recom":true,"maxRecomPages":3});});});</script></div></section>
<div class="main-story-wrapper"><p><strong>FORT WORTH (CBSDFW.COM) &#8211;</strong> The father of a teenager killed in the latest domestic murder-suicide in North Texas said he didn&#8217;t believe the news at first. He said it&#8217;s something you think only happens to other people. As police were still investigating the shooting deaths of a mother and son Tuesday, Wallace Akins received a Facebook message from an old family connection, offering condolences for his loss.</p>
<p>Even when he went to read news reports, he wasn&#8217;t certain what had happened. &#8220;But then, when the names came out, that&#8217;s when it really really hit me,&#8221; Akins said.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://baltimore.cbslocal.com/2021/06/04/dogecoin-cryptocurrency-explainer/" target="_blank">Is Dogecoin A Good Investment? Expert Suggests Avoiding Controversial Cryptocurrency Market</a>
<p>His son, Titus Akins, and his ex-wife, Holly Beverly, were killed in their apartment. It also happened on Titus&#8217; 17th birthday.</p>
<p>The shooter, also dead, has still not been officially identified by the medical examiner or police.</p>
<p>&#8220;I really don&#8217;t know how to feel, because this happens to others, it doesn&#8217;t happen to you. It only happens to other individuals,&#8221; Wallace Akins said.</p><strong style="color: black; float: left; padding-right: 5px;">READ MORE: </strong><a style="display: block; margin-bottom: 25px;" href="https://baltimore.cbslocal.com/2021/06/04/maryland-football-unveils-new-home-for-team-jones-hill-house/" target="_blank">Maryland Football Unveils New Home For Team, The Jones-Hill House</a>
<p>He said he doesn&#8217;t have insight to what may have prompted the murders, admitting he hadn&#8217;t been part of his children&#8217;s lives for several years. Just a weeks ago, however, he felt a strong need to reconnect and reached out to their mother.</p>
<p>&#8220;I wanted to reach out to see how they were doing, and what they were doing because they&#8217;re at that certain age now,&#8221; Wallace Akins said.</p>
<p>Now, the chance will never come for a reconnection between Wallace Akins and his son.</p>
<p>&#8220;One of my children will never be able to and I as a parent will never be able to have any kind of connection,&#8221; Wallace Akins said. &#8220;&#8230; Time never waits, for anybody. It&#8217;s going to keep coming.&#8221;</p><strong style="color: black; float: left; padding-right: 5px;">MORE NEWS: </strong><a style="display: block; margin-bottom: 25px;" href="https://baltimore.cbslocal.com/2021/06/04/2-confirmed-tornados-touched-down-in-maryland-on-thursday/" target="_blank">2 Confirmed Tornados Touched Down In Maryland On Thursday</a>
<p>He said he still hopes to reconnect with his older daughter who was not injured in the incident.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/34NV09x"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/34NV09x"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/34NV09x"></a></span>
			</div>
		
			</div>
</div></div></div><div id="app-promo-wrapper"><a href="https://apps.cbslocal.com/baltimore/" data-ios="https://apps.apple.com/us/app/cbs-baltimore/id1511220375" data-android="https://play.google.com/store/apps/details?id=com.wjz.android.news" target="_blank"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/app-promos/baltimore.jpg"/></a></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size='[[1,5],"fluid"]' data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-21"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size='[[300,250],[300,600],[300,1050]]' data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/CBSBaltimore" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="http://twitter.com/wjz" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="http://youtube.com/user/CBSBaltimore" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="https://www.reddit.com/user/cbsbaltimore" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/wjz-tv/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=baltimore"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://baltimore.cbslocal.com/2021/06/04/baltimore-residents-hire-private-security-to-patrol-federal-hill/" title="Baltimore Residents Hire Private Security To Patrol Federal Hill" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/snapshot-2021-06-02T163150.076.jpg?resize=55%2C55&#038;ssl=1" alt="Baltimore Residents Hire Private Security To Patrol Federal Hill" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/04/baltimore-residents-hire-private-security-to-patrol-federal-hill/" title="Baltimore Residents Hire Private Security To Patrol Federal Hill" class="bump-view" data-bump-view="tp">Baltimore Residents Hire Private Security To Patrol Federal Hill</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/06/04/ocean-city-worker-shortage-seasonal-summer-hires-needed/" title="Ocean City Officials Ask Visitors To Be Patient As They Continue To Struggle With Staffing Hotels, Restaurants And Attractions" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/05/snapshot-2021-05-31T094158.460.jpg?resize=55%2C55&#038;ssl=1" alt="Ocean City Officials Ask Visitors To Be Patient As They Continue To Struggle With Staffing Hotels, Restaurants And Attractions" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/04/ocean-city-worker-shortage-seasonal-summer-hires-needed/" title="Ocean City Officials Ask Visitors To Be Patient As They Continue To Struggle With Staffing Hotels, Restaurants And Attractions" class="bump-view" data-bump-view="tp">Ocean City Officials Ask Visitors To Be Patient As They Continue To Struggle With Staffing Hotels, Restaurants And Attractions</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/06/02/child-tax-credit-amount-how-much-3000-3600/" title="Child Tax Credit: How Much Money Will The Government Pay You Each Month?" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/05/white-house-1-1-1.jpg?resize=55%2C55&#038;ssl=1" alt="Child Tax Credit: How Much Money Will The Government Pay You Each Month?" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/02/child-tax-credit-amount-how-much-3000-3600/" title="Child Tax Credit: How Much Money Will The Government Pay You Each Month?" class="bump-view" data-bump-view="tp">Child Tax Credit: How Much Money Will The Government Pay You Each Month?</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/06/03/maryland-weather-flash-flood-watch-issued-for-baltimore-area-as-storms-roll-in-thursday/" title="Maryland Weather: Flood Warning Issued For Parts Of Baltimore &amp; Harford Counties" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/snapshot-2021-06-03T170722.928.jpg?resize=55%2C55&#038;ssl=1" alt="Maryland Weather: Flood Warning Issued For Parts Of Baltimore &amp; Harford Counties" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/03/maryland-weather-flash-flood-watch-issued-for-baltimore-area-as-storms-roll-in-thursday/" title="Maryland Weather: Flood Warning Issued For Parts Of Baltimore &amp; Harford Counties" class="bump-view" data-bump-view="tp">Maryland Weather: Flood Warning Issued For Parts Of Baltimore &amp; Harford Counties</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/06/03/vax-to-win-maryland-vaccine-lottery-daily-winners/" title="Maryland Vaccine Lottery: Friday&#039;s Winner Is From Howard County" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/05/Maryland-Lottery.jpg?resize=55%2C55&#038;ssl=1" alt="Maryland Vaccine Lottery: Friday&#039;s Winner Is From Howard County" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/03/vax-to-win-maryland-vaccine-lottery-daily-winners/" title="Maryland Vaccine Lottery: Friday&#039;s Winner Is From Howard County" class="bump-view" data-bump-view="tp">Maryland Vaccine Lottery: Friday&#039;s Winner Is From Howard County</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/06/02/gov-hogan-defends-decision-to-end-federal-unemployment-benefits/" title="Gov. Hogan Defends Decision To End Federal Unemployment Benefits" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/05/GettyImages-1219428132.jpg?resize=55%2C55&#038;ssl=1" alt="Gov. Hogan Defends Decision To End Federal Unemployment Benefits" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/02/gov-hogan-defends-decision-to-end-federal-unemployment-benefits/" title="Gov. Hogan Defends Decision To End Federal Unemployment Benefits" class="bump-view" data-bump-view="tp">Gov. Hogan Defends Decision To End Federal Unemployment Benefits</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/06/03/triple-c-gang-members-charged-with-murder/" title="Baltimore Gang Indicted On Racketeering, Drug Trafficking Charges Allegedly Involved In 18 Murders" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/snapshot-2021-06-03T200409.557.jpg?resize=55%2C55&#038;ssl=1" alt="Baltimore Gang Indicted On Racketeering, Drug Trafficking Charges Allegedly Involved In 18 Murders" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/03/triple-c-gang-members-charged-with-murder/" title="Baltimore Gang Indicted On Racketeering, Drug Trafficking Charges Allegedly Involved In 18 Murders" class="bump-view" data-bump-view="tp">Baltimore Gang Indicted On Racketeering, Drug Trafficking Charges Allegedly Involved In 18 Murders</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/06/02/covid-19-in-maryland-cases-fall-below-100-for-1st-time-since-early-days-of-pandemic/" title="COVID-19 In Maryland: Cases Fall Below 100 For 1st Time Since Early Days Of Pandemic" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/GettyImages-1257017490.jpg?resize=55%2C55&#038;ssl=1" alt="COVID-19 In Maryland: Cases Fall Below 100 For 1st Time Since Early Days Of Pandemic" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/02/covid-19-in-maryland-cases-fall-below-100-for-1st-time-since-early-days-of-pandemic/" title="COVID-19 In Maryland: Cases Fall Below 100 For 1st Time Since Early Days Of Pandemic" class="bump-view" data-bump-view="tp">COVID-19 In Maryland: Cases Fall Below 100 For 1st Time Since Early Days Of Pandemic</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/06/02/maryland-to-end-extra-300-in-unemployment-benefits-to-end-july-3/" title="Maryland To End Extra $300 In Unemployment Benefits To End July 3" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/Hotel-Revival.png?resize=55%2C55&#038;ssl=1" alt="Maryland To End Extra $300 In Unemployment Benefits To End July 3" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/02/maryland-to-end-extra-300-in-unemployment-benefits-to-end-july-3/" title="Maryland To End Extra $300 In Unemployment Benefits To End July 3" class="bump-view" data-bump-view="tp">Maryland To End Extra $300 In Unemployment Benefits To End July 3</a>
							</div>
													</li>
										<li>
						<a href="https://baltimore.cbslocal.com/2021/06/02/17-year-old-shot-in-baltimore-county-hotel-room/" title="17-Year-Old Shot In Baltimore County Hotel Room" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/06/snapshot-2021-06-02T230050.887.jpg?resize=55%2C55&#038;ssl=1" alt="17-Year-Old Shot In Baltimore County Hotel Room" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://baltimore.cbslocal.com/2021/06/02/17-year-old-shot-in-baltimore-county-hotel-room/" title="17-Year-Old Shot In Baltimore County Hotel Room" class="bump-view" data-bump-view="tp">17-Year-Old Shot In Baltimore County Hotel Room</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size='[[300,250]]' data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size='[[728,90]]' data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2017/10/baltimore.png" alt="CBS Baltimore" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/CBSBaltimore" class="facebook" target="_blank">Facebook</a><a href="http://twitter.com/wjz" class="twitter" target="_blank">Twitter</a><a href="http://youtube.com/user/CBSBaltimore" class="youtube" target="_blank">YouTube</a><a href="https://www.reddit.com/user/cbsbaltimore" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/wjz-tv/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			<div id="block-0" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">News</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/tag/baltimore-news/" title="Baltimore News" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Baltimore News</strong></div></a><a href="https://baltimore.cbslocal.com/category/weather/" title="Maryland Weather" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Maryland Weather</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/national/" title="National" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">National</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/" title="Local" class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Local</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://baltimore.cbslocal.com//category/health/" title="HealthWatch" class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a></div>
</div></div><div id="block-1" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Sports</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/category/sports/" title="Baltimore Sports" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Baltimore Sports</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/822/" title="Fan Cam" class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Fan Cam</strong></div></a><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-2" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Seen On WJZ</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/video/program/1259/" title="Morning Edition" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a><a href="https://baltimore.cbslocal.com/video/program/677/" title="Manic Monday" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Manic Monday</strong></div></a><a href="https://baltimore.cbslocal.com/category/its-academic/" title="It&#039;s Academic" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">It&#039;s Academic</strong></div></a><a href="https://baltimore.cbslocal.com/category/on-time/" title="On Time" class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">On Time</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-3" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Connect With CBS Baltimore</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/2010/11/24/get-your-news-on-the-go/" title="News On The Go" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">News On The Go</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="Station Info" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Station Info</strong></div></a><a href="https://baltimore.cbslocal.com/contact-us/" title="Contact Us" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-4" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Other</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="CBS+" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">CBS+</strong></div></a><a href="https://baltimore.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://baltimore.cbslocal.com/school-closings/" title="Baltimore School Closings" class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Baltimore School Closings</strong></div></a><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div><div id="block-5" class="embed-item embed-list block-menu" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title">Corporate</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://privacy.cbs/personalizedads" title="Ad Choices" class="cbs-thumbnail-link item-1" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Ad Choices</strong></div></a><div class="cbs-thumbnail-link item-2" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-3" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-4" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div><div class="cbs-thumbnail-link item-5" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div></div></div>
</div></div>		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-viacom-logo-white.png" alt="CBS Baltimore" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2021 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=baltimore.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-207290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207290"><a href="https://privacy.cbs/">Privacy Policy</a></li>
<li id="menu-item-207291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207291"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-839526" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-839526"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-839527" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-839527"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Personal Information</a></li>
<li id="menu-item-533039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-533039"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-745179" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-745179"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/08/qpdc-2018-wjz-tv.pdf">MD Digital Political Ad Disclosures</a></li>
<li id="menu-item-788013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788013"><a href="https://publicfiles.fcc.gov/tv-profile/wjz-tv">Public File for WJZ-TV / WJZ-13</a></li>
<li id="menu-item-788792" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788792"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-906064" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-906064"><a href="https://baltimore.cbslocal.com/fcc-applications/">FCC Applications</a></li>
<li id="menu-item-789850" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-789850"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2021/05/WJZJune2021.doc">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size='[[1,8]]' data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size='[[1,6]]' data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size='[[1,7]]' data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://baltimore.cbslocal.com/wp-admin/admin-ajax.php";
</script>
<link rel='stylesheet' id='screen-css-0' href='https://baltimore.cbslocal.com/_static/??-eJylTlkKgCAQvVDTtGH9RGfRcSjBjTS8fhKdoP7ezsMSgYLP7DPmgx0nJJXABpIWjSd76SqxU6yrk14I1qTcVtrg9z7sp9G/Ryi4KOnXmcKypk8oRu/8LG1u7cUwiGnpxvkGEZNrLQ==' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1622648037g' type='text/css' media='all' />
<script type='text/javascript' src='https://baltimore.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1622051374g'></script>
<script src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1' id='cbs-weather-widget-js'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.7.2' id='cbs-cbs-anvato-js'></script>
<script src='https://stats.wp.com/e-202122.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.8',blog:'162246106',post:'947243',tz:'-4',srv:'baltimore.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246106', '947243' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>