<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://baltimore.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="glen burnie, shell gas station robbery, gas station robbery, ritchie highway, maryland, david hall," />
<meta name="keywords" content="glen burnie, shell gas station robbery, gas station robbery, ritchie highway, maryland, david hall," />
<meta property="fb:pages" content="261323008476" />
<meta name="facebook-domain-verification" content="iiv3w5z7llhkla8zlctcj5kqsjba3k" />
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<title>Glen Burnie Man Charged In Ritchie Highway Shell Gas Station Robbery &#8211; CBS Baltimore</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//wayne.cbslocal.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CBS Baltimore &raquo; Feed" href="https://baltimore.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Baltimore &raquo; Comments Feed" href="https://baltimore.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Baltimore &raquo; Glen Burnie Man Charged In Ritchie Highway Shell Gas Station Robbery Comments Feed" href="https://baltimore.cbslocal.com/2019/10/23/glen-burnie-man-charged-in-ritchie-highway-shell-gas-station-robbery/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/_static/??-eJytUEkOwjAM/BDB4kBpD4i3ZDElqmNHWdTvN7RceoJKnGyPPaMZwxyVFS7IBcoLA2awJisSqwk8W6ruDeUMT5GC6dzaE/xEwmDQbdyYkES77+RIdfScIYir1DYmoZ48j4px3qR2yHFB/XHU6nHyeqCCZj1iWmV2iGqppyLxwI82jRoMa0+KPE//d4XUJi5r3ke4X67drRuGru8XjSy+MA==' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://baltimore.cbslocal.com/_static/??-eJyNy0sKgDAMANELWUNpK27Es9QYVEg/kIh4e+0FxO3wBq5qsGSlrKA7JRLARQwXjAyiN1OPIh18sSMjn2tLIlDjRkYpVY76420L8RuzStNzmmwYnBut9+EBIco5HA==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-custom-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-6' href='https://baltimore.cbslocal.com/_static/??-eJydUu1qwzAMfKG5JrSj7MfYsziySL3IlrGVhrz9lIS2dIFt2b/Tx51Osu2YDXASTGLlghGrhbYaYnBkMw1dSNVG9gNpZWkw0SXXYbFQNTNlPB0UvdifhEICGvycUs4YPBrBmMkJ1p3k7Ir8gfPdeb1wEeCbyiPcMR5ji37lL9BQqGLAiSPudq6hWwQgNNfH8Z7qXqVtq8Rep7TFlclWmQgPMaT92+vFO5T79We8EYmDudE+UbKDfkMXziZzVbR62e1j+3+iK/0svfYDE5d/vO5vunzFMpYgi+WP+N68npvm9HY8nr8A2fog4Q==' type='text/css' media='all' />
<link rel='stylesheet' id='cbs-external-css-css'  href='https://wayne.cbslocal.com/cbs-local-custom-css/global/cbslocal_custom_global.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-8' href='https://baltimore.cbslocal.com/wp-content/mu-plugins/jetpack/css/jetpack.css?m=1565296045g' type='text/css' media='all' />
<script type='text/javascript' src='https://baltimore.cbslocal.com/_static/??-eJy1kNEOwiAMRX9IxJlM44PxWxAqdpYyR5nx78XFB31ymPhUKPeeXqpvvbKRBVi0nCFA0vaYFEVrSCNbyq60uqT7SPcTEi0D8rJLCz3X2M1y9JQ9ctIhukzlxbjJXIoa1++ED/Q1w3B/la8CFdAPRuCnPJNABcPGw/BEfzRUmXeR2Fct5pTZCkZO/wgEVG4sqSqRcWdIOM7bUNF7ikdDdSMGQUtQ/d0bOg8yIV7HgjiEfdNum9WuaTdN9wB14gp1'></script>
<link rel='https://api.w.org/' href='https://baltimore.cbslocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://baltimore.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://baltimore.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.4" />
<link rel='shortlink' href='https://cbsloc.al/2N9hB7l' />
<link rel="alternate" type="application/json+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2019%2F10%2F23%2Fglen-burnie-man-charged-in-ritchie-highway-shell-gas-station-robbery%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://baltimore.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbaltimore.cbslocal.com%2F2019%2F10%2F23%2Fglen-burnie-man-charged-in-ritchie-highway-shell-gas-station-robbery%2F&#038;format=xml" />
			<meta property="fb:pages" content="" />
			
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="Glen Burnie Man Charged In Ritchie Highway Shell Gas Station Robbery" /><meta property="og:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhallmug.png?w=630" /><meta property="og:image:secure_url" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhallmug.png?w=630" /><meta property="og:image:width" content="630" /><meta property="og:image:height" content="354" /><meta property="og:description" content="Anne Arundel County police arrested a Glen Burnie man who allegedly robbed a business at the Shell gas station on Ritchie Highway early Wednesday morning at around 5 a.m. " /><meta property="og:type" content="article" /><meta property="og:url" content="https://baltimore.cbslocal.com/2019/10/23/glen-burnie-man-charged-in-ritchie-highway-shell-gas-station-robbery/" /><meta property="article:published_time" content="2019-10-23T10:45:12+00:00" /><meta property="article:suggested-social-copy" content="Anne Arundel County police arrested a Glen Burnie man who allegedly robbed a business at the Shell gas station on Ritchie Highway early Wednesday morning at around 5 a.m. " /><meta property="article:publisher" content="http://www.facebook.com/CBSBaltimore" /><meta property="article:author" content="http://www.facebook.com/CBSBaltimore" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhallmug.png?w=630"><meta name="twitter:title" content="Glen Burnie Man Charged In Ritchie Highway Shell Gas Station Robbery"/><meta name="twitter:description" content="Anne Arundel County police arrested a Glen Burnie man who allegedly robbed a business at the Shell gas station on Ritchie Highway early Wednesday morning at around 5 a.m. "/><meta name="twitter:site" content="/wjz"/>
<link rel="canonical" href="https://baltimore.cbslocal.com/2019/10/23/glen-burnie-man-charged-in-ritchie-highway-shell-gas-station-robbery/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://baltimore.cbslocal.com/2019/10/23/glen-burnie-man-charged-in-ritchie-highway-shell-gas-station-robbery/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/baltimore.cbslocal.com","url":"https:\/\/baltimore.cbslocal.com","name":"CBS Baltimore","foundingDate":"1941-07-01T14:30:00+00:00","sameAs":"http:\/\/wjz.com","logo":{"@type":"ImageObject","url":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2018\/07\/3_baltimore_cbs13_wjz.png?w=258"}},"url":"https:\/\/baltimore.cbslocal.com\/2019\/10\/23\/glen-burnie-man-charged-in-ritchie-highway-shell-gas-station-robbery\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/baltimore.cbslocal.com\/2019\/10\/23\/glen-burnie-man-charged-in-ritchie-highway-shell-gas-station-robbery\/"},"headline":"Glen Burnie Man Charged In Ritchie Highway Shell Gas Station Robbery","description":"Anne Arundel County police arrested a Glen Burnie man who allegedly robbed a business at the Shell gas station on Ritchie Highway early Wednesday morning at around 5 a.m.\u00a0","image":{"@context":"https:\/\/schema.org","@type":"ImageObject","url":"https:\/\/baltimore.cbslocal.com\/wp-content\/uploads\/sites\/15910056\/2019\/10\/1023davidhallmug.png?w=150"},"keywords":{"0":"Anne Arundel County","1":"Local","2":"News","3":"Syndicated Local","5":"Armed robbery","6":"Glen Burnie","7":"Local TV","8":"Maryland","9":"Maryland News","10":"Robbery","11":"Shell gas station","12":"Talkers","13":"news","14":"Glen Burnie Man Charged In Ritchie Highway Shell Gas Station Robbery"},"datePublished":"2019-10-23T10:45:12+00:00","dateModified":"2019-10-23T10:45:12+00:00","author":{"@type":"Organization","name":"CBS Baltimore"},"video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"WJZ Morning News & Weather Update","description":"WJZ Morning News & Weather Update","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/captures\/B98\/6AD\/B986AD30789841389C6A4CE0E8085E95.jpg?Expires=1666453561&KeyName=mcpkey1&Signature=cI9S4EqkVby3aI2DbA4rnhp3OpA","uploadDate":"2019-10-23","duration":"T1M44S","contentUrl":"https:\/\/baltimore.cbslocal.com\/video\/4195388-wjz-morning-news-weather-update\/","embedUrl":"https:\/\/baltimore.cbslocal.com\/video\/4195388-wjz-morning-news-weather-update\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.BALTIMORE","news",["glenburniemanchargedinritchiehighwayshellgasstationrobbery","post","article","annearundelcounty","local","news","syndicatedlocal","armedrobbery","glenburnie","localtv","maryland","marylandnews","robbery","shellgasstation","talkers","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>
		<script type="text/javascript">
			var formatTracker,marketTracker,masterTracker,stationsTracker,rollupTracker,pageTracker;
			var cbs_evidon_noticecdn_id = "https:\/\/baltimore.cbslocal.com\/wp-content\/themes\/cbs-local\/files\/crownpeak\/sitenotice\/425";
			var cbs_evidon_noticecdn_sitenotice = "https:\/\/baltimore.cbslocal.com\/wp-content\/themes\/cbs-local\/files\/crownpeak\/sitenotice\/";
		</script>
		<script type="text/javascript">(function(id){
			function append(scriptid,url,async){var d=document,sn='script',f=d.getElementsByTagName(sn)[0];if(!f)f=d.head;var s=d.createElement(sn);s.async=!0;s.id=scriptid;s.src=url;f.parentNode.insertBefore(s,f)}
			function getRootDomain(){return 'cbslocal';}
			window.evidon={};window.evidon.id=id;
			var evidoncdn='//c.evidon.com/',cdn="https:\/\/baltimore.cbslocal.com\/wp-content\/themes\/cbs-local\/files\/crownpeak\/",rootDomain='cbslocal',noticecdn=cbs_evidon_noticecdn_sitenotice;
			append('evidon-notice',cbs_evidon_noticecdn_sitenotice+'evidon-sitenotice-tag.js',!1);
			append('evidon-location',evidoncdn+'geo/country.js',!0);
			append('evidon-themes',cbs_evidon_noticecdn_id+'/snthemes.js',!0);
			append('evidon-settings',cbs_evidon_noticecdn_id+'/cbslocal/settings.js',!0);
			window.evidon.priorConsentCallback=function(){
				cbs_j.log('[CPM] priorConsentCallback');
				cbs_j.function_queue("partners-header-js", 'cbs_partners_header_js');
				cbs_j.function_queue("partners-footer-js", 'cbs_partners_footer_js');
			}
		})(425)</script>
		<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=32" sizes="32x32" />
<link rel="icon" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=180" />
<meta name="msapplication-TileImage" content="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/cropped-baltimore-favicon-512.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Anne Arundel County police arrested a Glen Burnie man who allegedly robbed a business at the Shell gas station on Ritchie Highway early Wednesday morning at around 5 a.m. " />
<script>//<![CDATA[
		!function(t,o,e){e=t.createElement(o),t=t.getElementsByTagName(o)[0],e.async=1,e.src="https://untidyrice.com/v2/0/bbrp1jweGIk3YvinQ2xQP9xVRQ9H4y2_c-h04atyes-rzbUS3_RWHfBv0Ar3WF7b6K9SlFNiOpX",t.parentNode.insertBefore(e,t)}(document,"script"),function(t,o){t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)}}(document,window,"script","admiral");!function(t,e,n,a){function o(t){try{return t=localStorage.getItem("v4ac1eiZr0"),t&&t.split(",")[4]>0}catch(e){}return!1}function r(){var a=o();if(a){var r=t[e].pubads();typeof r.setTargeting===n&&r.setTargeting("admiral-engaged","true")}}a=t[e]=t[e]||{},a.cmd=a.cmd||[],typeof a.pubads===n?r():typeof a.cmd.unshift===n?a.cmd.unshift(r):a.cmd.push(r)}(window,"googletag","function");;;;;
	
function cbs_partners_header_js(){cbs_j.log('[PARTNER] Header Function');cbs_j.dom.load_script("cbs-apstag", "//c.amazon-adsystem.com/aax2/apstag.js");cbs_j.dom.load_script("sonobi", "https://mtrx.go.sonobi.com/morpheus.cbslocal.3566.js");cbs_j.dom.load_script("dfp", "//www.googletagservices.com/tag/js/gpt.js");cbs_j.dom.load_script("trak-ga", "https://ssl.google-analytics.com/ga.js");cbs_j.dom.load_script("addthis", "//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ddd05dc24272928");cbs_j.dom.load_script("sharethrough", "//native.sharethrough.com/assets/tag.js");cbs_j.dom.load_script("taboola-pixel", "//cdn.taboola.com/libtrc/cbslocal-sc/tfa.js", function() {window._tfa = window._tfa || []; _tfa.push({ notify: "action",name: "page_view" });});}cbs_j.function_queue.activate_point('partners-header-js');
//]]></script>

</head>

<body class="post-template-default single single-post postid-827380 single-format-standard desktop-display-type  and-temp-wide w-breaking-news"><div id="wrapper" class="body-wrapper">

<div id="breaking-news"><div class="wrapper"><a href="https://baltimore.cbslocal.com/2019/10/23/rep-elijah-cummings-morgan-state-viewing-service-baltimore/" title="WATCH LIVE" class="cbs-thumbnail-link" ><div class="title-wrapper"><strong class="title">WATCH LIVE</strong><em class="description">First Of Services Planned For Rep. Elijah Cummings Begin Wednesday</em></div></a></div></div><div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://baltimore.cbslocal.com" id="header-logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/07/3_baltimore_cbs13_wjz.png?w=258" alt="CBS Baltimore" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://baltimore.cbslocal.com/category/sports/">Sports</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="http://baltimore.cbslocal.com/category/baltimore-gameday-uncensored/" title="Baltimore Gameday Uncensored" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Baltimore Gameday Uncensored</strong></div></a><a href="http://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a>		</div>
	</section>

<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
	
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/1253" title="Drone 13" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Drone 13</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/677/" title="Manic Monday" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Manic Monday</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-1 w-link w-submenu"><a href="https://baltimore.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/news/local/" title="Local News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Local News</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/anne-arundel-county/" title="Anne Arundel County" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Anne Arundel County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-city/" title="Baltimore City" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Baltimore City</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/baltimore-county/" title="Baltimore County" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Baltimore County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/carroll-county/" title="Carroll County" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Carroll County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/harford-county/" title="Harford County" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Harford County</strong></div></a><a href="https://baltimore.cbslocal.com/category/news/local/howard-county/" title="Howard County" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Howard County</strong></div></a><a href="http://baltimore.cbslocal.com/category/health" title="HealthWatch" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a><a href="https://baltimore.cbslocal.com/category/watch-listen/" title="Watch + Listen" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">Watch + Listen</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://baltimore.cbslocal.com/category/news/">Latest News</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/10/23/no-7-maryland-brings-deep-roster-high-hopes-into-season/" title="No. 7 Maryland brings Deep Roster, High Hopes Into Season" class="cbs-thumbnail-link item-1571844063 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2011/05/coach-turgeon.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">No. 7 Maryland brings Deep Roster, High Hopes Into Season</strong></div></a><a href="https://baltimore.cbslocal.com/2019/10/23/vaping-e-cigarettes-task-force-maryland/" title="Maryland Task Force Created To Examine Effects Of Vaping, E-Cigarettes" class="cbs-thumbnail-link item-1571843717 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/08/S112676839.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Maryland Task Force Created To Examine Effects Of Vaping, E-Cigarettes</strong><em class="description">Maryland Comptroller Peter Franchot announced Wednesday the launch of a task force to examine the effects of vaping and e-cigarettes. </em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://baltimore.cbslocal.com/video/" title="Video" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Video</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/1253" title="Drone 13" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Drone 13</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/health-fitness/" title="Health" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/677/" title="Manic Monday" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Manic Monday</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/1259" title="Morning Edition" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-4_column aspect-ratio-1-1" id="" >
		<header class="column-header">
				<h4 class="title">WJZ On Demand Video</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/category/news/" title="News" class="cbs-thumbnail-link item-1480350813" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/wjzlogo.jpg?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">News</strong></div></a><a href="http://baltimore.cbslocal.com/video/category/news-weather/" title="Weather" class="cbs-thumbnail-link item-1480350753" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2016/11/category_weather_500x500.png?w=310&#038;h=310&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="http://baltimore.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/maryland/" title="Maryland" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Maryland</strong></div></a><a href="https://baltimore.cbslocal.com/category/sports/local-ncaa/" title="Local NCAA" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Local NCAA</strong></div></a><a href="http://baltimore.cbslocal.com/category/baltimore-gameday-uncensored/" title="Baltimore Gameday Uncensored" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Baltimore Gameday Uncensored</strong></div></a><a href="http://www.sportsline.com/" title="Odds" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Odds</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-4 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/10/23/no-7-maryland-brings-deep-roster-high-hopes-into-season/" title="No. 7 Maryland brings Deep Roster, High Hopes Into Season" class="cbs-thumbnail-link item-1571844063 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2011/05/coach-turgeon.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">No. 7 Maryland brings Deep Roster, High Hopes Into Season</strong></div></a><a href="https://baltimore.cbslocal.com/2019/10/23/carter-blackburn-navy-tulane-matchup-interview/" title="Navy&#039;s Defensive Line Has Been Key To Success Says Carter Blackburn" class="cbs-thumbnail-link item-1571841635 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/GettyImages-1182131290.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Navy&#039;s Defensive Line Has Been Key To Success Says Carter Blackburn</strong><em class="description">CBS Sports college football announcer Carter Blackburn weighs in on how the Navy Midshipmen have improved defensively this season.</em></div></a><a href="https://baltimore.cbslocal.com/2019/10/23/juan-soto-homers-doubles-as-nats-win-game-1/" title="Juan Soto Homers, Doubles As Nats Win Game 1" class="cbs-thumbnail-link item-1571803427 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/GettyImages-1181119073.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Juan Soto Homers, Doubles As Nats Win Game 1</strong><em class="description">Juan Soto homered onto the train tracks high above the left field wall and hit a two-run double as the Washington Nationals tagged Gerrit Cole and the Houston Astros 5-4 Tuesday night in the World Series opener.</em></div></a><a href="https://baltimore.cbslocal.com/2019/10/22/demone-harris-ravens-practice-squad/" title="Linebacker Demone Harris Signed To Practice Squad After Ravens Help Him Find Lost Engagement Ring" class="cbs-thumbnail-link item-1571797784 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/Demone-Harris.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Linebacker Demone Harris Signed To Practice Squad After Ravens Help Him Find Lost Engagement Ring</strong><em class="description">Linebacker Demone Harris signed with the Ravens on Tuesday, but it&#039;s how it all unfolded that is making headlines. </em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://baltimore.cbslocal.com/category/weather/" title="Weather" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Weather</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Links</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/wjz-radar/" title="Weather Maps" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Weather Maps</strong></div></a><a href="http://baltimore.cbslocal.com/school-closings/" title="Maryland School Closings" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Maryland School Closings</strong></div></a><a href="http://baltimore.cbslocal.com/category/weather/weather-blog/" title="Weather Blog" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Weather Blog</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Videos</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/video/4195308-wednesday-morning-weather-with-chelsea-ingram/" title="Wednesday Morning Weather With Chelsea Ingram" class="cbs-thumbnail-link item-1571829881 content-type-video" ><div class="thumbnail-wrapper no-thumbnail"><span class="balance"><span class="backfill"></span></span></div><div class="title-wrapper"><strong class="title">Wednesday Morning Weather With Chelsea Ingram</strong><em class="description">Partly cloudy with high&#039;s in the mid 60&#039;s.</em></div><time datetime="2019-10-23T11:24:41+00:00" title="October 23, 2019 at 7:24 am">4 hours ago</time></a><a href="https://baltimore.cbslocal.com/video/4195200-bob-turk-has-an-updated-look-at-your-forecast/" title="Bob Turk Has An Updated Look At Your Forecast" class="cbs-thumbnail-link item-1571801104 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net/captures/D2F/DD8/D2FDD8D8090343C5A8D17202C16A9F9C.jpg?Expires=1666453444&#038;KeyName=mcpkey1&#038;Signature=mj_fl4vdorjCMxRyQK58cUMr8q8"></span></div><div class="title-wrapper"><strong class="title">Bob Turk Has An Updated Look At Your Forecast</strong><em class="description">Bob Turk Has An Updated Look At Your Forecast</em></div><time datetime="2019-10-23T03:25:04+00:00" title="October 22, 2019 at 11:25 pm">12 hours ago</time></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Weather Stories</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/10/22/weather-blog-sunshine-is-on-the-way/" title="Weather Blog | Sunshine Is On The Way!" class="cbs-thumbnail-link item-1571795879 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2010/11/bob-turk.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Blog | Sunshine Is On The Way!</strong><em class="description">I think it&#039;s fair to say, that our drought is finally erased, by three copious rainfalls in one week!  </em></div></a><a href="https://baltimore.cbslocal.com/2019/10/22/weather-blog-a-little-gray-today/" title="Weather Blog: A Little Gray Today" class="cbs-thumbnail-link item-1571749142 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2010/11/marty-bass.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Weather Blog: A Little Gray Today</strong><em class="description">A little gray today after yesterday&#039;s almost perfect afternoon.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="http://baltimore.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://baltimore.cbslocal.com/category/best-of/">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/10/22/light-city-2019-epigram-infinity-sculpture/" title="&#039;The User Is The Final Component&#039;: Interactive Art Display For Light City Nears Completion" class="cbs-thumbnail-link item-1571783637 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/infinity-epigram-light-city-brilliant-baltimore-2019.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">&#039;The User Is The Final Component&#039;: Interactive Art Display For Light City Nears Completion</strong><em class="description">In 10 days, Baltimore will be a little brighter, the Inner Harbor beaming with art from groups like Epigram. They&#039;re a group of five Puerto Rican and Argentinian artists.</em></div></a><a href="https://baltimore.cbslocal.com/2019/10/21/baltimore-light-city-ellis-marsalis-iii/" title="Baltimore Artist Ellis Marsalis III Looking Forward To Representing Community At Light City 2019" class="cbs-thumbnail-link item-1571698096 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/ellis-marsalis-iii-light-city.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Baltimore Artist Ellis Marsalis III Looking Forward To Representing Community At Light City 2019</strong><em class="description">Originally from New Orleans, Ellis Marsalis isn&#039;t just any artist -- the Light City photographer is one of the best out there. While art is his passion, it&#039;s his community that drives him.</em></div></a><a href="https://baltimore.cbslocal.com/2019/09/29/craving-soul-food-here-are-baltimores-top-four-options/" title="Craving Soul Food? Here Are Baltimore&#039;s Top Four Options" class="cbs-thumbnail-link item-1569804316 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/09/Ethels_Creole_Kitchen_Photo_3_Enhanced.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Craving Soul Food? Here Are Baltimore&#039;s Top Four Options</strong><em class="description">Hoodline crunched the numbers to find the top soul food outlets in Baltimore, using both Yelp data and our own secret sauce to produce a ranked list of the best spots to fill the bill.</em></div></a><a href="https://baltimore.cbslocal.com/2019/09/28/chatime-makes-federal-hill-debut-with-bubble-tea-and-more/" title="Chatime Makes Federal Hill Debut, With Bubble Tea And More" class="cbs-thumbnail-link item-1569728111 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/09/chatime.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Chatime Makes Federal Hill Debut, With Bubble Tea And More</strong><em class="description">Craving bubble tea? You&#039;re in luck: A new business has opened its doors in Federal Hill.</em></div></a><a href="https://baltimore.cbslocal.com/2019/09/28/treat-yourself-at-baltimores-3-priciest-day-spas/" title="Treat Yourself At Baltimore&#039;s 3 Priciest Day Spas" class="cbs-thumbnail-link item-1569721108 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/09/Four_Seasons.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Treat Yourself At Baltimore&#039;s 3 Priciest Day Spas</strong><em class="description">Looking to try the top day spas around?</em></div></a><a href="https://baltimore.cbslocal.com/2019/09/23/carl-ruiz-dead-baltimore-maryland/" title="Celebrity Chef Carl Ruiz Dead At 44, Last Tweets Feature Maryland Eateries" class="cbs-thumbnail-link item-1569252942 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/09/Carl-Ruiz.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Celebrity Chef Carl Ruiz Dead At 44, Last Tweets Feature Maryland Eateries</strong><em class="description">Celebrity chef Carl Ruiz, best known for his appearances on the Food Network, died suddenly Saturday. He was 44 years old.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-6 w-submenu"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Contests &amp; More</strong></div></div><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="https://baltimore.cbslocal.com/learn-about-us/">Station Info</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="WJZ 13" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">WJZ 13</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://baltimore.cbslocal.com/category/travel/">Travel</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/10/09/maryland-fatal-drunk-driving-accidents-brunch/" title="Maryland Has One Of The Highest Rates Deadly Impaired Driving Accidents During Brunch Hours" class="cbs-thumbnail-link item-1570651087 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/GettyImages-151678874.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Maryland Has One Of The Highest Rates Deadly Impaired Driving Accidents During Brunch Hours</strong><em class="description">Maryland ranks 18th for having an 11.16 percent drunk driving fatality rate during brunch hours of 9 a.m. to 3 p.m., according to QuoteWizard.</em></div></a><a href="https://baltimore.cbslocal.com/2019/09/30/ravens-bwi-southwest-trading-places/" title="Ravens Trade Football Field For Tarmac, Surprise Travelers At BWI" class="cbs-thumbnail-link item-1569881419 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/09/ravens-southwest-takeover-bwi-9.30.19.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Ravens Trade Football Field For Tarmac, Surprise Travelers At BWI</strong><em class="description">Linebacker Patrick Onwuasor and wide receiver Willie Snead, along with Ravens mascot Poe, traded in their jerseys and helmets for security vests and earplugs.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Contests</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/2019/10/07/sign-up-for-the-american-cancer-societys-making-strides-against-breast-cancer/" title="Sign Up For The American Cancer Society&#039;s Making Strides Against Breast Cancer" class="cbs-thumbnail-link item-1570481623" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/Making-Strides-Against-Breast-Cancer-Walk-2019.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Sign Up For The American Cancer Society&#039;s Making Strides Against Breast Cancer</strong><em class="description">Making Strides Against Breast Cancer walks unite communities behind the American Cancer Society&#039;s efforts to save lives from breast cancer. It&#039;s a part of WJZ&#039;s community commitment. </em></div></a><a href="https://baltimore.cbslocal.com/2019/09/18/how-to-get-free-breakfast-on-wjzs-morning-team/" title="How To Get Free Breakfast From WJZ’s Morning Team" class="cbs-thumbnail-link item-1568824541" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/09/1200x1200-Breakfast-On-Us-e1568824475816.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To Get Free Breakfast From WJZ’s Morning Team</strong><em class="description">Start your week off right with FREE breakfast.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-1 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">More</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/only-cbs/" title="CBS Entertainment" class="cbs-thumbnail-link item-1519402862" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/02/onlycbs.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Entertainment</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	<ul id="live"><li class="menu-item item-0"><a href="/live/channel/cbs-baltimore-live-video/" title="WJZ 13" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">WJZ 13</strong><em class="description">On Air</em></div></a><div class="submenu"><div class="wrapper"><div id="embed-list-1" class="embed-item embed-list" ><div class="wrapper">
<header class="partblock__title block-head-wrapper"><h4 class="title"><span>On Air </span> Schedule:</h4></header><div class="block-content-wrapper and-list layout-compact aspect-ratio-16-9"><div class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">11:00 AM</strong><em class="description">The Price Is Right</em></div></div><div class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">12:00 PM</strong><em class="description">WJZ News @ Noon</em></div></div><div class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">12:30 PM</strong><em class="description">The Young and the Restless</em></div></div><div class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">1:30 PM</strong><em class="description">The Bold and the Beautiful</em></div></div><div class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">2:00 PM</strong><em class="description">The Talk</em></div></div></div>
</div></div><a class="view-all" href="http://baltimore.cbslocal.com/program-guide/">View All Programs</a></div></div></li></ul>
	<a href="http://baltimore.cbslocal.com/category/weather/" id="info-weather"><div id="weather-widget-sticker" class="embed-item embed-weather weather-widget-wrap" ><div class="wrapper">
<wx-widget type="current-conditions" latitude="39.290385" longitude="-76.612189" header="false"></wx-widget>
</div></div></a>
	<div id="info-search"><form action="https://baltimore.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Glen Burnie Man Charged In Ritchie Highway Shell Gas Station Robbery</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">October 23, 2019 at 10:45 am</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://baltimore.cbslocal.com/tag/anne-arundel-county/">Anne Arundel County</a>, <a href="https://baltimore.cbslocal.com/tag/armed-robbery/">Armed robbery</a>, <a href="https://baltimore.cbslocal.com/tag/glen-burnie/">Glen Burnie</a>, <a href="https://baltimore.cbslocal.com/tag/local-tv/">Local TV</a>, <a href="https://baltimore.cbslocal.com/tag/maryland/">Maryland</a>, <a href="https://baltimore.cbslocal.com/tag/maryland-news/">Maryland News</a>, <a href="https://baltimore.cbslocal.com/tag/robbery/">Robbery</a>, <a href="https://baltimore.cbslocal.com/tag/shell-gas-station/">Shell gas station</a>, <a href="https://baltimore.cbslocal.com/tag/talkers/">Talkers</a></div></div></section><section id="column_block_2" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  close-btn" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id='p0'></div><script data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4195388&quot;,&quot;autoplay&quot;:true,&quot;titleVisible&quot;:false,&quot;accessKey&quot;:&quot;DVzl9QRzox3ZZsP9bNu5Li3X7obQOnqP&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p0&quot;,&quot;plugins&quot;:{&quot;heartbeat&quot;:{&quot;account&quot;:&quot;cbslocal-global-unified&quot;,&quot;publisherId&quot;:&quot;cbslocal&quot;,&quot;jobId&quot;:&quot;sc_va&quot;,&quot;marketingCloudId&quot;:&quot;823BA0335567497F7F000101@AdobeOrg&quot;,&quot;trackingServer&quot;:&quot;cbsdigitalmedia.hb.omtrdc.net&quot;,&quot;customTrackingServer&quot;:&quot;cbsdigitalmedia.d1.sc.omtrdc.net&quot;,&quot;chapterTracking&quot;:false,&quot;version&quot;:&quot;1.5&quot;},&quot;comscore&quot;:{&quot;clientId&quot;:&quot;3000023&quot;,&quot;c3&quot;:&quot;Baltimore.cbslocal.com&quot;},&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.BALTIMORE&amp;ciu_szs&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=[description_url]&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;featured&quot;}}}},&quot;shareLink&quot;:&quot;https:\/\/cbsloc.al\/2N9hB7l&quot;,&quot;video-type&quot;:&quot;featured&quot;,&quot;token&quot;:&quot;default&quot;,&quot;expectPreroll&quot;:true,&quot;expectPrerollTimeout&quot;:5,&quot;recom&quot;:true,&quot;maxRecomPages&quot;:3}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script></div></section>
<div class="main-story-wrapper"><p><strong>GLEN BURNIE, MD. (WJZ) —</strong> Anne Arundel County police arrested a Glen Burnie man who allegedly robbed a business at the Shell gas station on Ritchie Highway early Wednesday morning at around 5 a.m.</p>
<p>David Carroll Hall, 31, of Glen Burnie, has been charged with robbery, armed robbery, first and second-degree assault, reckless endangerment and theft of $100 to under $1,500.</p>
<div id="attachment_827384" style="width: 250px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-827384" class="size-medium wp-image-827384" src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhall.jpg?w=240" alt="" width="240" height="300" srcset="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhall.jpg 800w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhall.jpg?resize=120,150 120w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhall.jpg?resize=240,300 240w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhall.jpg?resize=768,960 768w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhall.jpg?resize=496,620 496w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhall.jpg?resize=640,800 640w, https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1023davidhall.jpg?resize=512,640 512w" sizes="(max-width: 240px) 100vw, 240px" /><p id="caption-attachment-827384" class="wp-caption-text"><em>Credit: Anne Arundel County Police</em></p></div>
<p>Police said a man entered the store, implied he had a weapon and then tried to remove property from the store. The store manager intervened and the suspect fled toward the back of the business.</p>
<p>A responding officer saw someone on Allen Road who matched Hall&#8217;s description and began to pursue him on foot.</p>
<p>Hall then tried to run but officers grabbed him after a short pursuit and arrested him. He was taken to Northern District for processing.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/2N9hB7l"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/2N9hB7l"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/2N9hB7l"></a></span>
			</div>
		
			</div>
</div></div></div><div id="more-links" class="embed-item embed-list" ><div class="wrapper">
<div class="block-content-wrapper and-list layout-catalog aspect-ratio-16-9"><a href="https://baltimore.cbslocal.com/2019/10/23/sex-offenders-sue-sheriff-over-no-trick-or-treat-signs-ahead-halloween/" title="Sex Offenders Sue Sheriff Over &#039;No Trick-Or-Treat&#039; Signs Ahead of Halloween" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Sex Offenders Sue Sheriff Over &#039;No Trick-Or-Treat&#039; Signs Ahead of Halloween</strong></div></a><a href="https://baltimore.cbslocal.com/2019/10/23/no-7-maryland-brings-deep-roster-high-hopes-into-season/" title="No. 7 Maryland brings Deep Roster, High Hopes Into Season" class="cbs-thumbnail-link item-1 content-type-video" ><div class="title-wrapper"><strong class="title">No. 7 Maryland brings Deep Roster, High Hopes Into Season</strong></div></a><a href="https://baltimore.cbslocal.com/2019/10/23/vaping-e-cigarettes-task-force-maryland/" title="Maryland Task Force Created To Examine Effects Of Vaping, E-Cigarettes" class="cbs-thumbnail-link item-2 content-type-video" ><div class="title-wrapper"><strong class="title">Maryland Task Force Created To Examine Effects Of Vaping, E-Cigarettes</strong></div></a><a href="https://baltimore.cbslocal.com/2019/10/23/maryland-senate-president-mike-miller-expected-to-discuss-health-future-amid-cancer-battle/" title="Maryland Senate President Mike Miller Expected To Discuss Health, Future Amid Cancer Battle" class="cbs-thumbnail-link item-3 content-type-video" ><div class="title-wrapper"><strong class="title">Maryland Senate President Mike Miller Expected To Discuss Health, Future Amid Cancer Battle</strong></div></a></div>
</div></div><a href="#" id="enable-comments-button" class="generic-button-v1" onclick="document.getElementById('story-comments').style.display=(document.getElementById('story-comments').style.display==='block')?'none':'block';return false;">Comments</a>
	<style>
	#comments .comments-title,
	#comments #respond #reply-title {
		color: black;
		font-size: 16px;
		font-weight: normal;
		margin-bottom: 20px;
	}
	#comments a:hover {
		text-decoration: underline;
	}
	#comments .comment-list,
	#comments .comment-list .children {
		list-style: none;
		margin: 0;
	}
		#comments .comment-list .comment {
			border-top: 1px solid #eaeaea;
			padding: 20px 10px;
		}
			#comments .comment-list .comment .comment-body {
				color: black;
				font-size: 13px;
				position: relative;
			}
				#comments .comment-list .comment .comment-body p {
					margin: 5px 0 7px 0;
					overflow: hidden;
					padding: 0;
				}
			#comments .comment-list .comment .comment-author .avatar {
				float: left;
				height: 42px;
				margin-bottom: 10px;
				margin-right: 15px;
				width: 42px;
			}
			#comments .comment-list .comment .comment-author .fn {
				color: black;
				font-size: 13px;
				font-style: normal;
				font-weight: bold;
			}
			#comments .comment-list .comment .comment-author .says {
				display: none;
			}

			#comments .comment-list .comment .comment-meta {
				position: absolute;
				right: 0;
				top: 0;
			}
			#comments .comment-list .comment .reply {
				margin-left: 57px;
			}
			#comments .comment-list .comment .comment-meta a,
			#comments .comment-list .comment .reply a {
				color: #808080;
				font-size: 11px;
			}
				#comments .comment-list:hover .comment .comment-meta a,
				#comments .comment-list:hover .comment .reply a {
					color: #333;
				}
			#comments .comment-list .comment .reply .safe-comments-report-link:last-of-type {
				display: none;
			}
	#comments .comment-list .children {
		margin-left: 20px;
		margin-top: 20px;
	}
		#comments .comment-list .children .comment {
			border-top: none;
			padding-right: 0;
			padding-top: 0;
		}

	#comments #reply-title a {
		color: black;
		font-size: 13px;
		padding: 0 5px;
	}
		#comments #reply-title small a {
			font-weight: normal;
		}
	



</style>

<div class="commenting-container">
	<a name="comments" class="comments-location-beacon"></a>
	<section id="story-comments" class="column-item">

		<div id="comments" class="comments-area">

			
							<p class="must-log-in">You must <a href="https://baltimore.cbslocal.com/wp-login.php?redirect_to=https%3A%2F%2Fbaltimore.cbslocal.com%2F2019%2F10%2F23%2Fglen-burnie-man-charged-in-ritchie-highway-shell-gas-station-robbery%2F%23respond">log in</a> to post a comment.</p>			
		</div>

	</section>
</div>
<div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected" data-ad_targets={"strnativekey":"d3da4d50"}><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-3"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="http://www.facebook.com/CBSBaltimore" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="http://twitter.com/wjz" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a><a href="http://youtube.com/user/CBSBaltimore" target="_blank" title="youtube_url" class="cbs-thumbnail-link youtube_url" ><div class="title-wrapper"><strong class="title">youtube_url</strong></div></a><a href="https://www.reddit.com/user/cbsbaltimore" target="_blank" title="reddit_url" class="cbs-thumbnail-link reddit_url" ><div class="title-wrapper"><strong class="title">reddit_url</strong></div></a><a href="https://www.linkedin.com/company/wjz-tv/" target="_blank" title="linkedin_url" class="cbs-thumbnail-link linkedin_url" ><div class="title-wrapper"><strong class="title">linkedin_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_cbs_newsletter_widget"><h3 class="title">Our | Newsletter</h3><div class="widget-content-wrapper"><iframe id="newsletter-widget-iframe" width="300" src="https://bh-ems-static-content.s3.amazonaws.com/cbsi/2706/cbs_local_form_f.html?market=baltimore"></iframe></div></div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
												<a href="https://baltimore.cbslocal.com/2019/10/21/ghost-sighting-baltimore-berthas-mussels/" title="Could This Be The Ghost Of A Little Girl? Spooky Sighting Caught On Cam In Baltimore&#039;s Fell&#039;s Point" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/73141824_2758069124212416_8068459312395059200_n.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Could This Be The Ghost Of A Little Girl? Spooky Sighting Caught On Cam In Baltimore&#039;s Fell&#039;s Point" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/10/21/ghost-sighting-baltimore-berthas-mussels/" class="bump-view" data-bump-view="tp">
								Could This Be The Ghost Of A Little Girl? Spooky Sighting Caught On Cam In Baltimore&#039;s Fell&#039;s Point							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/10/22/kayla-perry-charles-street-towson-crash-latest/" title="17-Year-Old Carver Center Student Kayla Perry Killed After Towson Crash" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/20191022_103436.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="17-Year-Old Carver Center Student Kayla Perry Killed After Towson Crash" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/10/22/kayla-perry-charles-street-towson-crash-latest/" class="bump-view" data-bump-view="tp">
								17-Year-Old Carver Center Student Kayla Perry Killed After Towson Crash							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/10/22/ocean-city-maryland-man-vs-food-fish-tales-dolles-candyland-justines-ice-cream/" title="3 Ocean City Eateries Featured On &#039;Man Vs. Food&#039;" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/dollesclearbox_1.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="3 Ocean City Eateries Featured On &#039;Man Vs. Food&#039;" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/10/22/ocean-city-maryland-man-vs-food-fish-tales-dolles-candyland-justines-ice-cream/" class="bump-view" data-bump-view="tp">
								3 Ocean City Eateries Featured On &#039;Man Vs. Food&#039;							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/10/21/the-horse-you-came-in-on-saloon-named-most-haunted-restaurant-in-maryland/" title="Baltimore&#039;s &#039;The Horse You Came In On Saloon&#039; Named Most Haunted Restaurant In Maryland By Food Network" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i0.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/01/thehorseyoucameinonsaloon.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Baltimore&#039;s &#039;The Horse You Came In On Saloon&#039; Named Most Haunted Restaurant In Maryland By Food Network" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/10/21/the-horse-you-came-in-on-saloon-named-most-haunted-restaurant-in-maryland/" class="bump-view" data-bump-view="tp">
								Baltimore&#039;s &#039;The Horse You Came In On Saloon&#039; Named Most Haunted Restaurant In Maryland By Food Network							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/10/22/1-person-killed-in-fatal-accident-in-frederick/" title="1 Person Killed In Fatal Accident In Frederick" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/07/crash.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="1 Person Killed In Fatal Accident In Frederick" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/10/22/1-person-killed-in-fatal-accident-in-frederick/" class="bump-view" data-bump-view="tp">
								1 Person Killed In Fatal Accident In Frederick							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/10/22/demone-harris-ravens-practice-squad/" title="Linebacker Demone Harris Signed To Practice Squad After Ravens Help Him Find Lost Engagement Ring" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i1.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/Demone-Harris.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Linebacker Demone Harris Signed To Practice Squad After Ravens Help Him Find Lost Engagement Ring" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/10/22/demone-harris-ravens-practice-squad/" class="bump-view" data-bump-view="tp">
								Linebacker Demone Harris Signed To Practice Squad After Ravens Help Him Find Lost Engagement Ring							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/10/22/atf-offering-5k-reward-for-information-on-charles-county-fugitive/" title="ATF Offering $5K Reward For Information On Charles County Fugitive" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/1022atfdeanteduckettmug.png?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="ATF Offering $5K Reward For Information On Charles County Fugitive" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/10/22/atf-offering-5k-reward-for-information-on-charles-county-fugitive/" class="bump-view" data-bump-view="tp">
								ATF Offering $5K Reward For Information On Charles County Fugitive							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/10/22/northeast-high-forfeits-football-games-ineligible-player/" title="Northeast High Forfeits First 3 Football Games, Including Victory, After Using Ineligible Player" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2014/09/fall-sports.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="Northeast High Forfeits First 3 Football Games, Including Victory, After Using Ineligible Player" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/10/22/northeast-high-forfeits-football-games-ineligible-player/" class="bump-view" data-bump-view="tp">
								Northeast High Forfeits First 3 Football Games, Including Victory, After Using Ineligible Player							</a>
						</div>
												</li>
										<li>
												<a href="https://baltimore.cbslocal.com/2019/10/22/62-year-old-man-reported-missing-from-perry-hall/" title="62-Year-Old Perry Hall Man Found Safe" class="bump-view" data-bump-view="tp">
							<img width="55" height="55" src="https://i2.wp.com/baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/10/richard_vosburg_missing_2.jpg?resize=55%2C55&#038;ssl=1" class='widgets-list-layout-blavatar' alt="62-Year-Old Perry Hall Man Found Safe" data-pin-nopin="true" />
						</a>
						<div class="widgets-list-layout-links">
							<a href="https://baltimore.cbslocal.com/2019/10/22/62-year-old-man-reported-missing-from-perry-hall/" class="bump-view" data-bump-view="tp">
								62-Year-Old Perry Hall Man Found Safe							</a>
						</div>
												</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2017/10/baltimore.png" alt="CBS Baltimore" /></a>							<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="http://www.facebook.com/CBSBaltimore" class="facebook" target="_blank">Facebook</a><a href="http://twitter.com/wjz" class="twitter" target="_blank">Twitter</a><a href="http://youtube.com/user/CBSBaltimore" class="youtube" target="_blank">YouTube</a><a href="https://www.reddit.com/user/cbsbaltimore" class="reddit" target="_blank">Reddit</a><a href="https://www.linkedin.com/company/wjz-tv/" class="linkedin" target="_blank">LinkedIn</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/news/" title="Baltimore News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore News</strong></div></a><a href="https://baltimore.cbslocal.com/category/weather/" title="Maryland Weather" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Maryland Weather</strong></div></a><a href="http://baltimore.cbslocal.com/category/news/national/" title="National" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">National</strong></div></a><a href="http://baltimore.cbslocal.com/category/news/local/" title="Local" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Local</strong></div></a><a href="http://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="/category/health/" title="HealthWatch" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">HealthWatch</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/sports/" title="Baltimore Sports" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Baltimore Sports</strong></div></a><a href="http://baltimore.cbslocal.com/category/sports/ravens/" title="Ravens" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ravens</strong></div></a><a href="http://baltimore.cbslocal.com/category/sports/orioles/" title="Orioles" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Orioles</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/822/" title="Fan Cam" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Fan Cam</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-2" >
		<header class="column-header">
				<h4 class="title">Seen On WJZ</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/video/program/1259/" title="Morning Edition" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Morning Edition</strong></div></a><a href="http://baltimore.cbslocal.com/video/program/677/" title="Manic Monday" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Manic Monday</strong></div></a><a href="http://baltimore.cbslocal.com/category/its-academic/" title="It&#039;s Academic" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">It&#039;s Academic</strong></div></a><a href="http://baltimore.cbslocal.com/category/on-time/" title="On Time" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">On Time</strong></div></a><a href="http://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-3" >
		<header class="column-header">
				<h4 class="title">Connect With CBS Baltimore</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/2010/11/24/get-your-news-on-the-go/" title="News On The Go" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">News On The Go</strong></div></a><a href="https://baltimore.cbslocal.com/station/wjz-13/" title="Station Info" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Station Info</strong></div></a><a href="https://baltimore.cbslocal.com/contact-us/" title="Contact Us" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-4" >
		<header class="column-header">
				<h4 class="title">Other</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://baltimore.cbslocal.com/category/news/entertainment/" title="Entertainment" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://baltimore.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="https://baltimore.cbslocal.com/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://baltimore.cbslocal.com/school-closings/" title="Baltimore School Closings" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Baltimore School Closings</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-5" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://baltimore.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="http://policies.cbslocal.com/privacy/current.html#onlinead" title="Ad Choices" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Ad Choices</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://baltimore.cbslocal.com" class="logo"><img src="https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Baltimore" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2019 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=baltimore.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://policies.cbslocal.com/privacy/current.html#video-services" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-207290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207290"><a href="http://policies.cbslocal.com/privacy/current.html">Privacy Policy</a></li>
<li id="menu-item-207291" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-207291"><a href="http://policies.cbslocal.com/terms-of-use/">Terms of Use</a></li>
<li id="menu-item-533038" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-533038"><a href="http://policies.cbslocal.com/privacy/current.html#cali-visitors">Your California Privacy Rights</a></li>
<li id="menu-item-533039" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-533039"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-745179" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-745179"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2018/08/qpdc-2018-wjz-tv.pdf">MD Digital Political Ad Disclosures</a></li>
<li id="menu-item-788013" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788013"><a href="https://publicfiles.fcc.gov/tv-profile/wjz-tv">Public File for WJZ-TV / WJZ-13</a></li>
<li id="menu-item-788792" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-788792"><a href="https://policies.cbslocal.com/fcc/contactusfcc.html">Public Inspection File Help</a></li>
<li id="menu-item-789850" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-789850"><a href="https://baltimore.cbslocal.com/wp-content/uploads/sites/15910056/2019/05/wjz_fcc-eeo-report-june2019.pdf">EEO Report</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='screen-css-0' href='https://baltimore.cbslocal.com/_static/??-eJyljFsKgCAQRTeUDWJGP9FadBxK8EUabr8hWkH93de50IvAnBqlBu2gSBXQVhEymgA+YbgcRxQtOW7qK0XwtY1sB/jOMxeLwV8/nQyvT9G92+l52uIq9azUIqdJ3zLlUXQ=' type='text/css' media='screen' />
<link rel='stylesheet' id='all-css-0' href='https://baltimore.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563381445g' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201943'></script>
<script type='text/javascript' src='https://baltimore.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1571091562g'></script>
<script type='text/javascript' src='https://widgets.media.weather.com/wxwidget.loader.js?cid=934888385&#038;ver=1.1'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-201943.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.8',blog:'162246106',post:'827380',tz:'-4',srv:'baltimore.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162246106', '827380' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>